rebuilt with cmake [release 1.3.7-2mamba;Tue May 09 2023]
This commit is contained in:
parent
5a9d7220ec
commit
6f2ab9f5ea
20
libvorbis-1.3.7-soname.patch
Normal file
20
libvorbis-1.3.7-soname.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- libvorbis-1.3.7/lib/CMakeLists.txt.orig 2020-04-15 18:20:52.000000000 +0200
|
||||
+++ libvorbis-1.3.7/lib/CMakeLists.txt 2023-05-09 12:34:57.295329566 +0200
|
||||
@@ -79,11 +79,14 @@
|
||||
add_library(vorbisfile ${VORBISFILE_SOURCES})
|
||||
|
||||
get_version_info(VORBIS_VERSION_INFO "V_LIB_CURRENT" "V_LIB_AGE" "V_LIB_REVISION")
|
||||
- set_target_properties(vorbis PROPERTIES SOVERSION ${VORBIS_VERSION_INFO})
|
||||
+ set_target_properties(vorbis PROPERTIES SOVERSION "0")
|
||||
+ set_target_properties(vorbis PROPERTIES VERSION ${VORBIS_VERSION_INFO})
|
||||
get_version_info(VORBISENC_VERSION_INFO "VE_LIB_CURRENT" "VE_LIB_AGE" "VE_LIB_REVISION")
|
||||
- set_target_properties(vorbisenc PROPERTIES SOVERSION ${VORBISENC_VERSION_INFO})
|
||||
+ set_target_properties(vorbisenc PROPERTIES SOVERSION "2")
|
||||
+ set_target_properties(vorbisenc PROPERTIES VERSION ${VORBISENC_VERSION_INFO})
|
||||
get_version_info(VORBISFILE_VERSION_INFO "VF_LIB_CURRENT" "VF_LIB_AGE" "VF_LIB_REVISION")
|
||||
- set_target_properties(vorbisfile PROPERTIES SOVERSION ${VORBISFILE_VERSION_INFO})
|
||||
+ set_target_properties(vorbisfile PROPERTIES SOVERSION "3")
|
||||
+ set_target_properties(vorbisfile PROPERTIES VERSION ${VORBISFILE_VERSION_INFO})
|
||||
|
||||
target_include_directories(vorbis
|
||||
PUBLIC
|
@ -1,21 +1,21 @@
|
||||
Name: libvorbis
|
||||
Version: 1.3.7
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: A general purpose public domain audio and music encoding format
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Aleph0 <aleph0@openmamba.org>
|
||||
URL: http://www.vorbis.com
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://xiph.org/vorbis/
|
||||
Source: http://downloads.xiph.org/releases/vorbis/libvorbis-%{version}.tar.gz
|
||||
Patch0: libvorbis-1.3.4-pkg-config.patch
|
||||
Patch1: libvorbis-1.3.7-soname.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libogg-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: pkgconfig
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: cmake
|
||||
|
||||
%description
|
||||
The libvorbis package contains a general purpose audio and music encoding format.
|
||||
@ -24,37 +24,33 @@ This is useful for creating (encoding) and playing (decoding) sound in a public
|
||||
%package devel
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: libogg-devel
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The libvorbis package contains a general purpose audio and music encoding format.
|
||||
This is useful for creating (encoding) and playing (decoding) sound in a public domain format.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
%patch 1 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%cmake -d build
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
rm -fr pckdocs
|
||||
%makeoldinstall \
|
||||
docdir=%{_builddir}/%{name}-%{version}/pckdocs
|
||||
|
||||
rm -f %{buildroot}%{_libdir}/*.a
|
||||
%makeinstall -C build
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
@ -66,21 +62,23 @@ rm -f %{buildroot}%{_libdir}/*.a
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/aclocal/*
|
||||
%dir %{_includedir}/vorbis
|
||||
%{_includedir}/vorbis/*.h
|
||||
%{_libdir}/libvorbis.so
|
||||
%{_libdir}/libvorbisenc.so
|
||||
%{_libdir}/libvorbisfile.so
|
||||
%{_libdir}/libvorbis.la
|
||||
%{_libdir}/libvorbisenc.la
|
||||
%{_libdir}/libvorbisfile.la
|
||||
%{_libdir}/pkgconfig/vorbis.pc
|
||||
%{_libdir}/pkgconfig/vorbisenc.pc
|
||||
%{_libdir}/pkgconfig/vorbisfile.pc
|
||||
%dir %{_includedir}/vorbis
|
||||
%{_includedir}/vorbis/*.h
|
||||
%doc pckdocs/*
|
||||
%dir %{_libdir}/cmake/Vorbis
|
||||
%{_libdir}/cmake/Vorbis/Vorbis*.cmake
|
||||
|
||||
#%doc pckdocs/*
|
||||
|
||||
%changelog
|
||||
* Tue May 09 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.7-2mamba
|
||||
- rebuilt with cmake
|
||||
|
||||
* Wed Jul 22 2020 Automatic Build System <autodist@mambasoft.it> 1.3.7-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user