rebuilt by autoport with build requirements: libxen-devel>=4.18.0-1mamba [release 10.1.0-2mamba;Thu Mar 21 2024]
This commit is contained in:
parent
b4d2aa8ef7
commit
e004f901e0
@ -1,13 +0,0 @@
|
||||
--- libvirt-1.0.5.orig/src/lxc/lxc_monitor_protocol.x 2013-03-19 05:58:31.000000000 +0100
|
||||
+++ libvirt-1.0.5/src/lxc/lxc_monitor_protocol.x 2013-05-29 10:25:03.534046146 +0200
|
||||
@@ -4,6 +4,10 @@
|
||||
* the libvirt_lxc helper program.
|
||||
*/
|
||||
|
||||
+%#ifdef HAVE_XDR_U_INT64_T
|
||||
+%# define xdr_uint64_t xdr_u_int64_t
|
||||
+%#endif
|
||||
+
|
||||
enum virLXCMonitorExitStatus {
|
||||
VIR_LXC_MONITOR_EXIT_STATUS_ERROR,
|
||||
VIR_LXC_MONITOR_EXIT_STATUS_SHUTDOWN,
|
@ -1,115 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
# the following is the LSB init header see
|
||||
# http://www.linux-foundation.org/spec//booksets/LSB-Core-generic/LSB-Core-generic.html#INITSCRCOMCONV
|
||||
#
|
||||
### BEGIN INIT INFO
|
||||
# Provides: libvirtd
|
||||
# Required-Start: $network messagebus
|
||||
# Should-Start: $named
|
||||
# Should-Start: xend
|
||||
# Should-Start: hal
|
||||
# Should-Start: avahi
|
||||
# Required-Stop: $network messagebus
|
||||
# Should-Stop: $named
|
||||
# Default-Start: 3 4 5
|
||||
# Short-Description: daemon for libvirt virtualization API
|
||||
# Description: This is a daemon for managing guest instances
|
||||
# and libvirt virtual networks
|
||||
# See http://libvirt.org
|
||||
### END INIT INFO
|
||||
|
||||
# the following is chkconfig init header
|
||||
#
|
||||
# libvirtd: guest and virtual network management daemon
|
||||
#
|
||||
# chkconfig: 345 97 03
|
||||
# description: This is a daemon for managing guest instances
|
||||
# and libvirt virtual networks
|
||||
# See http://libvirt.org
|
||||
#
|
||||
# processname: libvirtd
|
||||
# pidfile: /var/run/libvirtd.pid
|
||||
#
|
||||
|
||||
# Sanity checks.
|
||||
[ -x /usr/sbin/libvirtd ] || exit 0
|
||||
|
||||
# Source function library.
|
||||
. /etc/rc.d/init.d/functions
|
||||
|
||||
SERVICE=libvirtd
|
||||
PROCESS=libvirtd
|
||||
|
||||
LIBVIRTD_CONFIG=
|
||||
LIBVIRTD_ARGS=
|
||||
KRB5_KTNAME=/etc/libvirt/krb5.tab
|
||||
|
||||
test -f /etc/sysconfig/libvirtd && . /etc/sysconfig/libvirtd
|
||||
|
||||
LIBVIRTD_CONFIG_ARGS=
|
||||
if [ -n "$LIBVIRTD_CONFIG" ]
|
||||
then
|
||||
LIBVIRTD_CONFIG_ARGS="--config $LIBVIRTD_CONFIG"
|
||||
fi
|
||||
|
||||
RETVAL=0
|
||||
|
||||
start() {
|
||||
echo -n $"Starting $SERVICE daemon: "
|
||||
mkdir -p /var/cache/libvirt
|
||||
rm -rf /var/cache/libvirt/*
|
||||
KRB5_KTNAME=$KRB5_KTNAME daemon --check $SERVICE $PROCESS --daemon $LIBVIRTD_CONFIG_ARGS $LIBVIRTD_ARGS
|
||||
RETVAL=$?
|
||||
echo
|
||||
[ $RETVAL -eq 0 ] && touch /var/lock/subsys/$SERVICE
|
||||
}
|
||||
|
||||
stop() {
|
||||
echo -n $"Stopping $SERVICE daemon: "
|
||||
|
||||
killproc $PROCESS
|
||||
RETVAL=$?
|
||||
echo
|
||||
if [ $RETVAL -eq 0 ]; then
|
||||
rm -f /var/lock/subsys/$SERVICE
|
||||
rm -f /var/run/$SERVICE.pid
|
||||
rm -rf /var/cache/libvirt/*
|
||||
fi
|
||||
}
|
||||
|
||||
restart() {
|
||||
stop
|
||||
start
|
||||
}
|
||||
|
||||
reload() {
|
||||
echo -n $"Reloading $SERVICE configuration: "
|
||||
|
||||
killproc $PROCESS -HUP
|
||||
RETVAL=$?
|
||||
echo
|
||||
return $RETVAL
|
||||
}
|
||||
|
||||
# See how we were called.
|
||||
case "$1" in
|
||||
start|stop|restart|reload)
|
||||
$1
|
||||
;;
|
||||
status)
|
||||
status $PROCESS
|
||||
RETVAL=$?
|
||||
;;
|
||||
force-reload)
|
||||
reload
|
||||
;;
|
||||
condrestart|try-restart)
|
||||
[ -f /var/lock/subsys/$SERVICE ] && restart || :
|
||||
;;
|
||||
*)
|
||||
echo $"Usage: $0 {start|stop|status|restart|condrestart|reload}"
|
||||
exit 1
|
||||
;;
|
||||
esac
|
||||
exit $RETVAL
|
24
libvirt.spec
24
libvirt.spec
@ -3,7 +3,7 @@
|
||||
|
||||
Name: libvirt
|
||||
Version: 10.1.0
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: Virtualization API
|
||||
Group: Development/Libraries
|
||||
Vendor: openmamba
|
||||
@ -12,8 +12,6 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://libvirt.org
|
||||
Source0: http://libvirt.org/sources/libvirt-%{version}.tar.xz
|
||||
Source1: libvirt.sysconfig
|
||||
Source2: libvirt.initscript
|
||||
Patch0: libvirt-1.0.5-tirpc.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -49,7 +47,7 @@ BuildRequires: libyajl-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libwireshark-devel >= 4.2.0-2mamba
|
||||
%ifarch %{ix86} x86_64
|
||||
BuildRequires: libxen-devel >= 4.17.2-1mamba
|
||||
BuildRequires: libxen-devel >= 4.18.0-1mamba
|
||||
BuildRequires: libsmbios-devel
|
||||
%endif
|
||||
BuildRequires: libyajl-devel
|
||||
@ -86,7 +84,6 @@ This package contains static libraries and header files needed for development.
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#% patch0 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -94,20 +91,6 @@ This package contains static libraries and header files needed for development.
|
||||
-Dinit_script=systemd \
|
||||
-Dqemu_user=%{qemu_user} \
|
||||
-Dqemu_group=%{qemu_group}
|
||||
|
||||
#CPPFLAGS="%{optflags} -I%{_inclduedir}/tirpc" \
|
||||
#CFLAGS="%{optflags} -I%{_includedir}/tirpc" \
|
||||
#% configure \
|
||||
#%ifnarch arm
|
||||
# --with-xen \
|
||||
#%endif
|
||||
# --with-systemd-daemon \
|
||||
# --with-init-script=systemd \
|
||||
# --with-qemu-user=%{qemu_user} \
|
||||
# --with-qemu-group=%{qemu_group} \
|
||||
# --without-wireshark-dissector
|
||||
|
||||
# --with-remote-pid-file=%{_localstatedir}/run/libvirtd.pid \
|
||||
|
||||
%meson_build
|
||||
|
||||
@ -338,6 +321,9 @@ rm -f %{buildroot}%{_libdir}/*.a
|
||||
%{_mandir}/man7/virkeyname-*.7*
|
||||
|
||||
%changelog
|
||||
* Thu Mar 21 2024 Automatic Build System <autodist@mambasoft.it> 10.1.0-2mamba
|
||||
- rebuilt by autoport with build requirements: libxen-devel>=4.18.0-1mamba
|
||||
|
||||
* Sat Mar 02 2024 Automatic Build System <autodist@openmamba.org> 10.1.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user