148 lines
5.2 KiB
RPMSpec
148 lines
5.2 KiB
RPMSpec
%define pkgver %(echo %version | tr . -)
|
|
Name: libvigra
|
|
Version: 1.12.1
|
|
Release: 1mamba
|
|
Summary: A computer vision library that puts its main emphasize on customizable algorithms and data structures
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://ukoethe.github.io/vigra/
|
|
Source: https://github.com/ukoethe/vigra.git/Version-%{pkgver}/vigra-%{version}.tar.bz2
|
|
Patch0: libvigra-1.11.1-fix-incorrect-template-parameter-type.patch
|
|
Patch1: libvigra-1.11.1-python-3.7.patch
|
|
Patch2: libvigra-1.11.1-openexr-3.0.1.patch
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libboost-devel
|
|
BuildRequires: libfftw-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libhdf5-devel
|
|
BuildRequires: libimath-devel
|
|
BuildRequires: libjpeg-devel
|
|
BuildRequires: libopenexr-devel
|
|
BuildRequires: libpng-devel
|
|
BuildRequires: libpython3-devel
|
|
BuildRequires: libpython311-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libtiff-devel
|
|
BuildRequires: libz-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libopenexr-devel >= 3.0.4-1mamba
|
|
|
|
%description
|
|
VIGRA stands for "Vision with Generic Algorithms". It's a novel computer vision library that puts its main emphasize on customizable algorithms and data structures. By using template techniques similar to those in the C++ Standard Template Library, you can easily adapt any VIGRA component to the needs of your application, without thereby giving up execution speed.
|
|
|
|
%package devel
|
|
Group: Development/Libraries
|
|
Summary: Static libraries and headers for %{name}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
VIGRA stands for "Vision with Generic Algorithms". It's a novel computer vision library that puts its main emphasize on customizable algorithms and data structures. By using template techniques similar to those in the C++ Standard Template Library, you can easily adapt any VIGRA component to the needs of your application, without thereby giving up execution speed.
|
|
This package contains static libraries and header files need for development.
|
|
|
|
%package -n python-vigra-py3
|
|
Group: System/Libraries/Python
|
|
Summary: Python bindings for %{name}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n python-vigra-py3
|
|
VIGRA stands for "Vision with Generic Algorithms". It's a novel computer vision library that puts its main emphasize on customizable algorithms and data structures. By using template techniques similar to those in the C++ Standard Template Library, you can easily adapt any VIGRA component to the needs of your application, without thereby giving up execution speed.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n vigra-%{version}
|
|
#%patch 0 -p1
|
|
#%patch 1 -p1
|
|
%patch 2 -p1
|
|
|
|
%build
|
|
%cmake -d build \
|
|
-DDOCINSTALL=share/doc \
|
|
-DPython_EXECUTABLE=%{__python3} \
|
|
-DPython_INCLUDEDIR=%{python3_inc} \
|
|
-DWITH_OPENEXR=true \
|
|
-DWITH_VIGRANUMPY=1 \
|
|
-DCMAKE_C_FLAGS="-DH5_USE_110_API" \
|
|
-DCMAKE_CXX_FLAGS="-DH5_USE_110_API"
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
rm -f %{buildroot}%{_docdir}/vigranumpy/.buildinfo
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libvigraimpex.so.*
|
|
#%doc README.txt
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%{_bindir}/vigra-config
|
|
%dir %{_includedir}/vigra
|
|
%{_includedir}/vigra/*
|
|
%{_libdir}/vigra/*.cmake
|
|
%{_libdir}/libvigraimpex.so
|
|
%{_libdir}/vigranumpy/VigranumpyConfig.cmake
|
|
%dir %{_docdir}/vigra
|
|
%{_docdir}/vigra/*
|
|
#%dir %{_docdir}/vigranumpy
|
|
#%{_docdir}/vigranumpy/*
|
|
|
|
%files -n python-vigra-py3
|
|
%defattr(-,root,root)
|
|
%dir %{python3_sitelib}/vigra
|
|
%{python3_sitelib}/vigra/*
|
|
|
|
%changelog
|
|
* Tue Sep 03 2024 Automatic Build System <autodist@openmamba.org> 1.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Oct 08 2023 Automatic Build System <autodist@mambasoft.it> 1.11.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 24 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.11.1-2mamba
|
|
- rebuilt by autoport with build requirements: libopenexr-devel>=3.0.4-1mamba
|
|
|
|
* Sat May 15 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.11.1-1mamba
|
|
- update to 1.11.1
|
|
|
|
* Fri May 20 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.11.0-1mamba
|
|
- update to 1.11.0
|
|
|
|
* Sun Dec 13 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.0-2mamba
|
|
- rebuilt with gcc 5.2.0
|
|
|
|
* Sun Jan 12 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.0-1mamba
|
|
- update to 1.10.0
|
|
|
|
* Mon Dec 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.0-3mamba
|
|
- rebuilt with python 2.7
|
|
|
|
* Mon Mar 11 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.0-2mamba
|
|
- rebuilt with libhdf5 1.8.10
|
|
|
|
* Mon Mar 11 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.0-1mamba
|
|
- update to 1.9.0
|
|
|
|
* Fri Jan 07 2011 Automatic Build System <autodist@mambasoft.it> 1.7.1-2mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Jan 06 2011 Automatic Build System <autodist@mambasoft.it> 1.7.1-1mamba
|
|
- update to 1.7.1
|
|
|
|
* Thu Jan 06 2011 Automatic Build System <autodist@mambasoft.it> 1.7.0-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Jul 07 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-1mamba
|
|
- package created by autospec
|