package created by autospec [release 0.8.0-1mamba;Mon Jun 25 2012]

This commit is contained in:
Stefano Cotta Ramusino 2024-01-06 05:57:45 +01:00
parent 61c623340c
commit c53fe63ba8
3 changed files with 128 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# libtre # libtre
TRE is a lightweight, robust, and efficient POSIX compliant regexp matching library with some exciting features such as approximate (fuzzy) matching.

21
libtre-0.8.0-python.patch Normal file
View File

@ -0,0 +1,21 @@
diff -up tre-0.8.0/python/setup.py.chicken tre-0.8.0/python/setup.py
--- tre-0.8.0/python/setup.py.chicken 2009-09-20 09:51:01.000000000 +0200
+++ tre-0.8.0/python/setup.py 2009-09-20 15:43:45.000000000 +0200
@@ -10,7 +10,8 @@ import shutil
version = "0.8.0"
data_files = []
-include_dirs = ["../lib"]
+include_dirs = ["..", "../lib"]
+library_dirs = ["../lib/.libs"]
libraries = ["tre"]
if sys.platform == "win32":
@@ -31,6 +32,7 @@ setup(name = "tre",
sources = ["tre-python.c"],
define_macros = [("HAVE_CONFIG_H", None)],
include_dirs = include_dirs,
+ library_dirs = library_dirs,
libraries = libraries
),
],

105
libtre.spec Normal file
View File

@ -0,0 +1,105 @@
Name: libtre
Version: 0.8.0
Release: 1mamba
Summary: Free and portable approximate regex matching library
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
URL: http://laurikari.net/tre
Source: http://laurikari.net/tre/tre-%{version}.tar.bz2
Patch0: %{name}-0.8.0-python.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libpython-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
TRE is a lightweight, robust, and efficient POSIX compliant regexp matching library with some exciting features such as approximate (fuzzy) matching.
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: pkg-config
%description devel
This package contains libraries and header files for developing applications that use %{name}.
%package -n agrep
Summary: Approximate grep utility
Group: Applications/File
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n agrep
agrep (approximate grep) command line tool approximate regexp matching in the style of grep.
agrep allows full regexps of any length, any number of errors, and non-uniform costs for insertion, deletion and substitution.
%package -n python-tre
Summary: Python bindings for %{name}
Group: System/Libraries
%description -n python-tre
This package contains the python bindings for %{name}.
%prep
%setup -q -n tre-%{version}
# fix python bindings build
%patch0 -p1
ln -s lib tre
%build
%configure
%make
(cd python; CFLAGS="%{optflags}" %{__python} setup.py build)
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%find_lang tre || touch tre.lang
(cd python; %{__python} setup.py install \
-O1 --skip-build \
--root="%{buildroot}" \
--install-headers="%{_includedir}/python" \
--install-lib="%{python_sitearch}" \
--record=tre.filelist)
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," python/tre.filelist
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files -f tre.lang
%defattr(-,root,root)
%{_libdir}/*.so.*
%doc AUTHORS LICENSE THANKS
%files -n python-tre -f python/tre.filelist
%defattr(644,root,root,755)
%files devel
%defattr(-,root,root)
%{_includedir}/tre
%{_libdir}/*.la
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%doc ChangeLog NEWS README TODO
%doc doc/default.css doc/tre-api.html doc/tre-syntax.html
%files -n agrep
%defattr(-,root,root)
%{_bindir}/agrep
%{_mandir}/man1/*
%changelog
* Mon Jun 25 2012 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.8.0-1mamba
- package created by autospec