automatic version update by autodist [release 0.9.0-1mamba;Mon Sep 30 2024]

This commit is contained in:
Automatic Build System 2024-10-01 10:06:01 +02:00
parent 8fc4a11f64
commit b84566cacc
2 changed files with 10 additions and 55 deletions

View File

@ -1,21 +0,0 @@
diff -up tre-0.8.0/python/setup.py.chicken tre-0.8.0/python/setup.py
--- tre-0.8.0/python/setup.py.chicken 2009-09-20 09:51:01.000000000 +0200
+++ tre-0.8.0/python/setup.py 2009-09-20 15:43:45.000000000 +0200
@@ -10,7 +10,8 @@ import shutil
version = "0.8.0"
data_files = []
-include_dirs = ["../lib"]
+include_dirs = ["..", "../lib"]
+library_dirs = ["../lib/.libs"]
libraries = ["tre"]
if sys.platform == "win32":
@@ -31,6 +32,7 @@ setup(name = "tre",
sources = ["tre-python.c"],
define_macros = [("HAVE_CONFIG_H", None)],
include_dirs = include_dirs,
+ library_dirs = library_dirs,
libraries = libraries
),
],

View File

@ -1,21 +1,17 @@
Name: libtre
Version: 0.8.0.20201128git
Version: 0.9.0
Release: 1mamba
Summary: Free and portable approximate regex matching library
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
URL: http://laurikari.net/tre
Source: https://github.com/laurikari/tre.git/master/tre-%{version}.tar.bz2
#Source: http://laurikari.net/tre/tre-%{version}.tar.bz2
Patch0: %{name}-0.8.0-python.patch
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://laurikari.net/tre/
Source: https://github.com/laurikari/tre.git/v%{version}/tre-%{version}.tar.bz2
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libpython3-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
TRE is a lightweight, robust, and efficient POSIX compliant regexp matching library with some exciting features such as approximate (fuzzy) matching.
@ -42,7 +38,7 @@ agrep allows full regexps of any length, any number of errors, and non-uniform c
Summary: Python bindings for %{name}
Group: System/Libraries
Provides: python-tre
Obsoletes: python-tre
Obsoletes: python-tre < 0.9.0
%description -n python-tre-py3
This package contains the python bindings for %{name}.
@ -51,54 +47,31 @@ This package contains the python bindings for %{name}.
%prep
%setup -q -n tre-%{version}
# fix python bindings build
%patch0 -p1
ln -s lib tre
autoreconf -f -i
#sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," utils/config.sub
%build
%configure
%make
#(cd python; CFLAGS="%{optflags}" %{__python3} setup.py build)
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%find_lang tre || touch tre.lang
#(cd python; %{__python} setup.py install \
# -O1 --skip-build \
# --root="%{buildroot}" \
# --install-headers="%{_includedir}/python" \
# --install-lib="%{python_sitearch}" \
# --record=tre.filelist)
#
#sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," python/tre.filelist
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files -f tre.lang
%defattr(-,root,root)
%{_libdir}/*.so.*
%{_libdir}/libtre.so.*
%doc AUTHORS LICENSE THANKS
#%files -n python-tre-py3 -f python/tre.filelist
#%defattr(644,root,root,755)
%files devel
%defattr(-,root,root)
%{_includedir}/tre
%{_libdir}/*.la
%{_libdir}/*.so
%{_libdir}/libtre.so
%{_libdir}/pkgconfig/*.pc
%doc NEWS TODO
%doc doc/default.css doc/tre-api.html doc/tre-syntax.html
@ -109,6 +82,9 @@ autoreconf -f -i
%{_mandir}/man1/*
%changelog
* Mon Sep 30 2024 Automatic Build System <autodist@openmamba.org> 0.9.0-1mamba
- automatic version update by autodist
* Sat Nov 28 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.0.20201128git-1mamba
- update to 0.8.0.20201128git
- added debug package, remove python binding (not building with python3)