add another patch to disable other des symbols that are provided by glibc (fix breaking pam) [release 0.2.4-2mamba;Thu Apr 17 2014]

This commit is contained in:
Silvan Calarco 2024-01-06 05:55:51 +01:00
parent a9c099d69e
commit 7b6926bd13
5 changed files with 174 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# libtirpc # libtirpc
Libtirpc is a port of Suns Transport-Independent RPC library to Linux.

View File

@ -0,0 +1,36 @@
From f2f43212b33dea42635061c82645287454a70107 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Sat, 11 Jun 2011 15:21:55 -0400
Subject: [PATCH] add multiple inclusion protection to rpc/des.h
If you try to include this file multiple times, you get a build failure
due to redefinitions of enums and such.
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
tirpc/rpc/des.h | 5 +++++
1 files changed, 5 insertions(+), 0 deletions(-)
diff --git a/tirpc/rpc/des.h b/tirpc/rpc/des.h
index e3d6897..d2881ad 100644
--- a/tirpc/rpc/des.h
+++ b/tirpc/rpc/des.h
@@ -33,6 +33,9 @@
* Copyright (c) 1986 by Sun Microsystems, Inc.
*/
+#ifndef _RPC_DES_H_
+#define _RPC_DES_H_
+
#define DES_MAXLEN 65536 /* maximum # of bytes to encrypt */
#define DES_QUICKLEN 16 /* maximum # of bytes to encrypt quickly */
@@ -80,3 +83,5 @@ struct desparams {
* Software DES.
*/
extern int _des_crypt( char *, int, struct desparams * );
+
+#endif
--
1.7.5.3

View File

@ -0,0 +1,28 @@
Submitted By: Bruce Dubbs <bdubbs_at_linuxfromscratch_dot_org>
Date: 2011-11-19
Initial Package Version: 0.2.2
Upstream Status: Not submitted
Origin: Upstream and LFS
Description: This patch contains removes nis references that
have been removed from glibc.
diff -Naur libtirpc-0.2.2.orig/src/rpc_soc.c libtirpc-0.2.2/src/rpc_soc.c
--- libtirpc-0.2.2.orig/src/rpc_soc.c 2011-05-02 07:10:40.000000000 -0500
+++ libtirpc-0.2.2/src/rpc_soc.c 2011-11-19 19:46:22.000000000 -0600
@@ -519,6 +519,7 @@
* Create the client des authentication object. Obsoleted by
* authdes_seccreate().
*/
+#ifdef NEVER
AUTH *
authdes_create(servername, window, syncaddr, ckey)
char *servername; /* network name of server */
@@ -546,6 +547,7 @@
dummy = authdes_seccreate(servername, window, NULL, ckey);
return (dummy);
}
+#endif
/*
* Create a client handle for a unix connection. Obsoleted by clnt_vc_create()

View File

@ -0,0 +1,11 @@
--- libtirpc-0.2.4/src/Makefile.am 2013-12-09 21:59:51.000000000 +0100
+++ libtirpc-0.2.4.buono/src/Makefile.am 2014-04-17 00:52:02.762845419 +0200
@@ -51,7 +51,7 @@
rpc_callmsg.c rpc_generic.c rpc_soc.c rpcb_clnt.c rpcb_prot.c \
rpcb_st_xdr.c svc.c svc_auth.c svc_dg.c svc_auth_unix.c svc_auth_none.c \
svc_generic.c svc_raw.c svc_run.c svc_simple.c svc_vc.c getpeereid.c \
- auth_time.c auth_des.c authdes_prot.c
+ auth_time.c
## XDR
libtirpc_la_SOURCES += xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c

97
libtirpc.spec Normal file
View File

@ -0,0 +1,97 @@
Name: libtirpc
Version: 0.2.4
Release: 2mamba
Summary: A port of Suns Transport-Independent RPC library to Linux
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://sourceforge.net/projects/libtirpc/
Source: http://downloads.sourceforge.net/project/libtirpc/libtirpc/%{version}/libtirpc-%{version}.tar.bz2
Patch0: libtirpc-0.2.2-add-multiple-inclusion-protection-to-rpc_des.patch
Patch1: libtirpc-0.2.3-remove-nis.patch
Patch2: libtirpc-0.2.4-remove-des.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libe2fs-devel
BuildRequires: libkeyutils-devel
BuildRequires: libkrb5-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Libtirpc is a port of Suns Transport-Independent RPC library to Linux.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
Libtirpc is a port of Suns Transport-Independent RPC library to Linux.
This package contains static libraries and header files need for development.
%prep
%setup -q
%patch1 -p1
%patch2 -p1
sed -i "s|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|" configure.ac
%build
autoreconf -f -i
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%config %{_sysconfdir}/netconfig
%{_libdir}/libtirpc.so.*
%{_mandir}/man5/netconfig.5*
%doc AUTHORS COPYING THANKS
%files devel
%defattr(-,root,root)
%{_libdir}/libtirpc.a
%{_libdir}/libtirpc.la
%{_libdir}/libtirpc.so
# %{_bindir}/%{name}-config
# %{_datadir}/aclocal/*.m4
# %{_includedir}/*.h
%{_includedir}/tirpc
# %{_libdir}/*.a
# %{_libdir}/*.la
# %{_libdir}/*.so
%{_libdir}/pkgconfig/libtirpc.pc
%{_mandir}/man3/*.3t*
%doc ChangeLog NEWS README TODO
%changelog
* Thu Apr 17 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.4-2mamba
- add another patch to disable other des symbols that are provided by glibc (fix breaking pam)
* Tue Dec 17 2013 Automatic Build System <autodist@mambasoft.it> 0.2.4-1mamba
- automatic update by autodist
* Mon Feb 25 2013 Automatic Build System <autodist@mambasoft.it> 0.2.3-1mamba
- automatic version update by autodist
* Wed Sep 26 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.2-2mamba
- add a patch to fix: 'undefined symbol: _des_crypt_call' (remove nis) with pam 1.1.4
* Wed Aug 24 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.2-1mamba
- update to 0.2.2
* Sun Apr 03 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.1-1mamba
- package created by autospec