automatic version update by autodist [release 1.3.5-1mamba;Thu Jul 25 2024]

This commit is contained in:
Automatic Build System 2024-07-26 19:33:38 +02:00
parent 7f5e5b56b4
commit 1e98a2cfc0
6 changed files with 29 additions and 111 deletions

View File

@ -1,36 +0,0 @@
From f2f43212b33dea42635061c82645287454a70107 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Sat, 11 Jun 2011 15:21:55 -0400
Subject: [PATCH] add multiple inclusion protection to rpc/des.h
If you try to include this file multiple times, you get a build failure
due to redefinitions of enums and such.
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
tirpc/rpc/des.h | 5 +++++
1 files changed, 5 insertions(+), 0 deletions(-)
diff --git a/tirpc/rpc/des.h b/tirpc/rpc/des.h
index e3d6897..d2881ad 100644
--- a/tirpc/rpc/des.h
+++ b/tirpc/rpc/des.h
@@ -33,6 +33,9 @@
* Copyright (c) 1986 by Sun Microsystems, Inc.
*/
+#ifndef _RPC_DES_H_
+#define _RPC_DES_H_
+
#define DES_MAXLEN 65536 /* maximum # of bytes to encrypt */
#define DES_QUICKLEN 16 /* maximum # of bytes to encrypt quickly */
@@ -80,3 +83,5 @@ struct desparams {
* Software DES.
*/
extern int _des_crypt( char *, int, struct desparams * );
+
+#endif
--
1.7.5.3

View File

@ -1,28 +0,0 @@
Submitted By: Bruce Dubbs <bdubbs_at_linuxfromscratch_dot_org>
Date: 2011-11-19
Initial Package Version: 0.2.2
Upstream Status: Not submitted
Origin: Upstream and LFS
Description: This patch contains removes nis references that
have been removed from glibc.
diff -Naur libtirpc-0.2.2.orig/src/rpc_soc.c libtirpc-0.2.2/src/rpc_soc.c
--- libtirpc-0.2.2.orig/src/rpc_soc.c 2011-05-02 07:10:40.000000000 -0500
+++ libtirpc-0.2.2/src/rpc_soc.c 2011-11-19 19:46:22.000000000 -0600
@@ -519,6 +519,7 @@
* Create the client des authentication object. Obsoleted by
* authdes_seccreate().
*/
+#ifdef NEVER
AUTH *
authdes_create(servername, window, syncaddr, ckey)
char *servername; /* network name of server */
@@ -546,6 +547,7 @@
dummy = authdes_seccreate(servername, window, NULL, ckey);
return (dummy);
}
+#endif
/*
* Create a client handle for a unix connection. Obsoleted by clnt_vc_create()

View File

@ -1,11 +0,0 @@
--- libtirpc-0.2.5/src/Makefile.am.orig 2014-09-13 09:25:51.415764373 +0200
+++ libtirpc-0.2.5/src/Makefile.am 2014-09-13 16:33:37.565883603 +0200
@@ -51,7 +51,7 @@
rpc_callmsg.c rpc_generic.c rpc_soc.c rpcb_clnt.c rpcb_prot.c \
rpcb_st_xdr.c svc.c svc_auth.c svc_dg.c svc_auth_unix.c svc_auth_none.c \
svc_generic.c svc_raw.c svc_run.c svc_simple.c svc_vc.c getpeereid.c \
- auth_time.c auth_des.c authdes_prot.c debug.c
+ auth_time.c debug.c
## XDR
libtirpc_la_SOURCES += xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c

View File

@ -1,24 +0,0 @@
diff -Nru libtirpc-0.2.5.orig/tirpc/rpc/rpcb_prot.h libtirpc-0.2.5/tirpc/rpc/rpcb_prot.h
--- libtirpc-0.2.5.orig/tirpc/rpc/rpcb_prot.h 2014-08-08 18:24:34.000000000 +0200
+++ libtirpc-0.2.5/tirpc/rpc/rpcb_prot.h 2014-10-01 15:30:21.161591481 +0200
@@ -476,7 +476,7 @@
#define RPCBVERS_3 RPCBVERS
#define RPCBVERS_4 RPCBVERS4
-#define _PATH_RPCBINDSOCK "/var/run/rpcbind.sock"
+#define _PATH_RPCBINDSOCK "/run/rpcbind.sock"
#else /* ndef _KERNEL */
#ifdef __cplusplus
diff -Nru libtirpc-0.2.5.orig/tirpc/rpc/rpcb_prot.x libtirpc-0.2.5/tirpc/rpc/rpcb_prot.x
--- libtirpc-0.2.5.orig/tirpc/rpc/rpcb_prot.x 2014-08-08 18:24:34.000000000 +0200
+++ libtirpc-0.2.5/tirpc/rpc/rpcb_prot.x 2014-10-01 15:30:10.606591115 +0200
@@ -410,7 +410,7 @@
%#define RPCBVERS_3 RPCBVERS
%#define RPCBVERS_4 RPCBVERS4
%
-%#define _PATH_RPCBINDSOCK "/var/run/rpcbind.sock"
+%#define _PATH_RPCBINDSOCK "/run/rpcbind.sock"
%
%#else /* ndef _KERNEL */
%#ifdef __cplusplus

View File

@ -0,0 +1,24 @@
diff -Nru libtirpc-1.3.5.orig/tirpc/rpc/rpcb_prot.h libtirpc-1.3.5/tirpc/rpc/rpcb_prot.h
--- libtirpc-1.3.5.orig/tirpc/rpc/rpcb_prot.h 2024-07-22 13:10:59.000000000 +0200
+++ libtirpc-1.3.5/tirpc/rpc/rpcb_prot.h 2024-07-25 18:52:15.299261527 +0200
@@ -476,7 +476,7 @@
#define RPCBVERS_3 RPCBVERS
#define RPCBVERS_4 RPCBVERS4
-#define _PATH_RPCBINDSOCK "/var/run/rpcbind.sock"
+#define _PATH_RPCBINDSOCK "/run/rpcbind.sock"
#define _PATH_RPCBINDSOCK_ABSTRACT "\0/run/rpcbind.sock"
#else /* ndef _KERNEL */
diff -Nru libtirpc-1.3.5.orig/tirpc/rpc/rpcb_prot.x libtirpc-1.3.5/tirpc/rpc/rpcb_prot.x
--- libtirpc-1.3.5.orig/tirpc/rpc/rpcb_prot.x 2024-07-22 13:10:59.000000000 +0200
+++ libtirpc-1.3.5/tirpc/rpc/rpcb_prot.x 2024-07-25 18:52:03.804236673 +0200
@@ -410,7 +410,7 @@
%#define RPCBVERS_3 RPCBVERS
%#define RPCBVERS_4 RPCBVERS4
%
-%#define _PATH_RPCBINDSOCK "/var/run/rpcbind.sock"
+%#define _PATH_RPCBINDSOCK "/run/rpcbind.sock"
%#define _PATH_RPCBINDSOCK_ABSTRACT "\0/run/rpcbind.sock"
%
%#else /* ndef _KERNEL */

View File

@ -1,5 +1,5 @@
Name: libtirpc
Version: 1.3.4
Version: 1.3.5
Release: 1mamba
Summary: A port of Suns Transport-Independent RPC library to Linux
Group: System/Libraries
@ -8,11 +8,8 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://sourceforge.net/projects/libtirpc/
Source: http://downloads.sourceforge.net/project/libtirpc/libtirpc/%{version}/libtirpc-%{version}.tar.bz2
Patch0: libtirpc-0.2.2-add-multiple-inclusion-protection-to-rpc_des.patch
Patch1: libtirpc-0.2.3-remove-nis.patch
Patch2: libtirpc-0.2.5-remove-des.patch
Patch3: libtirpc-0.2.5-netconfig-disable-ipv6.patch
Patch4: libtirpc-0.2.5-var-run.patch
Patch4: libtirpc-1.3.5-var-run.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -36,7 +33,6 @@ This package contains static libraries and header files needed for development.
%prep
%setup -q
#%patch1 -p1
%patch 3 -p1
%patch 4 -p1
@ -71,17 +67,14 @@ autoreconf -f -i
%{_includedir}/tirpc/*
%{_libdir}/libtirpc.a
%{_libdir}/libtirpc.so
# %{_bindir}/%{name}-config
# %{_datadir}/aclocal/*.m4
# %{_includedir}/*.h
# %{_libdir}/*.a
# %{_libdir}/*.la
# %{_libdir}/*.so
%{_libdir}/pkgconfig/libtirpc.pc
%{_mandir}/man3/*.3t*
%doc ChangeLog NEWS README TODO
%changelog
* Thu Jul 25 2024 Automatic Build System <autodist@openmamba.org> 1.3.5-1mamba
- automatic version update by autodist
* Mon Oct 09 2023 Automatic Build System <autodist@mambasoft.it> 1.3.4-1mamba
- automatic version update by autodist