update to 0.1.19 [release 0.1.19-1mamba;Sat Jul 27 2013]
This commit is contained in:
parent
30b2582a5e
commit
b16488da58
@ -1,2 +1,4 @@
|
||||
# libthai
|
||||
|
||||
LibThai is a set of Thai language support routines aimed to ease developers' tasks to incorporate Thai language support in their applications. It includes important Thai-specific functions e.g. word breaking, input and output methods as well as basic character and string supports. LibThai is an Open Source and collaborative effort initiated by Thai Linux Working Group and opened for all contributors.
|
||||
|
||||
|
44
libthai-0.1.12-libdatrie-0.2.2-static-build.patch
Normal file
44
libthai-0.1.12-libdatrie-0.2.2-static-build.patch
Normal file
@ -0,0 +1,44 @@
|
||||
diff -up libthai-0.1.12/libdatrie-0.2.2/datrie/Makefile.am.static-build libthai-0.1.12/libdatrie-0.2.2/datrie/Makefile.am
|
||||
--- libthai-0.1.12/libdatrie/datrie/Makefile.am.static-build 2009-04-13 05:18:20.000000000 -0400
|
||||
+++ libthai-0.1.12/libdatrie/datrie/Makefile.am 2009-06-27 17:58:06.813631702 -0400
|
||||
@@ -10,7 +10,7 @@ EXTRA_DIST = libdatrie.map libdatrie.def
|
||||
|
||||
INCLUDES = -I$(top_srcdir)
|
||||
|
||||
-lib_LTLIBRARIES = libdatrie.la
|
||||
+noinst_LTLIBRARIES = libdatrie.la
|
||||
|
||||
libdatrie_la_SOURCES = \
|
||||
typedefs.h \
|
||||
diff -up libthai-0.1.12/libthai.pc.in.static-build libthai-0.1.12/libthai.pc.in
|
||||
--- libthai-0.1.12/libthai.pc.in.static-build 2009-03-31 00:25:23.000000000 -0400
|
||||
+++ libthai-0.1.12/libthai.pc.in 2009-06-27 17:58:06.814631492 -0400
|
||||
@@ -6,6 +6,5 @@ includedir=@includedir@
|
||||
Name: libthai
|
||||
Description: Thai support library
|
||||
Version: @VERSION@
|
||||
-Requires.private: datrie-0.2
|
||||
Libs: -L${libdir} -lthai
|
||||
Cflags: -I${includedir}
|
||||
diff -up libthai-0.1.12/src/Makefile.am.static-build libthai-0.1.12/src/Makefile.am
|
||||
--- libthai-0.1.12/src/Makefile.am.static-build 2009-06-07 03:20:15.000000000 -0400
|
||||
+++ libthai-0.1.12/src/Makefile.am 2009-06-27 17:59:20.060630864 -0400
|
||||
@@ -19,7 +19,8 @@ libthai_sublibs = \
|
||||
$(top_builddir)/src/thwchar/libthwchar.la \
|
||||
$(top_builddir)/src/thwctype/libthwctype.la \
|
||||
$(top_builddir)/src/thwstr/libthwstr.la \
|
||||
- $(top_builddir)/src/thwbrk/libthwbrk.la
|
||||
+ $(top_builddir)/src/thwbrk/libthwbrk.la \
|
||||
+ $(DATRIE_LIBS)
|
||||
|
||||
if LD_HAS_VERSION_SCRIPT
|
||||
EXPORTS_FLAGS = -Wl,-version-script -Wl,$(srcdir)/libthai.map
|
||||
diff -up libthai-0.1.12/src/thbrk/Makefile.am.static-build libthai-0.1.12/src/thbrk/Makefile.am
|
||||
--- libthai-0.1.12/src/thbrk/Makefile.am.static-build 2009-01-19 08:32:50.000000000 -0500
|
||||
+++ libthai-0.1.12/src/thbrk/Makefile.am 2009-06-27 17:58:06.812632123 -0400
|
||||
@@ -16,5 +16,4 @@ libthbrk_la_SOURCES = \
|
||||
brk-maximal.c \
|
||||
brk-maximal.h
|
||||
|
||||
-libthbrk_la_LIBADD = $(DATRIE_LIBS)
|
||||
|
27
libthai-0.1.9-doxygen-segfault.patch
Normal file
27
libthai-0.1.9-doxygen-segfault.patch
Normal file
@ -0,0 +1,27 @@
|
||||
diff -up libthai-0.1.9/doc/Doxyfile.in.doxygen-segfault libthai-0.1.9/doc/Doxyfile.in
|
||||
--- libthai-0.1.9/doc/Doxyfile.in.doxygen-segfault 2007-11-13 16:37:16.000000000 -0500
|
||||
+++ libthai-0.1.9/doc/Doxyfile.in 2007-11-13 16:37:31.000000000 -0500
|
||||
@@ -29,7 +29,6 @@ STRIP_FROM_PATH = @top_srcdir@/in
|
||||
STRIP_FROM_INC_PATH = @top_srcdir@/include
|
||||
SHORT_NAMES = NO
|
||||
JAVADOC_AUTOBRIEF = NO
|
||||
-QT_AUTOBRIEF = NO
|
||||
MULTILINE_CPP_IS_BRIEF = NO
|
||||
DETAILS_AT_TOP = YES
|
||||
INHERIT_DOCS = YES
|
||||
@@ -50,7 +49,6 @@ EXTRACT_PRIVATE = NO
|
||||
EXTRACT_STATIC = NO
|
||||
EXTRACT_LOCAL_CLASSES = YES
|
||||
EXTRACT_LOCAL_METHODS = NO
|
||||
-EXTRACT_ANON_NSPACES = NO
|
||||
HIDE_UNDOC_MEMBERS = YES
|
||||
HIDE_UNDOC_CLASSES = YES
|
||||
HIDE_FRIEND_COMPOUNDS = NO
|
||||
@@ -168,7 +166,6 @@ HTML_FOOTER =
|
||||
HTML_STYLESHEET =
|
||||
HTML_ALIGN_MEMBERS = YES
|
||||
GENERATE_HTMLHELP = NO
|
||||
-HTML_DYNAMIC_SECTIONS = NO
|
||||
CHM_FILE =
|
||||
HHC_LOCATION =
|
||||
GENERATE_CHI = NO
|
120
libthai.spec
Normal file
120
libthai.spec
Normal file
@ -0,0 +1,120 @@
|
||||
%define libdatrie_version 0.2.5
|
||||
Name: libthai
|
||||
Version: 0.1.19
|
||||
Release: 1mamba
|
||||
Summary: Thai language support routines
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://linux.thai.net/
|
||||
Source0: ftp://linux.thai.net/pub/thailinux/software/libthai/libthai-%{version}.tar.xz
|
||||
Source1: ftp://linux.thai.net/pub/thailinux/software/libthai/libdatrie-%{libdatrie_version}.tar.gz
|
||||
Patch0: libthai-0.1.12-libdatrie-0.2.2-static-build.patch
|
||||
Patch1: libthai-0.1.9-doxygen-segfault.patch
|
||||
License: LGPL
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: doxygen
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: pkgconfig
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libtool
|
||||
BuildRequires: pkgconfig
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
LibThai is a set of Thai language support routines aimed to ease developers' tasks to incorporate Thai language support in their applications. It includes important Thai-specific functions e.g. word breaking, input and output methods as well as basic character and string supports. LibThai is an Open Source and collaborative effort initiated by Thai Linux Working Group and opened for all contributors.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
LibThai is a set of Thai language support routines.
|
||||
|
||||
This package contains libraries and header files need for development.
|
||||
|
||||
%package static
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description static
|
||||
LibThai is a set of Thai language support routines.
|
||||
|
||||
This package contains static libraries need for development.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version} -a1
|
||||
mv libdatrie-%{libdatrie_version} libdatrie
|
||||
%patch0 -p1
|
||||
#%patch1 -p1
|
||||
|
||||
%build
|
||||
|
||||
{
|
||||
pushd libdatrie
|
||||
mkdir m4
|
||||
autoreconf -i -f
|
||||
%configure
|
||||
make
|
||||
popd
|
||||
}
|
||||
|
||||
export DATRIE_CFLAGS="-I$PWD/libdatrie"
|
||||
export DATRIE_LIBS="$PWD/libdatrie/datrie/libdatrie.la"
|
||||
export PATH="$PWD/libdatrie/tools:$PATH"
|
||||
autoreconf -i -f
|
||||
|
||||
%configure
|
||||
make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
mkdir installed-docs
|
||||
mv %{buildroot}%{_docdir}/libthai/* installed-docs
|
||||
rmdir %{buildroot}%{_docdir}/libthai
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libthai.so.*
|
||||
%{_datadir}/libthai/thbrk.tri
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/thai
|
||||
%{_includedir}/thai/*.h
|
||||
%{_libdir}/libthai.so
|
||||
%{_libdir}/pkgconfig/libthai.pc
|
||||
#%{_mandir}/man3/*.gz
|
||||
%doc ChangeLog NEWS README
|
||||
%doc installed-docs/*
|
||||
|
||||
%files static
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libthai.*a
|
||||
|
||||
%changelog
|
||||
* Sat Jul 27 2013 Automatic Build System <autodist@mambasoft.it> 0.1.19-1mamba
|
||||
- update to 0.1.19
|
||||
|
||||
* Sun Jul 29 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.18-1mamba
|
||||
- update to 0.1.18
|
||||
|
||||
* Mon Dec 06 2010 gil <puntogil@libero.it> 0.1.14-2mamba
|
||||
- rebuilt devel
|
||||
|
||||
* Sat May 01 2010 gil <puntogil@libero.it> 0.1.14-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user