x86_64 rebuild with patch to disable broken tcl support [release 2.8.17-4mamba;Sat Sep 20 2014]
This commit is contained in:
parent
0e3acc7af6
commit
ec944cc3ab
20
libsqlite2-2.8.17-no_tcl.patch
Normal file
20
libsqlite2-2.8.17-no_tcl.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff -bur sqlite-2.8.17~orig/main.mk sqlite-2.8.17/main.mk
|
||||||
|
--- sqlite-2.8.17~orig/main.mk 2006-02-13 04:09:33.000000000 -0600
|
||||||
|
+++ sqlite-2.8.17/main.mk 2006-02-13 04:15:42.000000000 -0600
|
||||||
|
@@ -58,7 +58,7 @@
|
||||||
|
expr.o func.o hash.o insert.o \
|
||||||
|
main.o opcodes.o os.o pager.o parse.o pragma.o printf.o random.o \
|
||||||
|
select.o table.o tokenize.o trigger.o update.o util.o \
|
||||||
|
- vacuum.o vdbe.o vdbeaux.o where.o tclsqlite.o
|
||||||
|
+ vacuum.o vdbe.o vdbeaux.o where.o
|
||||||
|
|
||||||
|
# All of the source code files.
|
||||||
|
#
|
||||||
|
@@ -91,7 +91,6 @@
|
||||||
|
$(TOP)/src/sqlite.h.in \
|
||||||
|
$(TOP)/src/sqliteInt.h \
|
||||||
|
$(TOP)/src/table.c \
|
||||||
|
- $(TOP)/src/tclsqlite.c \
|
||||||
|
$(TOP)/src/tokenize.c \
|
||||||
|
$(TOP)/src/trigger.c \
|
||||||
|
$(TOP)/src/update.c \
|
@ -1,6 +1,6 @@
|
|||||||
Name: libsqlite2
|
Name: libsqlite2
|
||||||
Version: 2.8.17
|
Version: 2.8.17
|
||||||
Release: 3mamba
|
Release: 4mamba
|
||||||
Summary: An Embeddable SQL Database Engine
|
Summary: An Embeddable SQL Database Engine
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,11 +8,15 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.hwaci.com/sw/sqlite
|
URL: http://www.hwaci.com/sw/sqlite
|
||||||
Source: http://www.hwaci.com/sw/sqlite/sqlite-%{version}.tar.gz
|
Source: http://www.hwaci.com/sw/sqlite/sqlite-%{version}.tar.gz
|
||||||
|
Patch0: libsqlite2-2.8.17-no_tcl.patch
|
||||||
License: Public Domain
|
License: Public Domain
|
||||||
BuildRequires: libtcl-devel
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libncurses-devel
|
BuildRequires: libncurses-devel
|
||||||
BuildRequires: libreadline-devel
|
BuildRequires: libreadline-devel
|
||||||
Obsoletes: sqlite
|
## AUTOBUILDREQ-END
|
||||||
|
#BuildRequires: libtcl-devel
|
||||||
|
#Obsoletes: sqlite
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -42,6 +46,7 @@ administer an SQLite database and which serves as an example of how to use the S
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n sqlite-%{version}
|
%setup -q -n sqlite-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -50,12 +55,16 @@ administer an SQLite database and which serves as an example of how to use the S
|
|||||||
|
|
||||||
%make
|
%make
|
||||||
make doc
|
make doc
|
||||||
make -k fulltest
|
#make -k fulltest
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ %{buildroot} != / ] && rm -rf "%{buildroot}"
|
[ %{buildroot} != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall
|
%makeinstall
|
||||||
|
|
||||||
|
%ifarch x86_64
|
||||||
|
mv %{buildroot}%{_prefix}/lib %{buildroot}%{_prefix}/lib64
|
||||||
|
%endif
|
||||||
|
|
||||||
install -D -m644 sqlite.1 %{buildroot}%{_mandir}/man1/sqlite.1
|
install -D -m644 sqlite.1 %{buildroot}%{_mandir}/man1/sqlite.1
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -64,7 +73,6 @@ install -D -m644 sqlite.1 %{buildroot}%{_mandir}/man1/sqlite.1
|
|||||||
%files
|
%files
|
||||||
%defattr(-, root, root)
|
%defattr(-, root, root)
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/*.so.*
|
||||||
%doc README
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-, root, root)
|
%defattr(-, root, root)
|
||||||
@ -74,6 +82,7 @@ install -D -m644 sqlite.1 %{buildroot}%{_mandir}/man1/sqlite.1
|
|||||||
%{_libdir}/pkgconfig/*.pc
|
%{_libdir}/pkgconfig/*.pc
|
||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
%doc doc/*
|
%doc doc/*
|
||||||
|
%doc README
|
||||||
|
|
||||||
%files tools
|
%files tools
|
||||||
%defattr(-, root, root)
|
%defattr(-, root, root)
|
||||||
@ -81,6 +90,9 @@ install -D -m644 sqlite.1 %{buildroot}%{_mandir}/man1/sqlite.1
|
|||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Sep 20 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.17-4mamba
|
||||||
|
- x86_64 rebuild with patch to disable broken tcl support
|
||||||
|
|
||||||
* Wed Jun 20 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.17-3mamba
|
* Wed Jun 20 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.17-3mamba
|
||||||
- updated maintainer
|
- updated maintainer
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user