automatic version update by autodist [release 3.47.0-1mamba;Sat Nov 09 2024]
This commit is contained in:
parent
5fda8ec6e6
commit
4e8f7bd6d7
11
libsqlite-3.47.0-tcl-8.6.15.patch
Normal file
11
libsqlite-3.47.0-tcl-8.6.15.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- sqlite-autoconf-3470000/tea/generic/tclsqlite3.c.orig 2024-11-08 17:16:21.902007739 +0100
|
||||
+++ sqlite-autoconf-3470000/tea/generic/tclsqlite3.c 2024-11-08 17:16:26.432017661 +0100
|
||||
@@ -53,7 +53,7 @@
|
||||
#if TCL_MAJOR_VERSION==9
|
||||
# define CONST const
|
||||
#else
|
||||
- typedef int Tcl_Size;
|
||||
+// typedef int Tcl_Size;
|
||||
#endif
|
||||
/**** End copy of tclsqlite.h ****/
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- sqlite-3.6.18/configure.ac.orig 2009-10-05 22:51:32.000000000 +0200
|
||||
+++ sqlite-3.6.18/configure.ac 2009-10-05 22:52:13.000000000 +0200
|
||||
@@ -637,6 +637,7 @@
|
||||
[use_loadextension=$enableval],[use_loadextension=no])
|
||||
if test "${use_loadextension}" = "yes" ; then
|
||||
OPT_FEATURE_FLAGS=""
|
||||
+ AC_SEARCH_LIBS(dlopen, [dl])
|
||||
else
|
||||
OPT_FEATURE_FLAGS="-DSQLITE_OMIT_LOAD_EXTENSION=1"
|
||||
fi
|
@ -1,21 +0,0 @@
|
||||
--- tool/lemon.c 2010-03-23 14:06:21.000000000 +0100
|
||||
+++ tool/lemon.c-gil 2010-05-14 06:55:06.000000000 +0200
|
||||
@@ -3106,6 +3106,8 @@
|
||||
tpltname = buf;
|
||||
}else if( access(templatename,004)==0 ){
|
||||
tpltname = templatename;
|
||||
+ }else if( access("/usr/share/lemon/lempar.c", R_OK)==0){
|
||||
+ tpltname = "/usr/share/lemon/lempar.c";
|
||||
}else{
|
||||
tpltname = pathsearch(lemp->argv0,templatename,0);
|
||||
}
|
||||
@@ -3117,7 +3119,7 @@
|
||||
}
|
||||
in = fopen(tpltname,"rb");
|
||||
if( in==0 ){
|
||||
- fprintf(stderr,"Can't open the template file \"%s\".\n",templatename);
|
||||
+ fprintf(stderr,"Can't open the template file \"%s\".\n",tpltname);
|
||||
lemp->errorcnt++;
|
||||
return 0;
|
||||
}
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff -up sqlite-src-3070400/test/wal2.test.nodirsync sqlite-src-3070400/test/wal2.test
|
||||
--- sqlite-src-3070400/test/wal2.test.nodirsync 2010-12-09 13:49:43.000000000 +0200
|
||||
+++ sqlite-src-3070400/test/wal2.test 2010-12-09 13:57:57.000000000 +0200
|
||||
@@ -1160,9 +1160,9 @@ if {$::tcl_platform(platform) == "unix"}
|
||||
# Test that "PRAGMA checkpoint_fullsync" appears to be working.
|
||||
#
|
||||
foreach {tn sql reslist} {
|
||||
- 1 { } {8 0 3 0 5 0}
|
||||
- 2 { PRAGMA checkpoint_fullfsync = 1 } {8 4 3 2 5 2}
|
||||
- 3 { PRAGMA checkpoint_fullfsync = 0 } {8 0 3 0 5 0}
|
||||
+ 1 { } {7 0 3 0 5 0}
|
||||
+ 2 { PRAGMA checkpoint_fullfsync = 1 } {7 4 3 2 5 2}
|
||||
+ 3 { PRAGMA checkpoint_fullfsync = 0 } {7 0 3 0 5 0}
|
||||
} {
|
||||
faultsim_delete_and_reopen
|
||||
|
@ -10,11 +10,10 @@
|
||||
%endif
|
||||
%endif
|
||||
%define year %(date +%Y)
|
||||
#% define year 2020
|
||||
|
||||
Name: libsqlite
|
||||
Epoch: 1
|
||||
Version: 3.46.1
|
||||
Version: 3.47.0
|
||||
Release: 1mamba
|
||||
Summary: A C library that implements an embeddable SQL database engine
|
||||
Group: System/Libraries
|
||||
@ -24,11 +23,8 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.sqlite.org/index.html
|
||||
Source0: https://www.sqlite.org/%{year}/sqlite-autoconf-%{real_version}.tar.gz
|
||||
Source1: https://www.sqlite.org/%{year}/sqlite-doc-%{doc_version}.zip
|
||||
Patch0: %{name}-3.7.11.0-enable_column_metadata.patch
|
||||
Patch1: %{name}-3.6.18-libdl.patch
|
||||
# support a system-wide lemon template
|
||||
Patch2: libsqlite-3.6.23.1-lemon-system-template.patch
|
||||
Patch3: libsqlite-3.7.4-wal2-nodirsync.patch
|
||||
Patch0: libsqlite-3.7.11.0-enable_column_metadata.patch
|
||||
Patch1: libsqlite-3.47.0-tcl-8.6.15.patch
|
||||
License: Public Domain
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -102,9 +98,7 @@ Tcl binding for %{name}.
|
||||
%prep
|
||||
%setup -q -n sqlite-autoconf-%{real_version} -a1
|
||||
%patch 0 -p1
|
||||
#%patch1 -p1
|
||||
#%patch2 -p0
|
||||
#%patch3 -p1
|
||||
%patch 1 -p1
|
||||
|
||||
rm -f sqlite-doc-%{real_version}%{?rel}/search
|
||||
|
||||
@ -180,8 +174,6 @@ make test || :
|
||||
%clean
|
||||
[ %{buildroot} != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-, root, root)
|
||||
@ -219,6 +211,9 @@ make test || :
|
||||
%{_mandir}/mann/*
|
||||
|
||||
%changelog
|
||||
* Sat Nov 09 2024 Automatic Build System <autodist@openmamba.org> 3.47.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Aug 14 2024 Automatic Build System <autodist@openmamba.org> 3.46.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user