update to 1.2rc1 [release 1.2rc1-1mamba;Sat Dec 08 2012]

This commit is contained in:
Automatic Build System 2024-01-06 05:50:01 +01:00
parent ba9bbde68f
commit 0b83136773
4 changed files with 135 additions and 0 deletions

View File

@ -1,2 +1,7 @@
# libspeex
Speex is an Open Source/Free Software patent-free audio compression format designed for speech.
The Speex Project aims to lower the barrier of entry for voice applications by providing a free alternative to expensive proprietary speech codecs.
Moreover, Speex is well-adapted to Internet applications and provides useful features that are not present in most other codecs.
Finally, Speex is part of the GNU Project and is available under the Xiph.org variant of the BSD license.

102
libspeex.spec Normal file
View File

@ -0,0 +1,102 @@
Name: libspeex
Version: 1.2rc1
Release: 1mamba
Summary: Open Source/Free Software patent-free audio compression format designed for speech
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://speex.org/
Source: http://downloads.us.xiph.org/releases/speex/speex-%{version}.tar.gz
Patch1: speex-1.1.6-fix-pkgconfig-path.patch
Patch2: speex-1.2-CVE-2008-1686.diff
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libogg-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
Provides: libspeexdsp
Obsoletes: libspeexdsp
%description
Speex is an Open Source/Free Software patent-free audio compression format designed for speech.
The Speex Project aims to lower the barrier of entry for voice applications by providing a free alternative to expensive proprietary speech codecs.
Moreover, Speex is well-adapted to Internet applications and provides useful features that are not present in most other codecs.
Finally, Speex is part of the GNU Project and is available under the Xiph.org variant of the BSD license.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libspeexdsp-devel
Obsoletes: libspeexdsp-devel
%description devel
Speex is an Open Source/Free Software patent-free audio compression format designed for speech.
The Speex Project aims to lower the barrier of entry for voice applications by providing a free alternative to expensive proprietary speech codecs.
Moreover, Speex is well-adapted to Internet applications and provides useful features that are not present in most other codecs.
This package contains static libraries and header files need for development.
%prep
%setup -q -n speex-%{version}
%patch1 -p1 -b .pkgconfig
%patch2 -p1 -b .CVE-2008-1686
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall
# remove uppackaged files
rm -f %{buildroot}%{_datadir}/doc/speex/manual.pdf
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/speexdec
%{_bindir}/speexenc
%{_libdir}/libspeex.so.*
%{_libdir}/libspeexdsp.so.*
%{_mandir}/man1/speexdec.*
%{_mandir}/man1/speexenc.*
%doc AUTHORS COPYING ChangeLog NEWS README TODO
%files devel
%defattr(-,root,root)
%{_datadir}/aclocal/speex.m4
%{_includedir}/speex/*.h
%{_libdir}/*.a
%{_libdir}/*.la
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%doc doc/manual.pdf
%changelog
* Sat Dec 08 2012 Automatic Build System <autodist@mambasoft.it> 1.2rc1-1mamba
- update to 1.2rc1
* Mon Aug 01 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2-3mamba
- rebuilt to add pkgconfig provides
* Fri Jul 10 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2-2mamba
- updated to 1.2rc1
- obsolete libspeexdsp
* Wed Aug 01 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2-1mamba
- update to 1.2 (beta2)
* Fri Jan 19 2007 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.5-2qilnx
- fixed speex.m4 (underquoted definition of XIPH_PATH_SPEEX)
* Thu Jun 09 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.5-1qilnx
- package created by autospec

View File

@ -0,0 +1,11 @@
--- speex-1.1.6/speex.pc.in~ 2005-01-19 10:22:32.928640949 +0100
+++ speex-1.1.6/speex.pc.in 2005-01-19 10:26:49.044726591 +0100
@@ -3,7 +3,7 @@
prefix=@prefix@
exec_prefix=@exec_prefix@
libdir=@libdir@
-includedir=@includedir@
+includedir=@includedir@/speex
Name: speex
Description: Speex is an audio codec tuned for speech

View File

@ -0,0 +1,17 @@
diff -pruN speex-1.2beta2.orig/libspeex/speex_header.c speex-1.2beta2/libspeex/speex_header.c
--- speex-1.2beta2.orig/libspeex/speex_header.c 2007-03-18 13:25:09.000000000 +0100
+++ speex-1.2beta2/libspeex/speex_header.c 2008-04-15 17:15:18.000000000 +0200
@@ -161,6 +161,13 @@ SpeexHeader *speex_packet_to_header(char
ENDIAN_SWITCH(le_header->frames_per_packet);
ENDIAN_SWITCH(le_header->extra_headers);
+ if (le_header->mode >= SPEEX_NB_MODES || le_header->mode < 0)
+ {
+ speex_warning ("Invalid mode specified in Speex header");
+ speex_free (le_header);
+ return NULL;
+ }
+
return le_header;
}