rebuilt with rpm5 patch and build options from pld [release 0.6.34-2mamba;Sat Jun 01 2019]
This commit is contained in:
parent
15ec47b0cd
commit
b7396071a6
11
libsolv-0.6.34-python.patch
Normal file
11
libsolv-0.6.34-python.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- libsolv-0.6.19/bindings/python/CMakeLists.txt.orig 2016-02-19 22:55:50.640253346 +0100
|
||||||
|
+++ libsolv-0.6.19/bindings/python/CMakeLists.txt 2016-02-19 23:16:50.826867127 +0100
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
FIND_PACKAGE (PythonLibs REQUIRED)
|
||||||
|
FIND_PACKAGE (PythonInterp ${PYTHONLIBS_VERSION_STRING} REQUIRED)
|
||||||
|
|
||||||
|
-EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c "from sys import stdout; from distutils import sysconfig; stdout.write(sysconfig.get_python_lib(True))" OUTPUT_VARIABLE PYTHON_INSTALL_DIR)
|
||||||
|
+EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c "from sys import stdout; from distutils import sysconfig; stdout.write(sysconfig.get_python_lib(plat_specific=True, prefix='/usr'))" OUTPUT_VARIABLE PYTHON_INSTALL_DIR)
|
||||||
|
|
||||||
|
IF (NOT DEFINED PYTHON_VERSION_MAJOR)
|
||||||
|
SET (PYTHON_VERSION_MAJOR 2)
|
30
libsolv-0.6.34-rpm-5.2.patch
Normal file
30
libsolv-0.6.34-rpm-5.2.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
Only in libsolv-0.6.34.patched: build
|
||||||
|
diff -ru libsolv-0.6.34/ext/repo_pubkey.c libsolv-0.6.34.patched/ext/repo_pubkey.c
|
||||||
|
--- libsolv-0.6.34/ext/repo_pubkey.c 2018-05-17 00:43:25.000000000 +0200
|
||||||
|
+++ libsolv-0.6.34.patched/ext/repo_pubkey.c 2019-06-01 10:15:43.608634150 +0200
|
||||||
|
@@ -28,6 +28,7 @@
|
||||||
|
#ifndef RPM5
|
||||||
|
#include <rpm/header.h>
|
||||||
|
#endif
|
||||||
|
+#include <rpm/rpm46compat.h>
|
||||||
|
#include <rpm/rpmdb.h>
|
||||||
|
|
||||||
|
#include "pool.h"
|
||||||
|
@@ -757,7 +758,7 @@
|
||||||
|
#ifndef RPM5
|
||||||
|
dig = pgpNewDig();
|
||||||
|
#else
|
||||||
|
- dig = pgpDigNew(RPMVSF_DEFAULT, 0);
|
||||||
|
+ dig = pgpDigNew(RPMVSF_DEFAULT);
|
||||||
|
#endif
|
||||||
|
(void) pgpPrtPkts(pkts, pktsl, dig, 0);
|
||||||
|
#ifdef HAVE_PGPDIGGETPARAMS
|
||||||
|
@@ -782,7 +783,7 @@
|
||||||
|
#ifndef RPM5
|
||||||
|
(void)pgpFreeDig(dig);
|
||||||
|
#else
|
||||||
|
- (void)pgpDigFree(dig);
|
||||||
|
+ (void)pgpDigFree(dig, 0);
|
||||||
|
#endif
|
||||||
|
}
|
||||||
|
|
39
libsolv-0.6.34-rpm-5.patch
Normal file
39
libsolv-0.6.34-rpm-5.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
(partial, not finished: rpmdbIndex* and headerImport APIs are used)
|
||||||
|
--- libsolv-0.6.34/ext/repo_rpmdb_librpm.h.orig 2018-03-23 12:04:14.000000000 +0100
|
||||||
|
+++ libsolv-0.6.34/ext/repo_rpmdb_librpm.h 2018-05-10 20:28:01.213443653 +0200
|
||||||
|
@@ -15,6 +15,12 @@
|
||||||
|
#include <rpm/rpmts.h>
|
||||||
|
#include <rpm/rpmmacro.h>
|
||||||
|
|
||||||
|
+#ifdef RPM5
|
||||||
|
+#define _RPMVSF_NOSIGNATURES (RPMVSF_NODSAHEADER | RPMVSF_NORSAHEADER | RPMVSF_NODSA | RPMVSF_NORSA)
|
||||||
|
+#define _RPMVSF_NODIGESTS (RPMVSF_NOSHA1HEADER | RPMVSF_NOMD5HEADER | RPMVSF_NOSHA1 | RPMVSF_NOMD5)
|
||||||
|
+#define _RPMVSF_NOHEADER (RPMVSF_NOSHA1HEADER | RPMVSF_NOMD5HEADER | RPMVSF_NODSAHEADER | RPMVSF_NORSAHEADER)
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
struct rpmdbstate {
|
||||||
|
Pool *pool;
|
||||||
|
char *rootdir;
|
||||||
|
--- libsolv-0.6.34/ext/repo_rpmdb.c.orig 2018-03-23 12:04:14.000000000 +0100
|
||||||
|
+++ libsolv-0.6.34/ext/repo_rpmdb.c 2018-05-10 19:30:12.563483259 +0200
|
||||||
|
@@ -30,6 +30,8 @@
|
||||||
|
#include <rpm/rpmpgp.h>
|
||||||
|
#ifndef RPM5
|
||||||
|
#include <rpm/header.h>
|
||||||
|
+#else
|
||||||
|
+#include <rpm/rpm46compat.h>
|
||||||
|
#endif
|
||||||
|
#include <rpm/rpmdb.h>
|
||||||
|
|
||||||
|
@@ -457,7 +459,11 @@
|
||||||
|
static int
|
||||||
|
headissourceheuristic(RpmHead *h)
|
||||||
|
{
|
||||||
|
+#ifdef RPM5
|
||||||
|
+ return !headerIsEntry(h, RPMTAG_SOURCERPM);
|
||||||
|
+#else
|
||||||
|
return headerIsSource(h);
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
static inline void
|
11
libsolv-0.6.34-swig-4.0.0.patch
Normal file
11
libsolv-0.6.34-swig-4.0.0.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- libsolv-0.6.34/bindings/solv.i.orig 2019-06-01 10:55:51.388501920 +0200
|
||||||
|
+++ libsolv-0.6.34/bindings/solv.i 2019-06-01 10:56:02.810556652 +0200
|
||||||
|
@@ -573,7 +573,7 @@
|
||||||
|
#if defined(SWIGRUBY)
|
||||||
|
SWIG_ConvertPtr(self, &argp1,SWIGTYPE_p_Pool, SWIG_POINTER_DISOWN | 0 );
|
||||||
|
#elif defined(SWIGPYTHON)
|
||||||
|
- SWIG_ConvertPtr(obj0, &argp1,SWIGTYPE_p_Pool, SWIG_POINTER_DISOWN | 0 );
|
||||||
|
+ SWIG_ConvertPtr(swig_obj[0], &argp1,SWIGTYPE_p_Pool, SWIG_POINTER_DISOWN | 0 );
|
||||||
|
#elif defined(SWIGPERL)
|
||||||
|
SWIG_ConvertPtr(ST(0), &argp1,SWIGTYPE_p_Pool, SWIG_POINTER_DISOWN | 0 );
|
||||||
|
#elif defined(SWIGTCL)
|
63
libsolv.spec
63
libsolv.spec
@ -1,6 +1,6 @@
|
|||||||
Name: libsolv
|
Name: libsolv
|
||||||
Version: 0.6.34
|
Version: 0.6.34
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Library for solving packages and reading repositories
|
Summary: Library for solving packages and reading repositories
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,10 +8,22 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://en.opensuse.org/openSUSE:Libzypp_satsolver
|
URL: http://en.opensuse.org/openSUSE:Libzypp_satsolver
|
||||||
Source: https://github.com/openSUSE/libsolv.git/%{version}/libsolv-%{version}.tar.bz2
|
Source: https://github.com/openSUSE/libsolv.git/%{version}/libsolv-%{version}.tar.bz2
|
||||||
|
Patch0: libsolv-0.6.34-rpm-5.patch
|
||||||
|
Patch1: libsolv-0.6.34-rpm-5.2.patch
|
||||||
|
Patch2: libsolv-0.6.34-python.patch
|
||||||
|
Patch3: libsolv-0.6.34-swig-4.0.0.patch
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libbzip2-devel
|
||||||
|
BuildRequires: libexpat-devel
|
||||||
|
BuildRequires: liblzma-devel
|
||||||
|
BuildRequires: libperl
|
||||||
|
BuildRequires: libpython-devel
|
||||||
|
BuildRequires: libtcl-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: perl-devel
|
||||||
|
BuildRequires: rpm-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -40,9 +52,32 @@ This package contains utility applications for %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build
|
%cmake -d build \
|
||||||
|
-DENABLE_APPDATA=ON \
|
||||||
|
-DENABLE_BZIP2_COMPRESSION=ON \
|
||||||
|
-DENABLE_COMPLEX_DEPS=ON \
|
||||||
|
-DENABLE_HELIXREPO=ON \
|
||||||
|
-DENABLE_LZMA_COMPRESSION=ON \
|
||||||
|
-DENABLE_PUBKEY=ON \
|
||||||
|
-DENABLE_RPMDB=ON \
|
||||||
|
-DENABLE_RPMDB_BYRPMHEADER=ON \
|
||||||
|
-DENABLE_RPMMD=ON \
|
||||||
|
-DRPM5=ON \
|
||||||
|
-DENABLE_PERL=ON \
|
||||||
|
-DENABLE_PYTHON=ON \
|
||||||
|
-DENABLE_RUBY=ON \
|
||||||
|
-DENABLE_TCL=ON \
|
||||||
|
-DPythonLibs_FIND_VERSION=2 \
|
||||||
|
-DPythonLibs_FIND_VERSION_MAJOR=2 \
|
||||||
|
-DUSE_VENDORDIRS=ON \
|
||||||
|
-DCMAKE_C_FLAGS="%{optflags} -Doff64_t=__off64_t"
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -61,6 +96,11 @@ cp ext/*.h %{buildroot}%{_includedir}/solv/
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libsolv.so.*
|
%{_libdir}/libsolv.so.*
|
||||||
%{_libdir}/libsolvext.so.*
|
%{_libdir}/libsolvext.so.*
|
||||||
|
%{perl_vendorarch}/solv.*
|
||||||
|
%{_libdir}/ruby/vendor_ruby/*/*-linux-gnu*/solv.so
|
||||||
|
%{_prefix}/lib/tcl8/*/solv-%{version}.*
|
||||||
|
%{python27_sitearch}/_solv.so
|
||||||
|
%{python27_sitearch}/solv.py
|
||||||
%doc CREDITS
|
%doc CREDITS
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
@ -81,16 +121,35 @@ cp ext/*.h %{buildroot}%{_includedir}/solv/
|
|||||||
|
|
||||||
%files tools
|
%files tools
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/appdata2solv
|
||||||
|
%{_bindir}/deltainfoxml2solv
|
||||||
%{_bindir}/dumpsolv
|
%{_bindir}/dumpsolv
|
||||||
|
%{_bindir}/helix2solv
|
||||||
%{_bindir}/installcheck
|
%{_bindir}/installcheck
|
||||||
%{_bindir}/mergesolv
|
%{_bindir}/mergesolv
|
||||||
%{_bindir}/repo2solv.sh
|
%{_bindir}/repo2solv.sh
|
||||||
%{_bindir}/testsolv
|
%{_bindir}/testsolv
|
||||||
|
%{_bindir}/repomdxml2solv
|
||||||
|
%{_bindir}/rpmdb2solv
|
||||||
|
%{_bindir}/rpmmd2solv
|
||||||
|
%{_bindir}/rpms2solv
|
||||||
|
%{_bindir}/updateinfoxml2solv
|
||||||
|
%{_mandir}/man1/appdata2solv.1*
|
||||||
|
%{_mandir}/man1/deltainfoxml2solv.1*
|
||||||
%{_mandir}/man1/dumpsolv.1*
|
%{_mandir}/man1/dumpsolv.1*
|
||||||
|
%{_mandir}/man1/helix2solv.1*
|
||||||
%{_mandir}/man1/installcheck.1*
|
%{_mandir}/man1/installcheck.1*
|
||||||
%{_mandir}/man1/mergesolv.1*
|
%{_mandir}/man1/mergesolv.1*
|
||||||
%{_mandir}/man1/testsolv.1*
|
%{_mandir}/man1/testsolv.1*
|
||||||
|
%{_mandir}/man1/repomdxml2solv.1*
|
||||||
|
%{_mandir}/man1/rpmdb2solv.1*
|
||||||
|
%{_mandir}/man1/rpmmd2solv.1*
|
||||||
|
%{_mandir}/man1/rpms2solv.1*
|
||||||
|
%{_mandir}/man1/updateinfoxml2solv.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jun 01 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.34-2mamba
|
||||||
|
- rebuilt with rpm5 patch and build options from pld
|
||||||
|
|
||||||
* Thu May 17 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.34-1mamba
|
* Thu May 17 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.34-1mamba
|
||||||
- package created using the webbuild interface
|
- package created using the webbuild interface
|
||||||
|
Loading…
Reference in New Issue
Block a user