x86_64: added patch to allow cohexistance of packages with same name if from different archs (x86) [release 0.7.5-2mamba;Sun Jun 23 2019]
This commit is contained in:
parent
501a71dcff
commit
5c1a693bd4
13
libsolv-0.7.5-x86_64-multiarch-cohexistance.patch
Normal file
13
libsolv-0.7.5-x86_64-multiarch-cohexistance.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -Nru libsolv-0.7.5/src/rules.c libsolv-0.7.5.patched/src/rules.c
|
||||
--- libsolv-0.7.5/src/rules.c 2019-06-22 17:43:42.000000000 +0200
|
||||
+++ libsolv-0.7.5.patched/src/rules.c 2019-06-23 19:29:11.527890506 +0200
|
||||
@@ -1016,6 +1016,9 @@
|
||||
p = 0;
|
||||
if (s->name == ps->name)
|
||||
{
|
||||
+ /* x86-64: allow cohexistence with x86 arch packages */
|
||||
+ if (ps->arch != s->arch)
|
||||
+ continue;
|
||||
/* optimization: do not add the same-name conflict rule if it was
|
||||
* already added when we looked at the other package.
|
||||
* (this assumes pool_colormatch is symmetric) */
|
54
libsolv.spec
54
libsolv.spec
@ -1,6 +1,6 @@
|
||||
Name: libsolv
|
||||
Version: 0.7.4
|
||||
Release: 3mamba
|
||||
Version: 0.7.5
|
||||
Release: 2mamba
|
||||
Summary: Library for solving packages and reading repositories
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -14,19 +14,22 @@ Patch2: libsolv-0.6.34-python.patch
|
||||
Patch3: libsolv-0.6.34-swig-4.0.0.patch
|
||||
Patch4: libsolv-0.7.4-rpm5-5.2-endianess-fix.patch
|
||||
Patch5: libsolv-0.7.4-rpm5.2-still-has-array-index.patch
|
||||
Patch6: libsolv-0.7.5-x86_64-multiarch-cohexistance.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libdb53-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libperl
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libtcl-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: rpm-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: librpm-devel >= 1:4.14.2.1
|
||||
BuildRequires: cmake
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
@ -54,12 +57,15 @@ This package contains utility applications for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
#%patch3 -p1
|
||||
#%patch4 -p1
|
||||
#%patch5 -p1
|
||||
%ifarch x86_64
|
||||
%patch6 -p1
|
||||
%endif
|
||||
|
||||
%build
|
||||
%cmake -d build \
|
||||
@ -69,18 +75,27 @@ This package contains utility applications for %{name}.
|
||||
-DENABLE_LZMA_COMPRESSION=ON \
|
||||
-DENABLE_ZCHUNK_COMPRESSION=ON \
|
||||
-DENABLE_RPMDB=ON \
|
||||
-DENABLE_RPMPKG=ON \
|
||||
-DENABLE_RPMDB_BYRPMHEADER=ON \
|
||||
-DENABLE_RPMDB_LIBRPM=ON \
|
||||
-DENABLE_RPMPKG_LIBRPM=ON \
|
||||
-DENABLE_RPMMD=ON \
|
||||
-DWITH_LIBXML2=ON \
|
||||
-DRPM5=ON \
|
||||
-DENABLE_PERL=ON \
|
||||
-DENABLE_PYTHON=ON \
|
||||
-DENABLE_RUBY=ON \
|
||||
-DENABLE_TCL=ON \
|
||||
-DPythonLibs_FIND_VERSION=2 \
|
||||
-DPythonLibs_FIND_VERSION_MAJOR=2 \
|
||||
-DUSE_VENDORDIRS=ON \
|
||||
-DCMAKE_C_FLAGS="%{optflags} -Doff64_t=__off64_t"
|
||||
-DENABLE_LZMA_COMPRESSION=ON \
|
||||
-DENABLE_BZIP2_COMPRESSION=ON \
|
||||
-DENABLE_ZCHUNK_COMPRESSIO=ON \
|
||||
-DWITH_SYSTEM_ZCHUNK=ON \
|
||||
-DENABLE_PYTHON=ON \
|
||||
-DPYTHON_EXECUTABLE=%{__python27} \
|
||||
-DENABLE_PYTHON3=ON \
|
||||
-DPYTHON3_EXECUTABLE=%{__python36} \
|
||||
-DUSE_VENDORDIRS=ON
|
||||
|
||||
# -DPythonLibs_FIND_VERSION=2 \
|
||||
# -DPythonLibs_FIND_VERSION_MAJOR=2 \
|
||||
|
||||
%make
|
||||
|
||||
@ -105,6 +120,8 @@ cp ext/*.h %{buildroot}%{_includedir}/solv/
|
||||
%{_prefix}/lib/tcl8/*/solv-%{version}.*
|
||||
%{python27_sitearch}/_solv.so
|
||||
%{python27_sitearch}/solv.py
|
||||
%{python36_sitearch}/_solv.so
|
||||
%{python36_sitearch}/solv.py
|
||||
%doc CREDITS
|
||||
|
||||
%files devel
|
||||
@ -152,6 +169,13 @@ cp ext/*.h %{buildroot}%{_includedir}/solv/
|
||||
%{_mandir}/man1/updateinfoxml2solv.1*
|
||||
|
||||
%changelog
|
||||
* Sun Jun 23 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.5-2mamba
|
||||
- x86_64: added patch to allow cohexistance of packages with same name if from different archs (x86)
|
||||
|
||||
* Sat Jun 22 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.5-1mamba
|
||||
- update to 0.7.5
|
||||
- rebuilt with rpm 4, removed rpm 5 patches
|
||||
|
||||
* Wed Jun 05 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.4-3mamba
|
||||
- added upstream patch to fix endianess with rpm 5.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user