rebuilt with rpm 4.19.1.1 [release 0.7.29-2mamba;Mon May 13 2024]
This commit is contained in:
parent
29b57136e6
commit
424e5af4dc
@ -1,11 +0,0 @@
|
|||||||
--- libsolv-0.6.19/bindings/python/CMakeLists.txt.orig 2016-02-19 22:55:50.640253346 +0100
|
|
||||||
+++ libsolv-0.6.19/bindings/python/CMakeLists.txt 2016-02-19 23:16:50.826867127 +0100
|
|
||||||
@@ -2,7 +2,7 @@
|
|
||||||
FIND_PACKAGE (PythonLibs REQUIRED)
|
|
||||||
FIND_PACKAGE (PythonInterp ${PYTHONLIBS_VERSION_STRING} REQUIRED)
|
|
||||||
|
|
||||||
-EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c "from sys import stdout; from distutils import sysconfig; stdout.write(sysconfig.get_python_lib(True))" OUTPUT_VARIABLE PYTHON_INSTALL_DIR)
|
|
||||||
+EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c "from sys import stdout; from distutils import sysconfig; stdout.write(sysconfig.get_python_lib(plat_specific=True, prefix='/usr'))" OUTPUT_VARIABLE PYTHON_INSTALL_DIR)
|
|
||||||
|
|
||||||
IF (NOT DEFINED PYTHON_VERSION_MAJOR)
|
|
||||||
SET (PYTHON_VERSION_MAJOR 2)
|
|
@ -1,30 +0,0 @@
|
|||||||
Only in libsolv-0.6.34.patched: build
|
|
||||||
diff -ru libsolv-0.6.34/ext/repo_pubkey.c libsolv-0.6.34.patched/ext/repo_pubkey.c
|
|
||||||
--- libsolv-0.6.34/ext/repo_pubkey.c 2018-05-17 00:43:25.000000000 +0200
|
|
||||||
+++ libsolv-0.6.34.patched/ext/repo_pubkey.c 2019-06-01 10:15:43.608634150 +0200
|
|
||||||
@@ -28,6 +28,7 @@
|
|
||||||
#ifndef RPM5
|
|
||||||
#include <rpm/header.h>
|
|
||||||
#endif
|
|
||||||
+#include <rpm/rpm46compat.h>
|
|
||||||
#include <rpm/rpmdb.h>
|
|
||||||
|
|
||||||
#include "pool.h"
|
|
||||||
@@ -757,7 +758,7 @@
|
|
||||||
#ifndef RPM5
|
|
||||||
dig = pgpNewDig();
|
|
||||||
#else
|
|
||||||
- dig = pgpDigNew(RPMVSF_DEFAULT, 0);
|
|
||||||
+ dig = pgpDigNew(RPMVSF_DEFAULT);
|
|
||||||
#endif
|
|
||||||
(void) pgpPrtPkts(pkts, pktsl, dig, 0);
|
|
||||||
#ifdef HAVE_PGPDIGGETPARAMS
|
|
||||||
@@ -782,7 +783,7 @@
|
|
||||||
#ifndef RPM5
|
|
||||||
(void)pgpFreeDig(dig);
|
|
||||||
#else
|
|
||||||
- (void)pgpDigFree(dig);
|
|
||||||
+ (void)pgpDigFree(dig, 0);
|
|
||||||
#endif
|
|
||||||
}
|
|
||||||
|
|
@ -1,11 +0,0 @@
|
|||||||
--- libsolv-0.6.34/bindings/solv.i.orig 2019-06-01 10:55:51.388501920 +0200
|
|
||||||
+++ libsolv-0.6.34/bindings/solv.i 2019-06-01 10:56:02.810556652 +0200
|
|
||||||
@@ -573,7 +573,7 @@
|
|
||||||
#if defined(SWIGRUBY)
|
|
||||||
SWIG_ConvertPtr(self, &argp1,SWIGTYPE_p_Pool, SWIG_POINTER_DISOWN | 0 );
|
|
||||||
#elif defined(SWIGPYTHON)
|
|
||||||
- SWIG_ConvertPtr(obj0, &argp1,SWIGTYPE_p_Pool, SWIG_POINTER_DISOWN | 0 );
|
|
||||||
+ SWIG_ConvertPtr(swig_obj[0], &argp1,SWIGTYPE_p_Pool, SWIG_POINTER_DISOWN | 0 );
|
|
||||||
#elif defined(SWIGPERL)
|
|
||||||
SWIG_ConvertPtr(ST(0), &argp1,SWIGTYPE_p_Pool, SWIG_POINTER_DISOWN | 0 );
|
|
||||||
#elif defined(SWIGTCL)
|
|
@ -1,27 +0,0 @@
|
|||||||
(partial, not finished: rpmdbIndex* and headerImport APIs are used)
|
|
||||||
--- libsolv-0.6.34/ext/repo_rpmdb_librpm.h.orig 2018-03-23 12:04:14.000000000 +0100
|
|
||||||
+++ libsolv-0.6.34/ext/repo_rpmdb_librpm.h 2018-05-10 20:28:01.213443653 +0200
|
|
||||||
@@ -15,6 +15,12 @@
|
|
||||||
#include <rpm/rpmts.h>
|
|
||||||
#include <rpm/rpmmacro.h>
|
|
||||||
|
|
||||||
+#ifdef RPM5
|
|
||||||
+#define _RPMVSF_NOSIGNATURES (RPMVSF_NODSAHEADER | RPMVSF_NORSAHEADER | RPMVSF_NODSA | RPMVSF_NORSA)
|
|
||||||
+#define _RPMVSF_NODIGESTS (RPMVSF_NOSHA1HEADER | RPMVSF_NOMD5HEADER | RPMVSF_NOSHA1 | RPMVSF_NOMD5)
|
|
||||||
+#define _RPMVSF_NOHEADER (RPMVSF_NOSHA1HEADER | RPMVSF_NOMD5HEADER | RPMVSF_NODSAHEADER | RPMVSF_NORSAHEADER)
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
struct rpmdbstate {
|
|
||||||
Pool *pool;
|
|
||||||
char *rootdir;
|
|
||||||
--- libsolv-0.6.35/ext/repo_rpmdb.c.orig 2019-06-04 17:32:58.000000000 +0200
|
|
||||||
+++ libsolv-0.6.35/ext/repo_rpmdb.c 2019-06-04 17:33:15.457951815 +0200
|
|
||||||
@@ -30,6 +30,8 @@
|
|
||||||
#include <rpm/rpmpgp.h>
|
|
||||||
#ifndef RPM5
|
|
||||||
#include <rpm/header.h>
|
|
||||||
+#else
|
|
||||||
+#include <rpm/rpm46compat.h>
|
|
||||||
#endif
|
|
||||||
#include <rpm/rpmdb.h>
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
--- libsolv-0.7.15/src/rules.c.orig 2020-09-13 11:49:27.386000000 +0200
|
|
||||||
+++ libsolv-0.7.15/src/rules.c 2020-09-13 11:46:18.006000000 +0200
|
|
||||||
@@ -1075,6 +1075,9 @@
|
|
||||||
p = 0;
|
|
||||||
if (s->name == ps->name)
|
|
||||||
{
|
|
||||||
+ /* x86-64: allow cohexistence with x86 arch packages */
|
|
||||||
+ if (ps->arch != s->arch && !s->supplements)
|
|
||||||
+ continue;
|
|
||||||
/* optimization: do not add the same-name conflict rule if it was
|
|
||||||
* already added when we looked at the other package.
|
|
||||||
* (this assumes pool_colormatch is symmetric) */
|
|
@ -1,50 +0,0 @@
|
|||||||
From 68d72a88d5dc983aff2ff5dce65581de0ee42b6d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Schroeder <mls@suse.de>
|
|
||||||
Date: Wed, 5 Jun 2019 15:58:55 +0200
|
|
||||||
Subject: [PATCH] Make libsolv work with rpm 5.2
|
|
||||||
|
|
||||||
Version 5.2 still used native endian encoding for the database ids.
|
|
||||||
---
|
|
||||||
ext/repo_rpmdb_bdb.h | 12 +++++++++---
|
|
||||||
1 file changed, 9 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/ext/repo_rpmdb_bdb.h b/ext/repo_rpmdb_bdb.h
|
|
||||||
index ed82a69c..d0053f71 100644
|
|
||||||
--- a/ext/repo_rpmdb_bdb.h
|
|
||||||
+++ b/ext/repo_rpmdb_bdb.h
|
|
||||||
@@ -27,6 +27,13 @@
|
|
||||||
# define RPM_INDEX_SIZE 8 /* rpmdbid + array index */
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#ifdef RPM5
|
|
||||||
+# include <rpm/rpmversion.h>
|
|
||||||
+# if RPMLIB_VERSION_GE(5,3,_,0,0,_)
|
|
||||||
+# define RPM5_BIG_ENDIAN_ID
|
|
||||||
+# endif
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
|
|
||||||
/******************************************************************/
|
|
||||||
/* Rpm Database stuff
|
|
||||||
@@ -66,11 +73,10 @@ stat_database(struct rpmdbstate *state, char *dbname, struct stat *statbuf, int
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
-
|
|
||||||
static inline Id
|
|
||||||
db2rpmdbid(unsigned char *db, int byteswapped)
|
|
||||||
{
|
|
||||||
-#ifdef RPM5
|
|
||||||
+#ifdef RPM5_BIG_ENDIAN_ID
|
|
||||||
return db[0] << 24 | db[1] << 16 | db[2] << 8 | db[3];
|
|
||||||
#else
|
|
||||||
# if defined(WORDS_BIGENDIAN)
|
|
||||||
@@ -87,7 +93,7 @@ db2rpmdbid(unsigned char *db, int byteswapped)
|
|
||||||
static inline void
|
|
||||||
rpmdbid2db(unsigned char *db, Id id, int byteswapped)
|
|
||||||
{
|
|
||||||
-#ifdef RPM5
|
|
||||||
+#ifdef RPM5_BIG_ENDIAN_ID
|
|
||||||
db[0] = id >> 24, db[1] = id >> 16, db[2] = id >> 8, db[3] = id;
|
|
||||||
#else
|
|
||||||
# if defined(WORDS_BIGENDIAN)
|
|
@ -1,38 +0,0 @@
|
|||||||
From 841287dfb7a5992b374aa5326e776cd7d54fc0da Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Schroeder <mls@suse.de>
|
|
||||||
Date: Wed, 5 Jun 2019 16:16:09 +0200
|
|
||||||
Subject: [PATCH] rpm-5.2 still had an array index
|
|
||||||
|
|
||||||
---
|
|
||||||
ext/repo_rpmdb_bdb.h | 15 +++++++--------
|
|
||||||
1 file changed, 7 insertions(+), 8 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/ext/repo_rpmdb_bdb.h b/ext/repo_rpmdb_bdb.h
|
|
||||||
index d0053f71..c680da6b 100644
|
|
||||||
--- a/ext/repo_rpmdb_bdb.h
|
|
||||||
+++ b/ext/repo_rpmdb_bdb.h
|
|
||||||
@@ -21,17 +21,16 @@
|
|
||||||
# endif
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#ifdef RPM5
|
|
||||||
-# define RPM_INDEX_SIZE 4 /* just the rpmdbid */
|
|
||||||
-#else
|
|
||||||
-# define RPM_INDEX_SIZE 8 /* rpmdbid + array index */
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
#ifdef RPM5
|
|
||||||
# include <rpm/rpmversion.h>
|
|
||||||
-# if RPMLIB_VERSION_GE(5,3,_,0,0,_)
|
|
||||||
+# if RPMLIB_VERSION < RPMLIB_VERSION_ENCODE(5,3,_,0,0,_)
|
|
||||||
+# define RPM_INDEX_SIZE 8 /* rpmdbid + array index */
|
|
||||||
+# else
|
|
||||||
+# define RPM_INDEX_SIZE 4 /* just the rpmdbid */
|
|
||||||
# define RPM5_BIG_ENDIAN_ID
|
|
||||||
-# endif
|
|
||||||
+#endif
|
|
||||||
+#else
|
|
||||||
+# define RPM_INDEX_SIZE 8 /* rpmdbid + array index */
|
|
||||||
#endif
|
|
||||||
|
|
||||||
|
|
29
libsolv.spec
29
libsolv.spec
@ -1,6 +1,6 @@
|
|||||||
Name: libsolv
|
Name: libsolv
|
||||||
Version: 0.7.29
|
Version: 0.7.29
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Library for solving packages and reading repositories
|
Summary: Library for solving packages and reading repositories
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,20 +8,13 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://en.opensuse.org/openSUSE:Libzypp_satsolver
|
URL: https://en.opensuse.org/openSUSE:Libzypp_satsolver
|
||||||
Source: https://github.com/openSUSE/libsolv.git/%{version}/libsolv-%{version}.tar.bz2
|
Source: https://github.com/openSUSE/libsolv.git/%{version}/libsolv-%{version}.tar.bz2
|
||||||
Patch0: libsolv-0.6.35-rpm-5.patch
|
|
||||||
Patch1: libsolv-0.6.34-rpm-5.2.patch
|
|
||||||
Patch2: libsolv-0.6.34-python.patch
|
|
||||||
Patch3: libsolv-0.6.34-swig-4.0.0.patch
|
|
||||||
Patch4: libsolv-0.7.4-rpm5-5.2-endianess-fix.patch
|
|
||||||
Patch5: libsolv-0.7.4-rpm5.2-still-has-array-index.patch
|
|
||||||
Patch6: libsolv-0.7.15-x86_64-multiarch-coexistence.patch
|
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libbzip2-devel
|
BuildRequires: libbzip2-devel
|
||||||
BuildRequires: liblzma-devel
|
BuildRequires: liblzma-devel
|
||||||
BuildRequires: libperl
|
BuildRequires: libperl
|
||||||
BuildRequires: libpython310-devel
|
BuildRequires: libpython311-devel
|
||||||
BuildRequires: librpm-devel
|
BuildRequires: librpm-devel
|
||||||
BuildRequires: libtcl-devel
|
BuildRequires: libtcl-devel
|
||||||
BuildRequires: libxml2-devel
|
BuildRequires: libxml2-devel
|
||||||
@ -30,7 +23,8 @@ BuildRequires: libzck-devel
|
|||||||
BuildRequires: libzstd-devel
|
BuildRequires: libzstd-devel
|
||||||
BuildRequires: perl-devel
|
BuildRequires: perl-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: librpm-devel >= 4.16.1.2-1mamba
|
BuildRequires: librpm-devel >= 4.19.1.1
|
||||||
|
BuildRequires: libtk-devel
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -65,10 +59,6 @@ This package contains the Python bindings for %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch2 -p1
|
|
||||||
#%ifarch x86_64
|
|
||||||
#%patch6 -p1
|
|
||||||
#%endif
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
@ -93,12 +83,10 @@ This package contains the Python bindings for %{name}.
|
|||||||
-DWITH_SYSTEM_ZCHUNK=ON \
|
-DWITH_SYSTEM_ZCHUNK=ON \
|
||||||
-DENABLE_PYTHON=OFF \
|
-DENABLE_PYTHON=OFF \
|
||||||
-DENABLE_PYTHON3=ON \
|
-DENABLE_PYTHON3=ON \
|
||||||
-DPYTHON3_EXECUTABLE=%{__python310} \
|
-DPYTHON3_EXECUTABLE=%{__python3} \
|
||||||
-DUSE_VENDORDIRS=ON \
|
-DUSE_VENDORDIRS=ON \
|
||||||
-DFEDORA=ON
|
-DFEDORA=ON
|
||||||
|
|
||||||
# -DPYTHON_EXECUTABLE=%{__python27} \
|
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -169,10 +157,13 @@ cp ext/*.h %{buildroot}%{_includedir}/solv/
|
|||||||
|
|
||||||
%files -n python-libsolv-py3
|
%files -n python-libsolv-py3
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{python310_sitearch}/_solv.so
|
%{python3_sitearch}/_solv.so
|
||||||
%{python310_sitearch}/solv.py
|
%{python3_sitearch}/solv.py
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 13 2024 Automatic Build System <autodist@openmamba.org> 0.7.29-2mamba
|
||||||
|
- rebuilt with rpm 4.19.1.1
|
||||||
|
|
||||||
* Tue Apr 30 2024 Automatic Build System <autodist@openmamba.org> 0.7.29-1mamba
|
* Tue Apr 30 2024 Automatic Build System <autodist@openmamba.org> 0.7.29-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user