libslang/libslang-1.4.9-fsuid.patch
Silvan Calarco 28c850952b rebuilt with --enable-wide-chars
build with libonig [release 2.2.4-2mamba;Thu Jul 26 2012]
2024-01-06 05:47:30 +01:00

34 lines
992 B
Diff

diff -ru slang-1.4.9/autoconf/configure.in slang-1.4.9-utf8/autoconf/configure.in
--- slang-1.4.9/autoconf/configure.in 2003-03-23 08:06:40.000000000 +0100
+++ slang-1.4.9-utf8/autoconf/configure.in 2006-01-31 16:12:11.000000000 +0100
@@ -38,8 +38,17 @@
sys/wait.h \
sys/utsname.h \
sys/times.h \
+sys/fsuid.h \
)
+AC_CHECK_FUNCS(setfsuid setfsgid)
+
+if test "${ac_cv_func_setfsuid}" != "yes" || test "${ac_cv_func_setfsgid}" != "yes"; then
+ AC_MSG_ERROR([
+*** setfsguid and setfsgid cannot be found!!!
+ These are needed to support setuid/setgid applications ***])
+fi
+
AC_TYPE_MODE_T
AC_TYPE_PID_T
AC_TYPE_UID_T
diff -ru slang-1.4.9/src/slinclud.h slang-1.4.9-utf8/src/slinclud.h
--- slang-1.4.9/src/slinclud.h 2003-03-23 08:06:40.000000000 +0100
+++ slang-1.4.9-utf8/src/slinclud.h 2006-01-31 16:13:50.000000000 +0100
@@ -27,4 +27,8 @@
# include <memory.h>
#endif
+#ifdef HAVE_SYS_FSUID_H
+# include <sys/fsuid.h>
+#endif
+
#endif /* _SLANG_INCLUDE_H_ */