automatic version update by autodist [release 2.3.1-1mamba;Fri Aug 10 2012]

This commit is contained in:
Automatic Build System 2024-01-06 05:46:06 +01:00
parent b6d00b6ce8
commit c3d5fb1139
3 changed files with 129 additions and 0 deletions

View File

@ -1,2 +1,6 @@
# libshout
Libshout is a library for communicating with and sending data to an icecast server. It handles the socket connection, the timing of the data, and prevents bad data from getting to the icecast server.
With just a few lines of code, a programmer can easily turn any application into a streaming source for an icecast server. Libshout also allows developers who want a specific feature set (database access, request taking) to concentrate on that feature set, instead of worrying about how server communication works.

View File

@ -0,0 +1,34 @@
diff -Nru libshout-2.2.2.orig/shout.pc.in libshout-2.2.2/shout.pc.in
--- libshout-2.2.2.orig/shout.pc.in 2005-09-01 23:52:57.000000000 +0200
+++ libshout-2.2.2/shout.pc.in 2008-12-08 18:53:36.000000000 +0100
@@ -11,5 +11,6 @@
Description: Audio streaming library for icecast encoders
Version: @VERSION@
Requires: @SHOUT_REQUIRES@
+Requires.private: @SHOUT_REQUIRES@
Libs: -L${libdir} -lshout
Cflags: -I${includedir} @PTHREAD_CPPFLAGS@ @SHOUT_CFLAGS@
diff -Nru libshout-2.2.2.orig/src/Makefile.am libshout-2.2.2/src/Makefile.am
--- libshout-2.2.2.orig/src/Makefile.am 2006-01-31 02:42:42.000000000 +0100
+++ libshout-2.2.2/src/Makefile.am 2008-12-08 18:52:51.000000000 +0100
@@ -26,7 +26,7 @@
AM_CFLAGS = @XIPH_CFLAGS@
libshout_la_LIBADD = net/libicenet.la timing/libicetiming.la avl/libiceavl.la\
- httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(VORBIS_LIBS)
+ httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(VORBIS_LIBS) $(SPEEX_LIBS)
INCLUDES = -I$(top_builddir)/include
diff -Nru libshout-2.2.2.orig/src/Makefile.in libshout-2.2.2/src/Makefile.in
--- libshout-2.2.2.orig/src/Makefile.in 2006-06-19 22:36:32.000000000 +0200
+++ libshout-2.2.2/src/Makefile.in 2008-12-08 18:53:15.000000000 +0100
@@ -261,7 +261,7 @@
libshout_la_SOURCES = shout.c util.c ogg.c vorbis.c mp3.c $(MAYBE_THEORA) $(MAYBE_SPEEX)
AM_CFLAGS = @XIPH_CFLAGS@
libshout_la_LIBADD = net/libicenet.la timing/libicetiming.la avl/libiceavl.la\
- httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(VORBIS_LIBS)
+ httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(VORBIS_LIBS) $(SPEEX_LIBS)
INCLUDES = -I$(top_builddir)/include
all: all-recursive

91
libshout.spec Normal file
View File

@ -0,0 +1,91 @@
Name: libshout
Version: 2.3.1
Release: 1mamba
Summary: A library for communicating with and sending data to an icecast server
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@qilinux.it>
URL: http://www.icecast.org
Source: http://downloads.us.xiph.org/releases/libshout/libshout-%{version}.tar.gz
Patch0: %{name}-2.2.2-missing_lib.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libogg-devel
BuildRequires: libspeex-devel
BuildRequires: libtheora-devel
BuildRequires: libvorbis-devel
## AUTOBUILDREQ-END
BuildRequires: pkgconfig >= 0.15.0
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Libshout is a library for communicating with and sending data to an icecast server. It handles the socket connection, the timing of the data, and prevents bad data from getting to the icecast server.
With just a few lines of code, a programmer can easily turn any application into a streaming source for an icecast server. Libshout also allows developers who want a specific feature set (database access, request taking) to concentrate on that feature set, instead of worrying about how server communication works.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{version}
%description devel
Libshout is a library for communicating with and sending data to an icecast server. It handles the socket connection, the timing of the data, and prevents bad data from getting to the icecast server.
With just a few lines of code, a programmer can easily turn any application into a streaming source for an icecast server. Libshout also allows developers who want a specific feature set (database access, request taking) to concentrate on that feature set, instead of worrying about how server communication works.
This package contains static libraries and header files need for development.
%prep
%setup -q
#%patch0 -p1
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall
rm -rf %{buildroot}%{_datadir}/doc/%{name}
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/*.so.*
%doc COPYING INSTALL README
%files devel
%defattr(-,root,root)
%{_datadir}/aclocal/shout.m4
%{_includedir}/shout/*.h
%{_libdir}/*.a
%{_libdir}/*.la
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%changelog
* Fri Aug 10 2012 Automatic Build System <autodist@mambasoft.it> 2.3.1-1mamba
- automatic version update by autodist
* Sun Apr 15 2012 Automatic Build System <autodist@mambasoft.it> 2.3.0-1mamba
- automatic version update by autodist
* Mon Dec 08 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-3mamba
- added patch to link correctly to libspeex
* Wed Jun 11 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-2mamba
- specfile vendor and distribution updated
* Wed Jun 11 2008 Tiziana Ferro <tiziana.ferro@email.it> 2.2.2-1mamba
- update to 2.2.2
* Tue Jun 14 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.1-1qilnx
- package created by autospec