automatic version update by autodist [release 1.3.10-1mamba;Sun Aug 06 2023]
This commit is contained in:
parent
b4c7ea2014
commit
eca5c01655
24
libserf-1.3.9-scons-python3.patch
Normal file
24
libserf-1.3.9-scons-python3.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
--- serf-1.3.9/SConstruct.orig 2019-07-26 17:49:30.910189251 +0000
|
||||||
|
+++ serf-1.3.9/SConstruct 2019-07-26 17:49:54.073821735 +0000
|
||||||
|
@@ -163,9 +163,9 @@
|
||||||
|
suffix='.def', src_suffix='.h')
|
||||||
|
})
|
||||||
|
|
||||||
|
-match = re.search('SERF_MAJOR_VERSION ([0-9]+).*'
|
||||||
|
- 'SERF_MINOR_VERSION ([0-9]+).*'
|
||||||
|
- 'SERF_PATCH_VERSION ([0-9]+)',
|
||||||
|
+match = re.search(b'SERF_MAJOR_VERSION ([0-9]+).*'
|
||||||
|
+ b'SERF_MINOR_VERSION ([0-9]+).*'
|
||||||
|
+ b'SERF_PATCH_VERSION ([0-9]+)',
|
||||||
|
env.File('serf.h').get_contents(),
|
||||||
|
re.DOTALL)
|
||||||
|
MAJOR, MINOR, PATCH = [int(x) for x in match.groups()]
|
||||||
|
@@ -183,7 +183,7 @@
|
||||||
|
|
||||||
|
unknown = opts.UnknownVariables()
|
||||||
|
if unknown:
|
||||||
|
- print 'Warning: Used unknown variables:', ', '.join(unknown.keys())
|
||||||
|
+ print ('Warning: Used unknown variables:', ', '.join(unknown.keys()))
|
||||||
|
|
||||||
|
apr = str(env['APR'])
|
||||||
|
apu = str(env['APU'])
|
20
libserf.spec
20
libserf.spec
@ -1,24 +1,24 @@
|
|||||||
Name: libserf
|
Name: libserf
|
||||||
Version: 1.3.9
|
Version: 1.3.10
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: High-performance asynchronous HTTP client library
|
Summary: High-performance asynchronous HTTP client library
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://code.google.com/p/serf/
|
URL: https://code.google.com/archive/p/serf
|
||||||
Source: https://archive.apache.org/dist/serf/serf-%{version}.tar.bz2
|
Source: https://archive.apache.org/dist/serf/serf-%{version}.tar.bz2
|
||||||
#Source: http://serf.googlecode.com/svn/src_releases/serf-%{version}.tar.bz2
|
#Source: http://serf.googlecode.com/svn/src_releases/serf-%{version}.tar.bz2
|
||||||
|
Patch0: libserf-1.3.9-scons-python3.patch
|
||||||
License: Apache License 2.0
|
License: Apache License 2.0
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libapr-devel
|
BuildRequires: libapr-devel
|
||||||
BuildRequires: libaprutil-devel
|
BuildRequires: libaprutil-devel
|
||||||
BuildRequires: libdb47
|
BuildRequires: libdb53-devel
|
||||||
BuildRequires: libe2fs-devel
|
BuildRequires: libe2fs-devel
|
||||||
BuildRequires: libexpat-devel
|
BuildRequires: libexpat-devel
|
||||||
BuildRequires: libgdbm-devel
|
BuildRequires: libgdbm-devel
|
||||||
BuildRequires: libkeyutils-devel
|
|
||||||
BuildRequires: libkrb5-devel
|
BuildRequires: libkrb5-devel
|
||||||
BuildRequires: libopenldap-devel
|
BuildRequires: libopenldap-devel
|
||||||
BuildRequires: libopenssl-devel
|
BuildRequires: libopenssl-devel
|
||||||
@ -26,7 +26,6 @@ BuildRequires: libuuid-devel
|
|||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: scons
|
BuildRequires: scons
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The serf library is a high performance C-based HTTP client library built upon the Apache Portable Runtime (APR) library.
|
The serf library is a high performance C-based HTTP client library built upon the Apache Portable Runtime (APR) library.
|
||||||
@ -40,8 +39,11 @@ Requires: pkg-config
|
|||||||
%description devel
|
%description devel
|
||||||
This package contains libraries and header files for developing applications that use %{name}.
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n serf-%{version}
|
%setup -q -n serf-%{version}
|
||||||
|
#%patch 0 -p1
|
||||||
sed -i '/SHLIBVERSION/s,MAJOR,0,' SConstruct
|
sed -i '/SHLIBVERSION/s,MAJOR,0,' SConstruct
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -79,6 +81,12 @@ find %{buildroot} -name '*.*a' -exec rm -vf {} ';'
|
|||||||
%doc CHANGES README NOTICE design-guide.txt
|
%doc CHANGES README NOTICE design-guide.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Aug 06 2023 Automatic Build System <autodist@mambasoft.it> 1.3.10-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Dec 09 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.9-2mamba
|
||||||
|
- rebuilt with debug package
|
||||||
|
|
||||||
* Wed Dec 14 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.9-1mamba
|
* Wed Dec 14 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.9-1mamba
|
||||||
- update to 1.3.9
|
- update to 1.3.9
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user