automatic version update by autodist [release 2.3-1mamba;Wed May 07 2014]
This commit is contained in:
parent
940437c38a
commit
c1b2a42267
@ -1,2 +1,5 @@
|
||||
# libselinux
|
||||
|
||||
SELinux is a security enhancement to Linux that allows users and administrators more control over which users and applications can access which resources, such as files. Standard Linux access controls, such as file modes (-rwxr-xr-x) are modifiable by the user and applications that the user runs whereas SELinux access controls are determined by a policy loaded on the system and not changeable by careless users or misbehaving applications.
|
||||
SELinux also adds finer granularity to access controls. Instead of only being able to specify who can read, write or execute a file, for example, SELinux lets you specify who can unlink, append only, move a file and so on. SELinux allows you to specify access to many resources other than files as well, such as network resources and interprocess communication (IPC).
|
||||
|
||||
|
12
libselinux-2.2.1-pkgconfig.patch
Normal file
12
libselinux-2.2.1-pkgconfig.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru libselinux-2.2.1.orig/src/libselinux.pc.in libselinux-2.2.1/src/libselinux.pc.in
|
||||
--- libselinux-2.2.1.orig/src/libselinux.pc.in 2013-11-06 20:56:30.000000000 +0100
|
||||
+++ libselinux-2.2.1/src/libselinux.pc.in 2013-11-30 19:08:36.323348242 +0100
|
||||
@@ -7,6 +7,6 @@
|
||||
Description: SELinux utility library
|
||||
Version: @VERSION@
|
||||
URL: http://userspace.selinuxproject.org/
|
||||
-Requires.private: libsepol libpcre
|
||||
-Libs: -L${libdir} -lselinux
|
||||
+Requires: libsepol libpcre
|
||||
+Libs: -L${libdir} -lselinux -lsepol -lpcre -lpthread
|
||||
Cflags: -I${includedir}
|
171
libselinux.spec
Normal file
171
libselinux.spec
Normal file
@ -0,0 +1,171 @@
|
||||
Name: libselinux
|
||||
Version: 2.3
|
||||
Release: 1mamba
|
||||
Summary: A security enhancement to Linux that allows users and administrators more control over resources access
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://userspace.selinuxproject.org/trac
|
||||
Source: http://userspace.selinuxproject.org/releases/current/%{name}-%{version}.tar.gz
|
||||
Source1: selinux-config
|
||||
Patch0: libselinux-2.2.1-pkgconfig.patch
|
||||
License: Public Domain
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libpcre-devel
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: libpython-devel
|
||||
%endif
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libsepol-devel
|
||||
Requires: libsepol >= 2.0.1
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
SELinux is a security enhancement to Linux that allows users and administrators more control over which users and applications can access which resources, such as files. Standard Linux access controls, such as file modes (-rwxr-xr-x) are modifiable by the user and applications that the user runs whereas SELinux access controls are determined by a policy loaded on the system and not changeable by careless users or misbehaving applications.
|
||||
SELinux also adds finer granularity to access controls. Instead of only being able to specify who can read, write or execute a file, for example, SELinux lets you specify who can unlink, append only, move a file and so on. SELinux allows you to specify access to many resources other than files as well, such as network resources and interprocess communication (IPC).
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
SELinux is a security enhancement to Linux that allows users and administrators more control over which users and applications can access which resources, such as files. Standard Linux access controls, such as file modes (-rwxr-xr-x) are modifiable by the user and applications that the user runs whereas SELinux access controls are determined by a policy loaded on the system and not changeable by careless users or misbehaving applications.
|
||||
SELinux also adds finer granularity to access controls. Instead of only being able to specify who can read, write or execute a file, for example, SELinux lets you specify who can unlink, append only, move a file and so on. SELinux allows you to specify access to many resources other than files as well, such as network resources and interprocess communication (IPC).
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%if "%{stage1}" != "1"
|
||||
%package python
|
||||
Group: System/Libraries
|
||||
Summary: Python bindings for libselinux
|
||||
Provides: python-libselinux = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Obsoletes: python-libselinux
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
%{py_requires}
|
||||
|
||||
%description python
|
||||
The libselinux-python package contains the python bindings for developing SELinux applications.
|
||||
|
||||
An interface for security-aware applications.
|
||||
This package contains the python interface library to libselinux.
|
||||
%endif
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%if "%{_build}" != "%{_host}"
|
||||
%make CC=%{_target_platform}-gcc TLSFLAGS=
|
||||
%else
|
||||
%make CC=%{_target_platform}-gcc
|
||||
%endif
|
||||
|
||||
%if "%{stage1}" != "1"
|
||||
%make pywrap
|
||||
%endif
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall \
|
||||
LIBDIR=%{buildroot}%{_libdir} \
|
||||
SHLIBDIR=%{buildroot}/%{_lib} \
|
||||
%if "%{stage1}" != "1"
|
||||
install-pywrap
|
||||
%endif
|
||||
|
||||
install -D -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/selinux/config
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) %{_sysconfdir}/selinux/config
|
||||
%{_sbindir}/*
|
||||
#/sbin/matchpathcon
|
||||
/%{_lib}/libselinux.so.*
|
||||
%{_libdir}/libselinux.so
|
||||
%{_mandir}/man8/*
|
||||
%doc ChangeLog LICENSE
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/selinux/
|
||||
%{_includedir}/selinux/*.h
|
||||
%{_libdir}/libselinux.a
|
||||
%{_mandir}/man3/*
|
||||
%{_mandir}/man5/*
|
||||
%{_libdir}/pkgconfig/libselinux.pc
|
||||
|
||||
%if "%{stage1}" != "1"
|
||||
%files python
|
||||
%defattr(-,root,root)
|
||||
%{python_sitearch}/selinux/*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed May 07 2014 Automatic Build System <autodist@mambasoft.it> 2.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Dec 31 2013 Automatic Build System <autodist@mambasoft.it> 2.2.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Dec 01 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.1-3mamba
|
||||
- really restore pkgconfig patch
|
||||
|
||||
* Sat Nov 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.1-2mamba
|
||||
- restore pkgconfig patch
|
||||
|
||||
* Thu Nov 07 2013 Automatic Build System <autodist@mambasoft.it> 2.2.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Oct 31 2013 Automatic Build System <autodist@mambasoft.it> 2.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jul 24 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.13-3mamba
|
||||
- fix pkg-config patch, don't use Requires.private and Libs.private
|
||||
|
||||
* Sat Jul 20 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.13-2mamba
|
||||
- add libpthread and libpcre in pkg-config file (needed in x86_64)
|
||||
|
||||
* Wed Apr 24 2013 Automatic Build System <autodist@mambasoft.it> 2.1.13-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Sep 25 2012 Automatic Build System <autodist@mambasoft.it> 2.1.12-1mamba
|
||||
- update to 2.1.12
|
||||
|
||||
* Mon Mar 12 2012 Automatic Build System <autodist@mambasoft.it> 2.1.9-1mamba
|
||||
- update to 2.1.9
|
||||
|
||||
* Sat Apr 30 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.94-2mamba
|
||||
- added default /etc/selinux/config file with SELINUX=disabled and SELINUXTYPE=targeted
|
||||
|
||||
* Tue Jun 22 2010 Automatic Build System <autodist@mambasoft.it> 2.0.94-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Mar 23 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.85-1mamba
|
||||
- update to 2.0.85
|
||||
|
||||
* Fri Jan 09 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.65-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Apr 04 2007 Davide Madrisan <davide.madrisan@gmail.com> 2.0.8-1mamba
|
||||
- update to version 2.0.8 by autospec
|
||||
|
||||
* Fri Jan 06 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.28-1qilnx
|
||||
- update to version 1.28 by autospec
|
||||
|
||||
* Wed Nov 02 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.26-1qilnx
|
||||
- update to version 1.26 by autospec
|
||||
|
||||
* Sat Jun 04 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.22-1qilnx
|
||||
- package created by autospec
|
10
selinux-config
Normal file
10
selinux-config
Normal file
@ -0,0 +1,10 @@
|
||||
# This file controls the state of SELinux on the system.
|
||||
# SELINUX= can take one of these three values:
|
||||
# enforcing - SELinux security policy is enforced.
|
||||
# permissive - SELinux prints warnings instead of enforcing.
|
||||
# disabled - No SELinux policy is loaded.
|
||||
SELINUX=disabled
|
||||
# SELINUXTYPE= can take one of these two values:
|
||||
# targeted - Only targeted network daemons are protected.
|
||||
# strict - Full SELinux protection.
|
||||
SELINUXTYPE=targeted
|
Loading…
Reference in New Issue
Block a user