update to 1.10.3 [release 1.10.3-1mamba;Tue Jun 04 2019]

This commit is contained in:
Silvan Calarco 2024-01-06 05:42:22 +01:00
parent 95b9221a23
commit 1cf6aefc69
2 changed files with 7 additions and 119 deletions

View File

@ -1,116 +0,0 @@
From 1dff9c2c8271ba7019b9a9a4d3612b6d4ff86b2b Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <ignatenko@redhat.com>
Date: Sat, 10 Feb 2018 18:28:28 +0100
Subject: [PATCH] stop requiring attr(xattr)
Latest xattr dropped xattr bits because they are in glibc.
Fixes: https://github.com/rpm-software-management/librepo/issues/121
Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>
---
CMakeLists.txt | 1 -
cmake/Modules/FindXattr.cmake | 29 -----------------------------
librepo/checksum.c | 3 ++-
librepo/downloader.c | 2 +-
tests/test_checksum.c | 3 ++-
5 files changed, 5 insertions(+), 33 deletions(-)
delete mode 100644 cmake/Modules/FindXattr.cmake
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e5c8c2e..90cf9b0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,7 +32,6 @@ PKG_SEARCH_MODULE(LIBCRYPTO REQUIRED libcrypto openssl)
FIND_PACKAGE(EXPAT REQUIRED)
FIND_PACKAGE(CURL REQUIRED)
FIND_PACKAGE(Gpgme REQUIRED)
-FIND_PACKAGE(Xattr REQUIRED)
INCLUDE_DIRECTORIES(${GLIB2_INCLUDE_DIRS})
diff --git a/cmake/Modules/FindXattr.cmake b/cmake/Modules/FindXattr.cmake
deleted file mode 100644
index fce2c56..0000000
--- a/cmake/Modules/FindXattr.cmake
+++ /dev/null
@@ -1,29 +0,0 @@
-# XATTR_FOUND libattr found
-# XATTR_INCLUDE_DIRS include directories
-# XATTR_LIBRARIES libattr library
-
-FIND_PATH(XATTR_INCLUDE attr/xattr.h
- /usr/include
- /usr/local/include
- ${CMAKE_INCLUDE_PATH}
- ${CMAKE_INSTALL_PREFIX}/usr/include
-)
-
-FIND_LIBRARY(XATTR_LIB NAMES attr libattr
- PATHS
- ${CMAKE_LIBRARY_PATH}
- ${CMAKE_INSTALL_PREFIX}/lib
-)
-
-IF(XATTR_INCLUDE AND XATTR_LIB)
- SET(XATTR_FOUND TRUE)
- SET(XATTR_INCLUDE_DIRS ${XATTR_INCLUDE})
- SET(XATTR_LIBRARIES ${XATTR_LIB})
- MESSAGE(STATUS "Found xattr")
-ELSE(XATTR_INCLUDE AND XATTR_LIB)
- SET(XATTR_FOUND FALSE)
- SET(XATTR_LIBRARIES "")
- MESSAGE(STATUS "Not found xattr")
-ENDIF(XATTR_INCLUDE AND XATTR_LIB)
-
-MARK_AS_ADVANCED( XATTR_LIB XATTR_INCLUDE )
diff --git a/librepo/checksum.c b/librepo/checksum.c
index d005397..f55735c 100644
--- a/librepo/checksum.c
+++ b/librepo/checksum.c
@@ -23,10 +23,11 @@
#include <assert.h>
#include <string.h>
#include <ctype.h>
+#include <errno.h>
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/xattr.h>
#include <unistd.h>
-#include <attr/xattr.h>
#include <openssl/evp.h>
#include "cleanup.h"
diff --git a/librepo/downloader.c b/librepo/downloader.c
index 5995da0..cf4f050 100644
--- a/librepo/downloader.c
+++ b/librepo/downloader.c
@@ -28,9 +28,9 @@
#include <errno.h>
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/xattr.h>
#include <fcntl.h>
#include <curl/curl.h>
-#include <attr/xattr.h>
#include "downloader.h"
#include "downloader_internal.h"
diff --git a/tests/test_checksum.c b/tests/test_checksum.c
index ab75038..023ae55 100644
--- a/tests/test_checksum.c
+++ b/tests/test_checksum.c
@@ -1,12 +1,13 @@
#define _GNU_SOURCE
+#include <errno.h>
#include <stdlib.h>
#include <stdio.h>
#include <unistd.h>
#include <string.h>
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/xattr.h>
#include <fcntl.h>
-#include <attr/xattr.h>
#include "librepo/util.h"
#include "librepo/checksum.h"

View File

@ -1,5 +1,5 @@
Name: librepo
Version: 1.8.1
Version: 1.10.3
Release: 1mamba
Summary: A library providing C and Python API for downloading packages and linux repository metadata in rpm-md format
Group: System/Libraries
@ -9,7 +9,6 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://rpm-software-management.github.io/librepo/
## GITSOURCE https://github.com/rpm-software-management/librepo.git 1.8.1
Source: https://github.com/rpm-software-management/librepo.git/%{version}/librepo-%{version}.tar.bz2
Patch0: librepo-1.8.1-xattr-glibc.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -42,7 +41,6 @@ This package contains libraries and header files for developing applications tha
%prep
%setup -q
%patch0 -p1
%build
%cmake -d build
@ -74,5 +72,11 @@ This package contains libraries and header files for developing applications tha
%doc README.md
%changelog
* Tue Jun 04 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.3-1mamba
- update to 1.10.3
* Sat Jun 01 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.0-1mamba
- update to 1.9.0
* Thu May 17 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.1-1mamba
- package created using the webbuild interface