update to 7.2.2.1 [release 7.2.2.1-1mamba;Tue Sep 28 2021]

This commit is contained in:
Silvan Calarco 2024-01-06 05:34:57 +01:00
parent 5f4129f9bd
commit 0e5d863532
2 changed files with 74 additions and 17 deletions

View File

@ -0,0 +1,51 @@
Submitted By: Bruce Dubbs <bdubbs@linuxfromscratch.org>
Date: 2021-08-23
Initial Package Version: 7.2.0.4
Upstream Status: Unknown
Origin: Marty Jack
Description: Corrects automatically downloaded skia package for current freetype
diff -Naur libreoffice-7.2.0.4.orig/external/skia/freetype_2.11.patch libreoffice-7.2.0.4/external/skia/freetype_2.11.patch
--- libreoffice-7.2.0.4.orig/external/skia/freetype_2.11.patch 1969-12-31 18:00:00.000000000 -0600
+++ libreoffice-7.2.0.4/external/skia/freetype_2.11.patch 2021-08-23 10:28:43.646193278 -0500
@@ -0,0 +1,29 @@
+diff -Naur skia.orig/src/ports/SkFontHost_FreeType_common.cpp skia/src/ports/SkFontHost_FreeType_common.cpp
+--- skia.orig/src/ports/SkFontHost_FreeType_common.cpp 2021-03-01 09:53:09.178606791 -0500
++++ skia/src/ports/SkFontHost_FreeType_common.cpp 2021-08-19 10:41:10.974582934 -0400
+@@ -665,8 +665,8 @@
+ canvas->drawPaint(paint);
+ break;
+ }
+- case FT_COLR_PAINTFORMAT_TRANSFORMED: {
+- SkMatrix transform = ToSkMatrix(colrv1_paint.u.transformed.affine);
++ case FT_COLR_PAINTFORMAT_TRANSFORM: {
++ SkMatrix transform = ToSkMatrix(colrv1_paint.u.transform.affine);
+
+ canvas->concat(transform);
+ break;
+@@ -760,12 +760,12 @@
+ traverse_result = colrv1_start_glyph(canvas, palette, face, paint.u.colr_glyph.glyphID,
+ FT_COLOR_NO_ROOT_TRANSFORM);
+ break;
+- case FT_COLR_PAINTFORMAT_TRANSFORMED:
++ case FT_COLR_PAINTFORMAT_TRANSFORM:
+ canvas->saveLayer(nullptr, nullptr);
+ // Traverse / draw operation will apply transform.
+ colrv1_draw_paint(canvas, palette, face, paint);
+ traverse_result =
+- colrv1_traverse_paint(canvas, palette, face, paint.u.transformed.paint);
++ colrv1_traverse_paint(canvas, palette, face, paint.u.transform.paint);
+ canvas->restore();
+ break;
+ case FT_COLR_PAINTFORMAT_ROTATE:
diff -Naur libreoffice-7.2.0.4.orig/external/skia/UnpackedTarball_skia.mk libreoffice-7.2.0.4/external/skia/UnpackedTarball_skia.mk
--- libreoffice-7.2.0.4.orig/external/skia/UnpackedTarball_skia.mk 2021-08-16 14:56:28.000000000 -0500
+++ libreoffice-7.2.0.4/external/skia/UnpackedTarball_skia.mk 2021-08-23 10:26:46.418807295 -0500
@@ -14,6 +14,7 @@
# * c++20.patch.0 has been reported upstream at
# <https://groups.google.com/forum/#!topic/skia-discuss/pYZQq_sLnv8> "C++20 operator== issue":
skia_patches := \
+ freetype_2.11.patch \
fix-pch.patch.1 \
fix-ddi.patch \
make-api-visible.patch.1 \

View File

@ -20,7 +20,7 @@
%define langpacks 1
Name: libreoffice
Version: 7.1.4.2
Version: 7.2.2.1
Release: 1mamba
Summary: Free Office Suite
Group: Graphical Desktop/Applications/Office
@ -45,12 +45,13 @@ Source28: http://dev-www.libreoffice.org/src/OpenCOLLADA-master-6509aa13af.
Source29: http://dev-www.libreoffice.org/src/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
Source30: http://dev-www.libreoffice.org/src/libgltf/libgltf-0.0.2.tar.bz2
Source31: http://dev-www.libreoffice.org/src/4b87018f7fff1d054939d19920b751a0-collada2gltf-master-cb1d97788a.tar.bz2
Source32: http://dev-www.libreoffice.org/src/pdfium-4306.tar.bz2
Source32: http://dev-www.libreoffice.org/src/pdfium-4500.tar.bz2
Source33: https://dev-www.libreoffice.org/extern/8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar
Source34: https://dev-www.libreoffice.org/extern/odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies+ODFTOOLKIT-460+ODFTOOLKIT-475.jar
Source35: https://dev-www.libreoffice.org/extern/f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
Source36: https://dev-www.libreoffice.org/src/dtoa-20180411.tgz
Source37: https://dev-www.libreoffice.org/src/skia-m88-59bafeeaa7de9eb753e3778c414e01dcf013dcd8.tar.xz
Source37: https://dev-www.libreoffice.org/src/skia-m90-45c57e116ee0ce214bdf78405a4762722e4507d9.tar.xz
Source38: https://dev-www.libreoffice.org/src/libcmis-0.5.2.tar.xz
Patch12: libreoffice-installfix.patch
Patch39: libreoffice-5.1.1.1-gcc-5.3-std-isnan.patch
Patch40: libreoffice-5.1.3.2-x86-cppunit.patch
@ -60,6 +61,7 @@ Patch43: libreoffice-6.1.2.1-boost-1.69.patch
Patch44: libreoffice-6.4.0.3-libpoppler-0.84.0.patch
Patch45: libreoffice-6.4.3.2-build-workaround-fix-deleteTestDirectory-failed-assert.patch
Patch46: libreoffice-6.4.3.2-libpoppler-0.87.patch
Patch47: libreoffice-7.2.0.4-libfreetype-2.11.0.patch
License: BSD, Common Development and Distribution License 1.0, GPL, LGPL, MPL 1.1, Netscape, Public Domain
## AUTOBUILDREQ-BEGIN
BuildRequires: firebird-devel
@ -203,9 +205,9 @@ BuildRequires: java-hsqldb1 < 1.8.1
BuildRequires: java-bsh2 >= 2.0b4
%ifnarch aarch64
BuildRequires: apache-ant
BuildRequires: java-pentaho-libxml
BuildRequires: java-flute
BuildRequires: java-pentaho-reporting-flow-engine
#BuildRequires: java-pentaho-libxml
#BuildRequires: java-flute
#BuildRequires: java-pentaho-reporting-flow-engine
BuildRequires: xerces-j2
BuildRequires: xalan-j2
BuildRequires: xml-commons-apis
@ -221,7 +223,6 @@ BuildRequires: postgresql-jdbc
%if %with_system_saxon9
BuildRequires: java-saxon9 >= 9.1.0.7
%endif
BuildRequires: java-pentaho-reporting-flow-engine
%endif
BuildRequires: hunspell-es
BuildRequires: hyphen-es
@ -543,6 +544,7 @@ A plug-in for LibreOffice that enables integration into the GNOME desktop enviro
#%patch12 -p1 -b .libreoffice-installfix.patch
#%patch45 -p1
#%patch46 -p1
%patch47 -p1
touch scripting/source/pyprov/delzip
#touch scripting/util/provider/beanshell/delzip
@ -567,6 +569,7 @@ ln -s %{SOURCE34} ext_sources
ln -s %{SOURCE35} ext_sources
ln -s %{SOURCE36} ext_sources
ln -s %{SOURCE37} ext_sources
ln -s %{SOURCE38} ext_sources
chmod +x bin/unpack-sources
@ -599,6 +602,7 @@ export JAVACMD=%{java_home}/bin/java
--disable-debug \
--with-vendor="%{distribution}" \
--with-build-version="Ver: %{version}-%{release}" \
--with-branding=`pwd`/branding \
--disable-epm \
--enable-gio \
--enable-evolution2 \
@ -628,7 +632,7 @@ export JAVACMD=%{java_home}/bin/java
--with-system-jfreereport \
--with-jdk-home=$JAVA_HOME \
--with-system-beanshell \
--with-beanshell-jar=$(build-classpath bsh2/bsh) \
--with-beanshell-jar=$(build-classpath bsh) \
--with-system-libwpd \
--with-system-libwpg \
--with-system-libwps \
@ -645,11 +649,10 @@ export JAVACMD=%{java_home}/bin/java
--with-system-zlib \
--with-system-openssl \
--with-system-graphite \
--without-system-libcmis \
--enable-split-app-modules \
--enable-split-opt-features
# --with-branding=`pwd`/branding \
# --enable-symbols \
# --enable-graphite \
# --with-system-mozilla=libxul \
@ -904,13 +907,13 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%files bsh -f file-lists/orig/gid_Module_Optional_Extensions_Script_Provider_For_BS
%defattr(-,root,root)
%files sdk -f file-lists/sdk_list.txt
%defattr(-,root,root)
#%{_libdir}/girepository-1.0/LOKDocView-*.typelib
#%{_datadir}/gir-1.0/LOKDocView-*.gir
#%files sdk -f file-lists/sdk_list.txt
#%defattr(-,root,root)
##%{_libdir}/girepository-1.0/LOKDocView-*.typelib
##%{_datadir}/gir-1.0/LOKDocView-*.gir
%files sdk-doc -f file-lists/sdk_doc_list.txt
%defattr(-,root,root)
#%files sdk-doc -f file-lists/sdk_doc_list.txt
#%defattr(-,root,root)
#%files testtools -f file-lists/testtool_list.txt
#%defattr(-,root,root)
@ -1057,6 +1060,9 @@ This package contains %{langname} translations and resources for LibreOffice.\
%langpack -l zu -n Zulu -F -H -Y
%changelog
* Tue Sep 28 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 7.2.2.1-1mamba
- update to 7.2.2.1
* Thu Jun 10 2021 Automatic Build System <autodist@mambasoft.it> 7.1.4.2-1mamba
- automatic version update by autodist