package created using the webbuild interface [release 1.9.2-1mamba;Sat Sep 24 2022]
This commit is contained in:
parent
fa497aa3e7
commit
d64bb7743e
@ -1,2 +1,4 @@
|
|||||||
# librdkafka
|
# librdkafka
|
||||||
|
|
||||||
|
librdkafka is a C library implementation of the Apache Kafka protocol, providing Producer, Consumer and Admin clients. It was designed with message delivery reliability and high performance in mind, current figures exceed 1 million msgs/second for the producer and 3 million msgs/second for the consumer.
|
||||||
|
|
||||||
|
24
librdkafka-1.9.2-curl-7.85.0.patch
Normal file
24
librdkafka-1.9.2-curl-7.85.0.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
From 23bd03c11c344aaa01ace8951e60913b4bfa3c2e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Adrian Costin <adriancostin6@gmail.com>
|
||||||
|
Date: Wed, 13 Jul 2022 17:29:18 +0200
|
||||||
|
Subject: [PATCH] cmake build fix: link against libcurl explicilty
|
||||||
|
|
||||||
|
---
|
||||||
|
src/CMakeLists.txt | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
||||||
|
index 33b3ced1e..79615187b 100644
|
||||||
|
--- a/src/CMakeLists.txt
|
||||||
|
+++ b/src/CMakeLists.txt
|
||||||
|
@@ -238,6 +238,10 @@ endif()
|
||||||
|
find_package(Threads REQUIRED)
|
||||||
|
target_link_libraries(rdkafka PUBLIC Threads::Threads)
|
||||||
|
|
||||||
|
+if(WITH_CURL)
|
||||||
|
+ target_link_libraries(rdkafka PUBLIC curl)
|
||||||
|
+endif()
|
||||||
|
+
|
||||||
|
if(WITH_SASL_CYRUS)
|
||||||
|
target_include_directories(rdkafka PRIVATE ${SASL_INCLUDE_DIRS})
|
||||||
|
target_link_libraries(rdkafka PUBLIC ${SASL_LIBRARIES})
|
79
librdkafka.spec
Normal file
79
librdkafka.spec
Normal file
@ -0,0 +1,79 @@
|
|||||||
|
Name: librdkafka
|
||||||
|
Version: 1.9.2
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A C library implementation of the Apache Kafka protocol
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://github.com/edenhill/librdkafka
|
||||||
|
Source: https://github.com/edenhill/librdkafka.git/v%{version}/librdkafka-%{version}.tar.bz2
|
||||||
|
Patch0: librdkafka-1.9.2-curl-7.85.0.patch
|
||||||
|
License: BSD
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libcurl-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: liblz4-devel
|
||||||
|
BuildRequires: libopenssl-devel
|
||||||
|
BuildRequires: libsasl2-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: libzstd-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: cmake
|
||||||
|
|
||||||
|
%description
|
||||||
|
librdkafka is a C library implementation of the Apache Kafka protocol, providing Producer, Consumer and Admin clients. It was designed with message delivery reliability and high performance in mind, current figures exceed 1 million msgs/second for the producer and 3 million msgs/second for the consumer.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: pkg-config
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1 -b .curl-7.85.0
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cmake -d build
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall -C build
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/librdkafka++.so.*
|
||||||
|
%{_libdir}/librdkafka.so.*
|
||||||
|
%doc LICENSE
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/librdkafka
|
||||||
|
%{_includedir}/librdkafka/*.h
|
||||||
|
%dir %{_libdir}/cmake/RdKafka
|
||||||
|
%{_libdir}/cmake/RdKafka/*.cmake
|
||||||
|
%{_libdir}/librdkafka++.so
|
||||||
|
%{_libdir}/librdkafka.so
|
||||||
|
%{_libdir}/pkgconfig/rdkafka++.pc
|
||||||
|
%{_libdir}/pkgconfig/rdkafka.pc
|
||||||
|
%{_datadir}/licenses/librdkafka/LICENSES.txt
|
||||||
|
%doc README.md README.win32
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Sep 24 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.2-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user