automatic version update by autodist [release 2.8.0-1mamba;Fri Jan 10 2025]
This commit is contained in:
parent
988ae7d491
commit
0ae5279330
@ -1,24 +0,0 @@
|
|||||||
From 23bd03c11c344aaa01ace8951e60913b4bfa3c2e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Adrian Costin <adriancostin6@gmail.com>
|
|
||||||
Date: Wed, 13 Jul 2022 17:29:18 +0200
|
|
||||||
Subject: [PATCH] cmake build fix: link against libcurl explicilty
|
|
||||||
|
|
||||||
---
|
|
||||||
src/CMakeLists.txt | 4 ++++
|
|
||||||
1 file changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
|
||||||
index 33b3ced1e..79615187b 100644
|
|
||||||
--- a/src/CMakeLists.txt
|
|
||||||
+++ b/src/CMakeLists.txt
|
|
||||||
@@ -238,6 +238,10 @@ endif()
|
|
||||||
find_package(Threads REQUIRED)
|
|
||||||
target_link_libraries(rdkafka PUBLIC Threads::Threads)
|
|
||||||
|
|
||||||
+if(WITH_CURL)
|
|
||||||
+ target_link_libraries(rdkafka PUBLIC curl)
|
|
||||||
+endif()
|
|
||||||
+
|
|
||||||
if(WITH_SASL_CYRUS)
|
|
||||||
target_include_directories(rdkafka PRIVATE ${SASL_INCLUDE_DIRS})
|
|
||||||
target_link_libraries(rdkafka PUBLIC ${SASL_LIBRARIES})
|
|
@ -1,11 +0,0 @@
|
|||||||
--- librdkafka-2.0.2/src/CMakeLists.txt.orig 2023-02-11 14:43:40.983064404 +0100
|
|
||||||
+++ librdkafka-2.0.2/src/CMakeLists.txt 2023-02-11 14:44:05.011918841 +0100
|
|
||||||
@@ -296,7 +296,7 @@
|
|
||||||
set(PKG_CONFIG_DESCRIPTION "The Apache Kafka C/C++ library")
|
|
||||||
|
|
||||||
if(WITH_CURL)
|
|
||||||
- string(APPEND PKG_CONFIG_REQUIRES "curl ")
|
|
||||||
+ string(APPEND PKG_CONFIG_REQUIRES "libcurl ")
|
|
||||||
endif()
|
|
||||||
|
|
||||||
if(WITH_ZLIB)
|
|
@ -1,5 +1,5 @@
|
|||||||
Name: librdkafka
|
Name: librdkafka
|
||||||
Version: 2.6.1
|
Version: 2.8.0
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A C library implementation of the Apache Kafka protocol
|
Summary: A C library implementation of the Apache Kafka protocol
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -8,8 +8,6 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://github.com/confluentinc/librdkafka
|
URL: https://github.com/confluentinc/librdkafka
|
||||||
Source: https://github.com/edenhill/librdkafka.git/v%{version}/librdkafka-%{version}.tar.bz2
|
Source: https://github.com/edenhill/librdkafka.git/v%{version}/librdkafka-%{version}.tar.bz2
|
||||||
Patch0: librdkafka-1.9.2-curl-7.85.0.patch
|
|
||||||
Patch1: librdkafka-2.0.2-libcurl-pkgconfig.patch
|
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -36,12 +34,9 @@ Requires: pkg-config
|
|||||||
%description devel
|
%description devel
|
||||||
This package contains libraries and header files for developing applications that use %{name}.
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
%debug_package
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1 -b .curl-7.85.0
|
|
||||||
#%patch 1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build
|
%cmake -d build
|
||||||
@ -75,6 +70,9 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%doc README.md README.win32
|
%doc README.md README.win32
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 10 2025 Automatic Build System <autodist@openmamba.org> 2.8.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Tue Nov 19 2024 Automatic Build System <autodist@openmamba.org> 2.6.1-1mamba
|
* Tue Nov 19 2024 Automatic Build System <autodist@openmamba.org> 2.6.1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user