specfile fixes and rebuild [release 1.0.17-4mamba;Thu Nov 28 2024]
This commit is contained in:
parent
3e1df69189
commit
fe6e968d44
@ -1,33 +0,0 @@
|
|||||||
diff -up redland-1.0.10/src/Makefile.am.no_undefined redland-1.0.10/src/Makefile.am
|
|
||||||
--- redland-1.0.10/src/Makefile.am.no_undefined 2009-11-23 00:38:32.000000000 -0600
|
|
||||||
+++ redland-1.0.10/src/Makefile.am 2010-01-04 12:51:17.245649696 -0600
|
|
||||||
@@ -152,7 +152,7 @@ if STORAGE_VIRTUOSO
|
|
||||||
plugin_LTLIBRARIES += librdf_storage_virtuoso.la
|
|
||||||
librdf_storage_virtuoso_la_SOURCES = rdf_storage_virtuoso.c rdf_storage_virtuoso_internal.h
|
|
||||||
librdf_storage_virtuoso_la_CPPFLAGS = @ODBC_CFLAGS@
|
|
||||||
-librdf_storage_virtuoso_la_LIBADD = @ODBC_LIBS@
|
|
||||||
+librdf_storage_virtuoso_la_LIBADD = @ODBC_LIBS@ librdf.la
|
|
||||||
librdf_storage_virtuoso_la_LDFLAGS = -module -avoid-version
|
|
||||||
endif
|
|
||||||
|
|
||||||
diff -up redland-1.0.10/src/Makefile.in.no_undefined redland-1.0.10/src/Makefile.in
|
|
||||||
--- redland-1.0.10/src/Makefile.in.no_undefined 2009-12-14 00:53:52.000000000 -0600
|
|
||||||
+++ redland-1.0.10/src/Makefile.in 2010-01-04 12:56:01.389896396 -0600
|
|
||||||
@@ -214,7 +214,7 @@ librdf_storage_tstore_la_LINK = $(LIBTOO
|
|
||||||
$(librdf_storage_tstore_la_LDFLAGS) $(LDFLAGS) -o $@
|
|
||||||
@MODULAR_LIBRDF_TRUE@@STORAGE_TSTORE_TRUE@am_librdf_storage_tstore_la_rpath = \
|
|
||||||
@MODULAR_LIBRDF_TRUE@@STORAGE_TSTORE_TRUE@ -rpath $(plugindir)
|
|
||||||
-librdf_storage_virtuoso_la_DEPENDENCIES =
|
|
||||||
+librdf_storage_virtuoso_la_DEPENDENCIES = librdf.la
|
|
||||||
am__librdf_storage_virtuoso_la_SOURCES_DIST = rdf_storage_virtuoso.c \
|
|
||||||
rdf_storage_virtuoso_internal.h
|
|
||||||
@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@am_librdf_storage_virtuoso_la_OBJECTS = librdf_storage_virtuoso_la-rdf_storage_virtuoso.lo
|
|
||||||
@@ -570,7 +570,7 @@ plugindir = $(libdir)/redland
|
|
||||||
@MODULAR_LIBRDF_TRUE@@STORAGE_POSTGRESQL_TRUE@librdf_storage_postgresql_la_LDFLAGS = -module -avoid-version
|
|
||||||
@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_SOURCES = rdf_storage_virtuoso.c rdf_storage_virtuoso_internal.h
|
|
||||||
@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_CPPFLAGS = @ODBC_CFLAGS@
|
|
||||||
-@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_LIBADD = @ODBC_LIBS@
|
|
||||||
+@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_LIBADD = @ODBC_LIBS@ librdf.la
|
|
||||||
@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_LDFLAGS = -module -avoid-version
|
|
||||||
librdf_la_LIBADD = \
|
|
||||||
@LTLIBOBJS@ @DIGEST_OBJS@ @HASH_OBJS@ \
|
|
@ -1,38 +0,0 @@
|
|||||||
--- librdf/trunk/src/Makefile.am 2009/04/14 05:23:12 15151
|
|
||||||
+++ librdf/trunk/src/Makefile.am 2009/04/28 23:59:20 15171
|
|
||||||
@@ -119,7 +119,7 @@
|
|
||||||
plugin_LTLIBRARIES += librdf_storage_tstore.la
|
|
||||||
librdf_storage_tstore_la_SOURCES = rdf_storage_tstore.c
|
|
||||||
librdf_storage_tstore_la_CPPFLAGS = @TSTORE_CPPFLAGS@
|
|
||||||
-librdf_storage_tstore_la_LIBADD = @TSTORE_LIBS@
|
|
||||||
+librdf_storage_tstore_la_LIBADD = @TSTORE_LIBS@ librdf.la
|
|
||||||
librdf_storage_tstore_la_LDFLAGS = -module -avoid-version
|
|
||||||
endif
|
|
||||||
|
|
||||||
@@ -127,7 +127,7 @@
|
|
||||||
plugin_LTLIBRARIES += librdf_storage_mysql.la
|
|
||||||
librdf_storage_mysql_la_SOURCES = rdf_storage_mysql.c
|
|
||||||
librdf_storage_mysql_la_CPPFLAGS = @MYSQL_CPPFLAGS@
|
|
||||||
-librdf_storage_mysql_la_LIBADD = @MYSQL_LIBS@
|
|
||||||
+librdf_storage_mysql_la_LIBADD = @MYSQL_LIBS@ librdf.la
|
|
||||||
librdf_storage_mysql_la_LDFLAGS = -module -avoid-version
|
|
||||||
endif
|
|
||||||
|
|
||||||
@@ -135,7 +135,7 @@
|
|
||||||
plugin_LTLIBRARIES += librdf_storage_sqlite.la
|
|
||||||
librdf_storage_sqlite_la_SOURCES = rdf_storage_sqlite.c
|
|
||||||
librdf_storage_sqlite_la_CPPFLAGS = @SQLITE_CPPFLAGS@
|
|
||||||
-librdf_storage_sqlite_la_LIBADD = @SQLITE_LIBS@
|
|
||||||
+librdf_storage_sqlite_la_LIBADD = @SQLITE_LIBS@ librdf.la
|
|
||||||
librdf_storage_sqlite_la_LDFLAGS = -module -avoid-version
|
|
||||||
endif
|
|
||||||
|
|
||||||
@@ -143,7 +143,7 @@
|
|
||||||
plugin_LTLIBRARIES += librdf_storage_postgresql.la
|
|
||||||
librdf_storage_postgresql_la_SOURCES = rdf_storage_postgresql.c
|
|
||||||
librdf_storage_postgresql_la_CPPFLAGS = @POSTGRESQL_CPPFLAGS@
|
|
||||||
-librdf_storage_postgresql_la_LIBADD = @POSTGRESQL_LIBS@
|
|
||||||
+librdf_storage_postgresql_la_LIBADD = @POSTGRESQL_LIBS@ librdf.la
|
|
||||||
librdf_storage_postgresql_la_LDFLAGS = -module -avoid-version
|
|
||||||
endif
|
|
||||||
|
|
34
librdf.spec
34
librdf.spec
@ -1,19 +1,16 @@
|
|||||||
Name: librdf
|
Name: librdf
|
||||||
Version: 1.0.17
|
Version: 1.0.17
|
||||||
Release: 3mamba
|
Release: 4mamba
|
||||||
Summary: Redland RDF Libraries
|
Summary: Redland RDF Libraries
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Aleph0 <aleph0@openmamba.org>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://librdf.org/
|
URL: https://librdf.org/
|
||||||
Source: http://download.librdf.org/source/redland-%{version}.tar.gz
|
Source: http://download.librdf.org/source/redland-%{version}.tar.gz
|
||||||
Patch0: %{name}-1.0.9-fix_undefined_symbol.patch
|
|
||||||
Patch1: %{name}-1.0.10-no_undefined.patch
|
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: ldconfig
|
|
||||||
BuildRequires: libdb53-devel
|
BuildRequires: libdb53-devel
|
||||||
BuildRequires: libiodbc-devel
|
BuildRequires: libiodbc-devel
|
||||||
BuildRequires: libltdl-devel
|
BuildRequires: libltdl-devel
|
||||||
@ -27,11 +24,6 @@ BuildRequires: pkgconfig
|
|||||||
BuildRequires: libcurl-devel
|
BuildRequires: libcurl-devel
|
||||||
BuildRequires: libexpat-devel
|
BuildRequires: libexpat-devel
|
||||||
BuildRequires: libxslt-devel
|
BuildRequires: libxslt-devel
|
||||||
#%ifnarch arm
|
|
||||||
#BuildRequires: virtuoso-opensource
|
|
||||||
#%endif
|
|
||||||
#Provides: redland = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Redland is a set of free software libraries that provide support for the Resource Description Framework (RDF).
|
Redland is a set of free software libraries that provide support for the Resource Description Framework (RDF).
|
||||||
@ -43,8 +35,7 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
Redland is a set of free software libraries that provide support for the Resource Description Framework (RDF).
|
Redland is a set of free software libraries that provide support for the Resource Description Framework (RDF).
|
||||||
|
This package contains static libraries and header files needed for development.
|
||||||
This package contains static libraries and header files need for development.
|
|
||||||
|
|
||||||
%package apidocs
|
%package apidocs
|
||||||
Summary: %{pkgname} API documentation
|
Summary: %{pkgname} API documentation
|
||||||
@ -82,8 +73,6 @@ Requires: %{name} = %{version}-%{release}
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n redland-%{version}
|
%setup -q -n redland-%{version}
|
||||||
#%patch0 -p2
|
|
||||||
#%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -100,25 +89,18 @@ Requires: %{name} = %{version}-%{release}
|
|||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
|
||||||
%postun -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/rdfproc
|
%{_bindir}/rdfproc
|
||||||
%{_bindir}/redland-db-upgrade
|
%{_bindir}/redland-db-upgrade
|
||||||
%{_libdir}/librdf.so.*
|
%{_libdir}/librdf.so.*
|
||||||
%{_libdir}/redland/librdf_storage_mysql.a
|
%{_libdir}/redland/librdf_storage_mysql.a
|
||||||
%{_libdir}/redland/librdf_storage_mysql.la
|
|
||||||
%{_libdir}/redland/librdf_storage_mysql.so
|
%{_libdir}/redland/librdf_storage_mysql.so
|
||||||
%{_libdir}/redland/librdf_storage_postgresql.a
|
%{_libdir}/redland/librdf_storage_postgresql.a
|
||||||
%{_libdir}/redland/librdf_storage_postgresql.la
|
|
||||||
%{_libdir}/redland/librdf_storage_postgresql.so
|
%{_libdir}/redland/librdf_storage_postgresql.so
|
||||||
%{_libdir}/redland/librdf_storage_sqlite.a
|
%{_libdir}/redland/librdf_storage_sqlite.a
|
||||||
%{_libdir}/redland/librdf_storage_sqlite.la
|
|
||||||
%{_libdir}/redland/librdf_storage_sqlite.so
|
%{_libdir}/redland/librdf_storage_sqlite.so
|
||||||
%{_libdir}/redland/librdf_storage_virtuoso.a
|
%{_libdir}/redland/librdf_storage_virtuoso.a
|
||||||
%{_libdir}/redland/librdf_storage_virtuoso.la
|
|
||||||
%{_libdir}/redland/librdf_storage_virtuoso.so
|
%{_libdir}/redland/librdf_storage_virtuoso.so
|
||||||
%{_datadir}/redland/
|
%{_datadir}/redland/
|
||||||
%{_mandir}/man1/rdfproc.*
|
%{_mandir}/man1/rdfproc.*
|
||||||
@ -130,9 +112,8 @@ Requires: %{name} = %{version}-%{release}
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/redland-config
|
%{_bindir}/redland-config
|
||||||
%{_includedir}/*.h
|
%{_includedir}/*.h
|
||||||
%{_libdir}/*.a
|
%{_libdir}/librdf.a
|
||||||
%{_libdir}/*.la
|
%{_libdir}/librdf.so
|
||||||
%{_libdir}/*.so
|
|
||||||
%{_libdir}/pkgconfig/redland.pc
|
%{_libdir}/pkgconfig/redland.pc
|
||||||
%{_mandir}/man1/redland-config.*
|
%{_mandir}/man1/redland-config.*
|
||||||
%doc ChangeLog FAQS.html NEWS NOTICE README TODO
|
%doc ChangeLog FAQS.html NEWS NOTICE README TODO
|
||||||
@ -142,6 +123,9 @@ Requires: %{name} = %{version}-%{release}
|
|||||||
%{_datadir}/gtk-doc/html/redland/
|
%{_datadir}/gtk-doc/html/redland/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 28 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.17-4mamba
|
||||||
|
- specfile fixes and rebuild
|
||||||
|
|
||||||
* Sat Dec 12 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.17-3mamba
|
* Sat Dec 12 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.17-3mamba
|
||||||
- rebuilt with debug package
|
- rebuilt with debug package
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user