automatic update by autodist [release 1.0.17-1mamba;Sun Dec 29 2013]
This commit is contained in:
parent
8770b22c28
commit
3a2f3d5cb8
@ -1,2 +1,4 @@
|
|||||||
# librdf
|
# librdf
|
||||||
|
|
||||||
|
Redland is a set of free software libraries that provide support for the Resource Description Framework (RDF).
|
||||||
|
|
||||||
|
33
librdf-1.0.10-no_undefined.patch
Normal file
33
librdf-1.0.10-no_undefined.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
diff -up redland-1.0.10/src/Makefile.am.no_undefined redland-1.0.10/src/Makefile.am
|
||||||
|
--- redland-1.0.10/src/Makefile.am.no_undefined 2009-11-23 00:38:32.000000000 -0600
|
||||||
|
+++ redland-1.0.10/src/Makefile.am 2010-01-04 12:51:17.245649696 -0600
|
||||||
|
@@ -152,7 +152,7 @@ if STORAGE_VIRTUOSO
|
||||||
|
plugin_LTLIBRARIES += librdf_storage_virtuoso.la
|
||||||
|
librdf_storage_virtuoso_la_SOURCES = rdf_storage_virtuoso.c rdf_storage_virtuoso_internal.h
|
||||||
|
librdf_storage_virtuoso_la_CPPFLAGS = @ODBC_CFLAGS@
|
||||||
|
-librdf_storage_virtuoso_la_LIBADD = @ODBC_LIBS@
|
||||||
|
+librdf_storage_virtuoso_la_LIBADD = @ODBC_LIBS@ librdf.la
|
||||||
|
librdf_storage_virtuoso_la_LDFLAGS = -module -avoid-version
|
||||||
|
endif
|
||||||
|
|
||||||
|
diff -up redland-1.0.10/src/Makefile.in.no_undefined redland-1.0.10/src/Makefile.in
|
||||||
|
--- redland-1.0.10/src/Makefile.in.no_undefined 2009-12-14 00:53:52.000000000 -0600
|
||||||
|
+++ redland-1.0.10/src/Makefile.in 2010-01-04 12:56:01.389896396 -0600
|
||||||
|
@@ -214,7 +214,7 @@ librdf_storage_tstore_la_LINK = $(LIBTOO
|
||||||
|
$(librdf_storage_tstore_la_LDFLAGS) $(LDFLAGS) -o $@
|
||||||
|
@MODULAR_LIBRDF_TRUE@@STORAGE_TSTORE_TRUE@am_librdf_storage_tstore_la_rpath = \
|
||||||
|
@MODULAR_LIBRDF_TRUE@@STORAGE_TSTORE_TRUE@ -rpath $(plugindir)
|
||||||
|
-librdf_storage_virtuoso_la_DEPENDENCIES =
|
||||||
|
+librdf_storage_virtuoso_la_DEPENDENCIES = librdf.la
|
||||||
|
am__librdf_storage_virtuoso_la_SOURCES_DIST = rdf_storage_virtuoso.c \
|
||||||
|
rdf_storage_virtuoso_internal.h
|
||||||
|
@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@am_librdf_storage_virtuoso_la_OBJECTS = librdf_storage_virtuoso_la-rdf_storage_virtuoso.lo
|
||||||
|
@@ -570,7 +570,7 @@ plugindir = $(libdir)/redland
|
||||||
|
@MODULAR_LIBRDF_TRUE@@STORAGE_POSTGRESQL_TRUE@librdf_storage_postgresql_la_LDFLAGS = -module -avoid-version
|
||||||
|
@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_SOURCES = rdf_storage_virtuoso.c rdf_storage_virtuoso_internal.h
|
||||||
|
@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_CPPFLAGS = @ODBC_CFLAGS@
|
||||||
|
-@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_LIBADD = @ODBC_LIBS@
|
||||||
|
+@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_LIBADD = @ODBC_LIBS@ librdf.la
|
||||||
|
@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_LDFLAGS = -module -avoid-version
|
||||||
|
librdf_la_LIBADD = \
|
||||||
|
@LTLIBOBJS@ @DIGEST_OBJS@ @HASH_OBJS@ \
|
38
librdf-1.0.9-fix_undefined_symbol.patch
Normal file
38
librdf-1.0.9-fix_undefined_symbol.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
--- librdf/trunk/src/Makefile.am 2009/04/14 05:23:12 15151
|
||||||
|
+++ librdf/trunk/src/Makefile.am 2009/04/28 23:59:20 15171
|
||||||
|
@@ -119,7 +119,7 @@
|
||||||
|
plugin_LTLIBRARIES += librdf_storage_tstore.la
|
||||||
|
librdf_storage_tstore_la_SOURCES = rdf_storage_tstore.c
|
||||||
|
librdf_storage_tstore_la_CPPFLAGS = @TSTORE_CPPFLAGS@
|
||||||
|
-librdf_storage_tstore_la_LIBADD = @TSTORE_LIBS@
|
||||||
|
+librdf_storage_tstore_la_LIBADD = @TSTORE_LIBS@ librdf.la
|
||||||
|
librdf_storage_tstore_la_LDFLAGS = -module -avoid-version
|
||||||
|
endif
|
||||||
|
|
||||||
|
@@ -127,7 +127,7 @@
|
||||||
|
plugin_LTLIBRARIES += librdf_storage_mysql.la
|
||||||
|
librdf_storage_mysql_la_SOURCES = rdf_storage_mysql.c
|
||||||
|
librdf_storage_mysql_la_CPPFLAGS = @MYSQL_CPPFLAGS@
|
||||||
|
-librdf_storage_mysql_la_LIBADD = @MYSQL_LIBS@
|
||||||
|
+librdf_storage_mysql_la_LIBADD = @MYSQL_LIBS@ librdf.la
|
||||||
|
librdf_storage_mysql_la_LDFLAGS = -module -avoid-version
|
||||||
|
endif
|
||||||
|
|
||||||
|
@@ -135,7 +135,7 @@
|
||||||
|
plugin_LTLIBRARIES += librdf_storage_sqlite.la
|
||||||
|
librdf_storage_sqlite_la_SOURCES = rdf_storage_sqlite.c
|
||||||
|
librdf_storage_sqlite_la_CPPFLAGS = @SQLITE_CPPFLAGS@
|
||||||
|
-librdf_storage_sqlite_la_LIBADD = @SQLITE_LIBS@
|
||||||
|
+librdf_storage_sqlite_la_LIBADD = @SQLITE_LIBS@ librdf.la
|
||||||
|
librdf_storage_sqlite_la_LDFLAGS = -module -avoid-version
|
||||||
|
endif
|
||||||
|
|
||||||
|
@@ -143,7 +143,7 @@
|
||||||
|
plugin_LTLIBRARIES += librdf_storage_postgresql.la
|
||||||
|
librdf_storage_postgresql_la_SOURCES = rdf_storage_postgresql.c
|
||||||
|
librdf_storage_postgresql_la_CPPFLAGS = @POSTGRESQL_CPPFLAGS@
|
||||||
|
-librdf_storage_postgresql_la_LIBADD = @POSTGRESQL_LIBS@
|
||||||
|
+librdf_storage_postgresql_la_LIBADD = @POSTGRESQL_LIBS@ librdf.la
|
||||||
|
librdf_storage_postgresql_la_LDFLAGS = -module -avoid-version
|
||||||
|
endif
|
||||||
|
|
192
librdf.spec
Normal file
192
librdf.spec
Normal file
@ -0,0 +1,192 @@
|
|||||||
|
Name: librdf
|
||||||
|
Version: 1.0.17
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Redland RDF Libraries
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Aleph0 <aleph0@openmamba.org>
|
||||||
|
URL: http://librdf.org/
|
||||||
|
Source: http://download.librdf.org/source/redland-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-1.0.9-fix_undefined_symbol.patch
|
||||||
|
Patch1: %{name}-1.0.10-no_undefined.patch
|
||||||
|
License: LGPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: gtk-doc
|
||||||
|
BuildRequires: libdb47-devel
|
||||||
|
BuildRequires: libmysql5-devel
|
||||||
|
BuildRequires: libopenssl-devel
|
||||||
|
BuildRequires: libpostgresql-devel
|
||||||
|
BuildRequires: libraptor-devel
|
||||||
|
BuildRequires: librasqal-devel
|
||||||
|
BuildRequires: libsqlite-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: pkgconfig
|
||||||
|
BuildRequires: libcurl-devel
|
||||||
|
BuildRequires: libexpat-devel
|
||||||
|
BuildRequires: libsqlite3-devel
|
||||||
|
BuildRequires: libxslt-devel
|
||||||
|
%ifnarch arm
|
||||||
|
BuildRequires: virtuoso-opensource
|
||||||
|
%endif
|
||||||
|
#Provides: redland = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Redland is a set of free software libraries that provide support for the Resource Description Framework (RDF).
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Redland is a set of free software libraries that provide support for the Resource Description Framework (RDF).
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%package apidocs
|
||||||
|
Summary: %{pkgname} API documentation
|
||||||
|
Group: Documentation
|
||||||
|
Requires: gtk-doc
|
||||||
|
|
||||||
|
%description apidocs
|
||||||
|
%{name} API documentation.
|
||||||
|
|
||||||
|
%package mysql
|
||||||
|
Summary: %{pkgname} component for MySQL
|
||||||
|
Group: System/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description mysql
|
||||||
|
%{pkgname} component for MySQL.
|
||||||
|
|
||||||
|
%package postgresql
|
||||||
|
Summary: %{pkgname} component for PostgreSQL
|
||||||
|
Group: System/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description postgresql
|
||||||
|
%{pkgname} component for PostgreSQL.
|
||||||
|
|
||||||
|
%package sqlite
|
||||||
|
Summary: %{pkgname} component for SQLite
|
||||||
|
Group: System/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description sqlite
|
||||||
|
%{pkgname} component for SQLite.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n redland-%{version}
|
||||||
|
#%patch0 -p2
|
||||||
|
#%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure \
|
||||||
|
--enable-release \
|
||||||
|
--with-rasqal=system \
|
||||||
|
--with-raptor=system
|
||||||
|
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/rdfproc
|
||||||
|
%{_bindir}/redland-db-upgrade
|
||||||
|
%{_libdir}/librdf.so.*
|
||||||
|
%{_libdir}/redland/librdf_storage_mysql.a
|
||||||
|
%{_libdir}/redland/librdf_storage_mysql.la
|
||||||
|
%{_libdir}/redland/librdf_storage_mysql.so
|
||||||
|
%{_libdir}/redland/librdf_storage_postgresql.a
|
||||||
|
%{_libdir}/redland/librdf_storage_postgresql.la
|
||||||
|
%{_libdir}/redland/librdf_storage_postgresql.so
|
||||||
|
%{_libdir}/redland/librdf_storage_sqlite.a
|
||||||
|
%{_libdir}/redland/librdf_storage_sqlite.la
|
||||||
|
%{_libdir}/redland/librdf_storage_sqlite.so
|
||||||
|
%{_libdir}/redland/librdf_storage_virtuoso.a
|
||||||
|
%{_libdir}/redland/librdf_storage_virtuoso.la
|
||||||
|
%{_libdir}/redland/librdf_storage_virtuoso.so
|
||||||
|
%{_datadir}/redland/
|
||||||
|
%{_mandir}/man1/rdfproc.*
|
||||||
|
%{_mandir}/man1/redland-db-upgrade.*
|
||||||
|
%{_mandir}/man3/redland.*
|
||||||
|
%doc AUTHORS COPYING.LIB
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/redland-config
|
||||||
|
%{_includedir}/*.h
|
||||||
|
%{_libdir}/*.a
|
||||||
|
%{_libdir}/*.la
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_libdir}/pkgconfig/redland.pc
|
||||||
|
%{_mandir}/man1/redland-config.*
|
||||||
|
%doc ChangeLog FAQS.html NEWS NOTICE README TODO
|
||||||
|
|
||||||
|
%files apidocs
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_datadir}/gtk-doc/html/redland/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Dec 29 2013 Automatic Build System <autodist@mambasoft.it> 1.0.17-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu Jan 10 2013 Automatic Build System <autodist@mambasoft.it> 1.0.16-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Aug 08 2012 Automatic Build System <autodist@mambasoft.it> 1.0.15-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Oct 29 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.14-1mamba
|
||||||
|
- update to 1.0.14
|
||||||
|
|
||||||
|
* Sat Jul 02 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.12-1mamba
|
||||||
|
- update to 1.0.12
|
||||||
|
|
||||||
|
* Sat Jul 02 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.13-1mamba
|
||||||
|
- update to 1.0.13
|
||||||
|
|
||||||
|
* Wed Jul 14 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.10-3mamba
|
||||||
|
- rebuilt with --enable-release
|
||||||
|
- added no_undefined patch to fix missing dependency in librdf_storage_virtuoso.la and fix soprano build
|
||||||
|
|
||||||
|
* Tue Jun 29 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.10-2mamba
|
||||||
|
- rebuilt with new virtuoso-opensource
|
||||||
|
|
||||||
|
* Thu Jun 03 2010 Automatic Build System <autodist@mambasoft.it> 1.0.10-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sun Aug 09 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.9-2mamba
|
||||||
|
- added patch to fix undefined symbol: librdf_storage_register_factory
|
||||||
|
|
||||||
|
* Thu Apr 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.9-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Mar 11 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.8-4mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Nov 24 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.8-2mamba
|
||||||
|
- rebuilt against libdb47
|
||||||
|
- use system libraptor and librascal
|
||||||
|
|
||||||
|
* Thu Aug 28 2008 Aleph0 <aleph0@openmamba.org> 1.0.8-1mamba
|
||||||
|
- update to 1.0.8
|
||||||
|
|
||||||
|
* Fri Jan 11 2008 Aleph0 <aleph0@openmamba.org> 1.0.7-1mamba
|
||||||
|
- update to 1.0.7
|
||||||
|
|
||||||
|
* Thu Jul 05 2007 Aleph0 <aleph0@openmamba.org> 1.0.6-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user