automatic version update by autodist [release 6.1.4-1mamba;Mon Mar 25 2019]
This commit is contained in:
parent
4297ba2f1d
commit
1792ec602f
@ -1,4 +1,5 @@
|
||||
# libqwt
|
||||
|
||||
The Qwt library contains GUI Components and utility classes which are primarily useful for programs with a technical background. Beside a 2D plot widget it provides scales, sliders, dials, compasses, thermometers, wheels and knobs to control or display values, arrays, or ranges of type double.
|
||||
The Qwt library contains GUI Components and utility classes which are primarily useful for programs with a technical background.
|
||||
Beside a 2D plot widget it provides scales, sliders, dials, compasses, thermometers, wheels and knobs to control or display values, arrays, or ranges of type double.
|
||||
|
||||
|
64
libqwt-6.0.2-install_qt.patch
Normal file
64
libqwt-6.0.2-install_qt.patch
Normal file
@ -0,0 +1,64 @@
|
||||
diff -up qwt-6.0.1/qwtbuild.pri.install-qt qwt-6.0.1/qwtbuild.pri
|
||||
--- qwt-6.0.1/qwtbuild.pri.install-qt 2011-08-01 09:33:53.000000000 -0500
|
||||
+++ qwt-6.0.1/qwtbuild.pri 2012-11-26 16:32:07.290520771 -0600
|
||||
@@ -14,7 +14,6 @@
|
||||
CONFIG += qt
|
||||
CONFIG += warn_on
|
||||
CONFIG += no_keywords
|
||||
-CONFIG += silent
|
||||
|
||||
######################################################################
|
||||
# release/debug mode
|
||||
@@ -56,7 +55,7 @@ RCC_DIR = resources
|
||||
|
||||
unix {
|
||||
|
||||
- exists( $${QMAKE_LIBDIR_QT}/libqwt.* ) {
|
||||
+ exists( $${QMAKE_LIBDIR_QT}/libqwt.so ) {
|
||||
|
||||
# On some Linux distributions the Qwt libraries are installed
|
||||
# in the same directory as the Qt libraries. Unfortunately
|
||||
diff -up qwt-6.0.1/qwtconfig.pri.install-qt qwt-6.0.1/qwtconfig.pri
|
||||
--- qwt-6.0.1/qwtconfig.pri.install-qt 2011-08-01 09:33:53.000000000 -0500
|
||||
+++ qwt-6.0.1/qwtconfig.pri 2012-11-26 16:29:01.360797707 -0600
|
||||
@@ -18,6 +18,13 @@ QWT_VERSION = $${QWT_VER_MAJ}.$${QW
|
||||
|
||||
QWT_INSTALL_PREFIX = $$[QT_INSTALL_PREFIX]
|
||||
|
||||
+CONFIG(install-qt) {
|
||||
+QWT_INSTALL_DOCS = $$[QT_INSTALL_DOCS]/html
|
||||
+QWT_INSTALL_HEADERS = $$[QT_INSTALL_HEADERS]/qwt
|
||||
+QWT_INSTALL_LIBS = $$[QT_INSTALL_LIBS]
|
||||
+QWT_INSTALL_PLUGINS = $$[QT_INSTALL_PLUGINS]/designer
|
||||
+QWT_INSTALL_FEATURES = $$[QMAKE_MKSPECS]/features
|
||||
+} else {
|
||||
unix {
|
||||
QWT_INSTALL_PREFIX = /usr/local/qwt-$$QWT_VERSION
|
||||
}
|
||||
@@ -51,6 +58,7 @@ QWT_INSTALL_PLUGINS = $${QWT_INSTALL_P
|
||||
|
||||
QWT_INSTALL_FEATURES = $${QWT_INSTALL_PREFIX}/features
|
||||
# QWT_INSTALL_FEATURES = $${QT_INSTALL_PREFIX}/features
|
||||
+}
|
||||
|
||||
######################################################################
|
||||
# Build the static/shared libraries.
|
||||
diff -up qwt-6.0.1/src/src.pro.install-qt qwt-6.0.1/src/src.pro
|
||||
--- qwt-6.0.1/src/src.pro.install-qt 2011-08-01 09:33:53.000000000 -0500
|
||||
+++ qwt-6.0.1/src/src.pro 2012-11-26 16:29:01.361797695 -0600
|
||||
@@ -16,6 +16,15 @@ include( $${QWT_ROOT}/qwtbuild.pri )
|
||||
TEMPLATE = lib
|
||||
TARGET = $$qtLibraryTarget(qwt)
|
||||
|
||||
+# pkgconfig support
|
||||
+CONFIG += create_pc create_prl no_install_prl
|
||||
+QMAKE_PKGCONFIG_NAME = qwt
|
||||
+QMAKE_PKGCONFIG_DESCRIPTION = Qt Widgets for Technical Applications
|
||||
+QMAKE_PKGCONFIG_LIBDIR = $${QWT_INSTALL_LIBS}
|
||||
+QMAKE_PKGCONFIG_INCDIR = $${QWT_INSTALL_HEADERS}
|
||||
+QMAKE_PKGCONFIG_REQUIRES = QtGui QtSvg
|
||||
+QMAKE_PKGCONFIG_DESTDIR = pkgconfig
|
||||
+
|
||||
DESTDIR = $${QWT_ROOT}/lib
|
||||
|
||||
contains(QWT_CONFIG, QwtDll) {
|
20
libqwt-6.0.2-project_error.patch
Normal file
20
libqwt-6.0.2-project_error.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- qwt-6.0.2/qwtbuild.pri.orig 2013-01-11 04:23:05.001149320 +0100
|
||||
+++ qwt-6.0.2/qwtbuild.pri 2013-01-11 04:23:15.355436864 +0100
|
||||
@@ -64,17 +64,3 @@
|
||||
!debug_and_release {
|
||||
OBJECTS_DIR = obj
|
||||
}
|
||||
-
|
||||
-unix {
|
||||
-
|
||||
- exists( $${QMAKE_LIBDIR_QT}/libqwt.so ) {
|
||||
-
|
||||
- # On some Linux distributions the Qwt libraries are installed
|
||||
- # in the same directory as the Qt libraries. Unfortunately
|
||||
- # qmake always adds QMAKE_LIBDIR_QT at the beginning of the
|
||||
- # linker path, so that the installed libraries will be
|
||||
- # used instead of the local ones.
|
||||
-
|
||||
- error( "local build will conflict with $${QMAKE_LIBDIR_QT}/libqwt.*" )
|
||||
- }
|
||||
-}
|
79
libqwt.spec
79
libqwt.spec
@ -1,53 +1,61 @@
|
||||
Name: libqwt
|
||||
Version: 5.2.1
|
||||
Release: 2mamba
|
||||
Summary: GUI Components and utility classes which are primarily useful for programs with a technical background
|
||||
Version: 6.1.4
|
||||
Release: 1mamba
|
||||
Summary: Qt Widgets for Technical Applications
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://qwt.sourceforge.net/
|
||||
URL: http://qwt.sourceforge.net
|
||||
Source: http://downloads.sourceforge.net/project/qwt/qwt/%{version}/qwt-%{version}.tar.bz2
|
||||
Source1: qwtconfig-openmamba.pri
|
||||
Patch1: libqwt-6.0.2-install_qt.patch
|
||||
Patch2: libqwt-6.0.2-project_error.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libqt4-designer
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The Qwt library contains GUI Components and utility classes which are primarily useful for programs with a technical background. Beside a 2D plot widget it provides scales, sliders, dials, compasses, thermometers, wheels and knobs to control or display values, arrays, or ranges of type double.
|
||||
The Qwt library contains GUI Components and utility classes which are primarily useful for programs with a technical background.
|
||||
Beside a 2D plot widget it provides scales, sliders, dials, compasses, thermometers, wheels and knobs to control or display values, arrays, or ranges of type double.
|
||||
|
||||
%package devel
|
||||
Summary: Development file for libqwt
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: pkg-config
|
||||
|
||||
%description devel
|
||||
The Qwt library contains GUI Components and utility classes which are primarily useful for programs with a technical background. Beside a 2D plot widget it provides scales, sliders, dials, compasses, thermometers, wheels and knobs to control or display values, arrays, or ranges of type double.
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
This package contains the header files needed for development with %{name}.
|
||||
%package apidocs
|
||||
Group: Documentation
|
||||
Summary: API documentation for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description apidocs
|
||||
API documentation for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n qwt-%{version}
|
||||
sed -i "s|\(INSTALLBASE[[:space:]]*= \).*|\1%{_prefix}|" qwtconfig.pri
|
||||
sed -i "s|\(doc.path[[:space:]]*= \).*|\1%{_datadir}|" qwtconfig.pri
|
||||
sed -i "s|\(target.path[[:space:]]*= \).*|\1%{_libdir}|" qwtconfig.pri
|
||||
sed -i "s|#\(CONFIG[[:space:]]*+=[[:space:]]*QwtSVGItem.*\)|\1|" qwtconfig.pri
|
||||
cp %{SOURCE1} qwtconfig.pri
|
||||
sed -i "s|%LIB%|%{_lib}|" qwtconfig.pri
|
||||
|
||||
%build
|
||||
qmake-qt4
|
||||
%_qt4_qmake \
|
||||
CONFIG+=install-qt
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall INSTALL_ROOT=%{buildroot}
|
||||
|
||||
mkdir -p %{buildroot}%{_docdir}/qwt-%{version}
|
||||
mv %{buildroot}%{_datadir}/html %{buildroot}%{_docdir}/qwt-%{version}
|
||||
%makeinstall \
|
||||
INSTALL_ROOT=%{buildroot}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -58,25 +66,34 @@ mv %{buildroot}%{_datadir}/html %{buildroot}%{_docdir}/qwt-%{version}
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libqwt.so.*
|
||||
%{_qt4_plugindir}/designer/libqwt_designer_plugin.so
|
||||
%{_mandir}/man3/controlscreenshots.3.gz
|
||||
%{_mandir}/man3/curvescreenshots.3.gz
|
||||
%{_mandir}/man3/deprecated.3.gz
|
||||
%{_mandir}/man3/histogramscreenshots.3.gz
|
||||
%{_mandir}/man3/Qwt*.3.gz
|
||||
%{_mandir}/man3/qwtinstall.3.gz
|
||||
%{_mandir}/man3/qwtlicense.3.gz
|
||||
%{_mandir}/man3/scatterscreenshots.3.gz
|
||||
%{_mandir}/man3/spectrogramscreenshots.3.gz
|
||||
%{_docdir}/qwt-%{version}/*
|
||||
%doc CHANGES COPYING README
|
||||
%doc COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/qwt
|
||||
%{_includedir}/qwt/*.h
|
||||
%{_libdir}/libqwt.so
|
||||
%{_includedir}/qwt*.h
|
||||
#%{_mandir}/man3/*
|
||||
%doc README
|
||||
|
||||
%files apidocs
|
||||
%defattr(-,root,root)
|
||||
%dir %{_docdir}/qwt
|
||||
%{_docdir}/qwt/*
|
||||
|
||||
%changelog
|
||||
* Mon Mar 25 2019 Automatic Build System <autodist@mambasoft.it> 6.1.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Nov 07 2016 Automatic Build System <autodist@mambasoft.it> 6.1.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Dec 27 2015 Automatic Build System <autodist@mambasoft.it> 6.1.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Jan 11 2013 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 6.0.2-1mamba
|
||||
- update to 6.0.2
|
||||
|
||||
* Mon Aug 23 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.1-2mamba
|
||||
- enable build of QwtSVGItem as required by kdebindings 4.5.0
|
||||
|
||||
|
118
qwtconfig-openmamba.pri
Normal file
118
qwtconfig-openmamba.pri
Normal file
@ -0,0 +1,118 @@
|
||||
################################################################
|
||||
# Qwt Widget Library
|
||||
# Copyright (C) 1997 Josef Wilgen
|
||||
# Copyright (C) 2002 Uwe Rathmann
|
||||
#
|
||||
# This library is free software; you can redistribute it and/or
|
||||
# modify it under the terms of the Qwt License, Version 1.0
|
||||
################################################################
|
||||
|
||||
QWT_VER_MAJ = 6
|
||||
QWT_VER_MIN = 1
|
||||
QWT_VER_PAT = 2
|
||||
QWT_VERSION = $${QWT_VER_MAJ}.$${QWT_VER_MIN}.$${QWT_VER_PAT}
|
||||
|
||||
######################################################################
|
||||
# Install paths
|
||||
######################################################################
|
||||
|
||||
QWT_INSTALL_PREFIX = $$[QT_INSTALL_PREFIX]
|
||||
|
||||
unix {
|
||||
QWT_INSTALL_PREFIX = /usr
|
||||
}
|
||||
|
||||
win32 {
|
||||
QWT_INSTALL_PREFIX = C:/Qwt
|
||||
}
|
||||
|
||||
QWT_INSTALL_DOCS = $${QWT_INSTALL_PREFIX}/share/doc/qwt
|
||||
QWT_INSTALL_HEADERS = $${QWT_INSTALL_PREFIX}/include/qwt
|
||||
QWT_INSTALL_LIBS = $${QWT_INSTALL_PREFIX}/%LIB%
|
||||
|
||||
######################################################################
|
||||
# Designer plugin
|
||||
######################################################################
|
||||
|
||||
#QWT_INSTALL_PLUGINS = $${QWT_INSTALL_PREFIX}/plugins/designer
|
||||
# QWT_INSTALL_PLUGINS = $${QT_INSTALL_PREFIX}/plugins/designer
|
||||
|
||||
######################################################################
|
||||
# Features
|
||||
# When building a Qwt application with qmake you might want to load
|
||||
# the compiler/linker flags, that are required to build a Qwt application
|
||||
# from qwt.prf. Therefore all you need to do is to add "CONFIG += qwt"
|
||||
# to your project file and take care, that qwt.prf can be found by qmake.
|
||||
# ( see http://doc.trolltech.com/4.7/qmake-advanced-usage.html#adding-new-configuration-features )
|
||||
# I recommend not to install the Qwt features together with the
|
||||
# Qt features, because you will have to reinstall the Qwt features,
|
||||
# with every Qt upgrade.
|
||||
######################################################################
|
||||
|
||||
#QWT_INSTALL_FEATURES = $${QWT_INSTALL_PREFIX}/features
|
||||
# QWT_INSTALL_FEATURES = $${QT_INSTALL_PREFIX}/features
|
||||
|
||||
######################################################################
|
||||
# Build the static/shared libraries.
|
||||
# If QwtDll is enabled, a shared library is built, otherwise
|
||||
# it will be a static library.
|
||||
######################################################################
|
||||
|
||||
QWT_CONFIG += QwtDll
|
||||
|
||||
######################################################################
|
||||
# QwtPlot enables all classes, that are needed to use the QwtPlot
|
||||
# widget.
|
||||
######################################################################
|
||||
|
||||
QWT_CONFIG += QwtPlot
|
||||
|
||||
######################################################################
|
||||
# QwtWidgets enables all classes, that are needed to use the all other
|
||||
# widgets (sliders, dials, ...), beside QwtPlot.
|
||||
######################################################################
|
||||
|
||||
QWT_CONFIG += QwtWidgets
|
||||
|
||||
######################################################################
|
||||
# If you want to display svg images on the plot canvas, or
|
||||
# export a plot to a SVG document
|
||||
######################################################################
|
||||
|
||||
QWT_CONFIG += QwtSvg
|
||||
|
||||
######################################################################
|
||||
# You can use the MathML renderer of the Qt solutions package to
|
||||
# enable MathML support in Qwt. Because of license implications
|
||||
# the ( modified ) code of the MML Widget solution is included and
|
||||
# linked together with the QwtMathMLTextEngine into an own library.
|
||||
# To use it you will have to add "CONFIG += qwtmathml"
|
||||
# to your qmake project file.
|
||||
######################################################################
|
||||
|
||||
#QWT_CONFIG += QwtMathML
|
||||
|
||||
######################################################################
|
||||
# If you want to build the Qwt designer plugin,
|
||||
# enable the line below.
|
||||
# Otherwise you have to build it from the designer directory.
|
||||
######################################################################
|
||||
|
||||
QWT_CONFIG += QwtDesigner
|
||||
|
||||
######################################################################
|
||||
# If you want to auto build the examples, enable the line below
|
||||
# Otherwise you have to build them from the examples directory.
|
||||
######################################################################
|
||||
|
||||
#QWT_CONFIG += QwtExamples
|
||||
|
||||
######################################################################
|
||||
# When Qt has been built as framework qmake ( qtAddLibrary ) wants
|
||||
# to link frameworks instead of regular libs
|
||||
######################################################################
|
||||
|
||||
macx:CONFIG(qt_framework, qt_framework|qt_no_framework) {
|
||||
|
||||
QWT_CONFIG += QwtFramework
|
||||
}
|
Loading…
Reference in New Issue
Block a user