rebuilt with debug enabled [release 4.8.7-2mamba;Mon Jul 04 2016]
This commit is contained in:
parent
4c00707660
commit
4829d03d73
35
libqt4-4.8.7-gcc-6.1.0.patch
Normal file
35
libqt4-4.8.7-gcc-6.1.0.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
diff -up qt-everywhere-opensource-src-4.8.7/configure.gcc6 qt-everywhere-opensource-src-4.8.7/configure
|
||||||
|
--- qt-everywhere-opensource-src-4.8.7/configure.gcc6 2016-04-15 07:04:19.430268222 -0500
|
||||||
|
+++ qt-everywhere-opensource-src-4.8.7/configure 2016-04-15 07:05:22.157568689 -0500
|
||||||
|
@@ -7744,7 +7744,7 @@ case "$XPLATFORM" in
|
||||||
|
*-g++*)
|
||||||
|
# Check gcc's version
|
||||||
|
case "$(${QMAKE_CONF_COMPILER} -dumpversion)" in
|
||||||
|
- 5*|4*|3.4*)
|
||||||
|
+ 8*|7*|6*|5*|4*|3.4*)
|
||||||
|
;;
|
||||||
|
3.3*)
|
||||||
|
canBuildWebKit="no"
|
||||||
|
@@ -8060,7 +8060,7 @@ g++*)
|
||||||
|
3.*)
|
||||||
|
COMPILER_VERSION="3.*"
|
||||||
|
;;
|
||||||
|
- 5*|4.*)
|
||||||
|
+ 8*|7*|6*|5*|4.*)
|
||||||
|
COMPILER_VERSION="4"
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
diff -up qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.gcc6 qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h
|
||||||
|
--- qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.gcc6 2015-05-07 09:14:48.000000000 -0500
|
||||||
|
+++ qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h 2016-04-15 07:04:19.431268227 -0500
|
||||||
|
@@ -70,8 +70,8 @@ namespace QPatternist
|
||||||
|
ForegroundShift = 10,
|
||||||
|
BackgroundShift = 20,
|
||||||
|
SpecialShift = 20,
|
||||||
|
- ForegroundMask = ((1 << ForegroundShift) - 1) << ForegroundShift,
|
||||||
|
- BackgroundMask = ((1 << BackgroundShift) - 1) << BackgroundShift
|
||||||
|
+ ForegroundMask = 0x1f << ForegroundShift,
|
||||||
|
+ BackgroundMask = 0x7 << BackgroundShift
|
||||||
|
};
|
||||||
|
|
||||||
|
public:
|
27
libqt4.spec
27
libqt4.spec
@ -23,7 +23,7 @@
|
|||||||
|
|
||||||
Name: libqt4
|
Name: libqt4
|
||||||
Version: 4.8.7
|
Version: 4.8.7
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A multiplatform, C++ GUI application development framework
|
Summary: A multiplatform, C++ GUI application development framework
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -52,6 +52,7 @@ Patch5: libqt4-4.8.4-set-alpha-flags-after-converto32-in-eglcreatesurface
|
|||||||
Patch6: libqt4-4.8.6-glib-honor-ExcludeSocketNotifiers-flag.patch
|
Patch6: libqt4-4.8.6-glib-honor-ExcludeSocketNotifiers-flag.patch
|
||||||
Patch7: libqt4-4.8.6-qclipboard_fix_recursive.patch
|
Patch7: libqt4-4.8.6-qclipboard_fix_recursive.patch
|
||||||
Patch8: libqt4-4.8.6-qclipboard_delay.patch
|
Patch8: libqt4-4.8.6-qclipboard_delay.patch
|
||||||
|
Patch9: libqt4-4.8.7-gcc-6.1.0.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -545,6 +546,7 @@ Phonon development files for %{name}.
|
|||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch7 -p0
|
%patch7 -p0
|
||||||
%patch8 -p0
|
%patch8 -p0
|
||||||
|
%patch9 -p1
|
||||||
|
|
||||||
sed -i -e "s|-O2|%{optflags}|g" mkspecs/%{platform}/qmake.conf
|
sed -i -e "s|-O2|%{optflags}|g" mkspecs/%{platform}/qmake.conf
|
||||||
|
|
||||||
@ -554,6 +556,8 @@ export qtbuilddir=`pwd`
|
|||||||
export PATH=$qtbuilddir/bin:$PATH
|
export PATH=$qtbuilddir/bin:$PATH
|
||||||
export MANPATH=$qtbuilddir/doc/man:$MANPATH
|
export MANPATH=$qtbuilddir/doc/man:$MANPATH
|
||||||
export LD_LIBRARY_PATH=$qtbuilddir/lib:$LD_LIBRARY_PATH
|
export LD_LIBRARY_PATH=$qtbuilddir/lib:$LD_LIBRARY_PATH
|
||||||
|
# workaround for class std::auto_ptr' is deprecated with gcc-6
|
||||||
|
export CXXFLAGS="%{optflags} -std=gnu++98 -Wno-deprecated"
|
||||||
|
|
||||||
./configure \
|
./configure \
|
||||||
-prefix %{_qt4_prefix} \
|
-prefix %{_qt4_prefix} \
|
||||||
@ -576,7 +580,7 @@ export LD_LIBRARY_PATH=$qtbuilddir/lib:$LD_LIBRARY_PATH
|
|||||||
%ifarch arm
|
%ifarch arm
|
||||||
-egl \
|
-egl \
|
||||||
%endif
|
%endif
|
||||||
-release \
|
-debug \
|
||||||
-shared \
|
-shared \
|
||||||
-cups \
|
-cups \
|
||||||
-fontconfig \
|
-fontconfig \
|
||||||
@ -629,10 +633,10 @@ for d in QtDeclarative QtCore QtScript QtGui; do
|
|||||||
done
|
done
|
||||||
|
|
||||||
# install libwebcore.a and libjscore.a
|
# install libwebcore.a and libjscore.a
|
||||||
install -m755 src/3rdparty/webkit/Source/WebCore/release/libwebcore.a %{buildroot}%{_libdir}/libwebcore.a
|
#install -m755 src/3rdparty/webkit/Source/WebCore/release/libwebcore.a %{buildroot}%{_libdir}/libwebcore.a
|
||||||
install -m644 src/3rdparty/webkit/Source/WebCore/release/libwebcore.prl %{buildroot}%{_libdir}/libwebcore.prl
|
#install -m644 src/3rdparty/webkit/Source/WebCore/release/libwebcore.prl %{buildroot}%{_libdir}/libwebcore.prl
|
||||||
install -m755 src/3rdparty/webkit/Source/JavaScriptCore/release/libjscore.a %{buildroot}%{_libdir}/libjscore.a
|
#install -m755 src/3rdparty/webkit/Source/JavaScriptCore/release/libjscore.a %{buildroot}%{_libdir}/libjscore.a
|
||||||
install -m644 src/3rdparty/webkit/Source/JavaScriptCore/release/libjscore.prl %{buildroot}%{_libdir}/libjscore.prl
|
#install -m644 src/3rdparty/webkit/Source/JavaScriptCore/release/libjscore.prl %{buildroot}%{_libdir}/libjscore.prl
|
||||||
|
|
||||||
install -p -m644 LICENSE.GPL3 %{buildroot}%{_qt4_prefix}/
|
install -p -m644 LICENSE.GPL3 %{buildroot}%{_qt4_prefix}/
|
||||||
|
|
||||||
@ -985,10 +989,10 @@ echo "\
|
|||||||
%{_qt4_headerdir}/QtDeclarative/
|
%{_qt4_headerdir}/QtDeclarative/
|
||||||
%{?build_phonon:%exclude %{_qt4_headerdir}/phonon/}
|
%{?build_phonon:%exclude %{_qt4_headerdir}/phonon/}
|
||||||
#%{?build_phonon:%exclude %{_qt4_headerdir}/Qt/phonon*}
|
#%{?build_phonon:%exclude %{_qt4_headerdir}/Qt/phonon*}
|
||||||
%{_qt4_libdir}/libwebcore.a
|
#%{_qt4_libdir}/libwebcore.a
|
||||||
%{_qt4_libdir}/libwebcore.prl
|
#%{_qt4_libdir}/libwebcore.prl
|
||||||
%{_qt4_libdir}/libjscore.a
|
#%{_qt4_libdir}/libjscore.a
|
||||||
%{_qt4_libdir}/libjscore.prl
|
#%{_qt4_libdir}/libjscore.prl
|
||||||
%{_qt4_libdir}/libQtUiTools.a
|
%{_qt4_libdir}/libQtUiTools.a
|
||||||
%{_qt4_libdir}/libQt3Support.la
|
%{_qt4_libdir}/libQt3Support.la
|
||||||
%{_qt4_libdir}/libQt3Support.prl
|
%{_qt4_libdir}/libQt3Support.prl
|
||||||
@ -1159,6 +1163,9 @@ echo "\
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 04 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.7-2mamba
|
||||||
|
- rebuilt with debug enabled
|
||||||
|
|
||||||
* Sun Jun 07 2015 Automatic Build System <autodist@mambasoft.it> 4.8.7-1mamba
|
* Sun Jun 07 2015 Automatic Build System <autodist@mambasoft.it> 4.8.7-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user