added patch to fix moc with libboost 1.65 [release 4.8.7-4mamba;Mon Oct 23 2017]
This commit is contained in:
parent
21644f178c
commit
420d968be0
12
libqt4-4.8.7-QT_VERSION_CHECK.patch
Normal file
12
libqt4-4.8.7-QT_VERSION_CHECK.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up qt-everywhere-opensource-src-4.8.7/src/corelib/global/qglobal.h.majmin qt-everywhere-opensource-src-4.8.7/src/corelib/global/qglobal.h
|
||||||
|
--- qt-everywhere-opensource-src-4.8.7/src/corelib/global/qglobal.h.majmin 2015-05-07 09:14:48.000000000 -0500
|
||||||
|
+++ qt-everywhere-opensource-src-4.8.7/src/corelib/global/qglobal.h 2016-12-08 12:10:29.677359701 -0600
|
||||||
|
@@ -52,7 +52,7 @@
|
||||||
|
/*
|
||||||
|
can be used like #if (QT_VERSION >= QT_VERSION_CHECK(4, 4, 0))
|
||||||
|
*/
|
||||||
|
-#define QT_VERSION_CHECK(major, minor, patch) ((major<<16)|(minor<<8)|(patch))
|
||||||
|
+#define QT_VERSION_CHECK(qt_version_check_major, qt_version_check_minor, qt_version_check_patch) ((qt_version_check_major<<16)|(qt_version_check_minor<<8)|(qt_version_check_patch))
|
||||||
|
|
||||||
|
#define QT_PACKAGEDATE_STR "2015-05-07"
|
||||||
|
|
11
libqt4-4.8.7-icu-59.patch
Normal file
11
libqt4-4.8.7-icu-59.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- qt-everywhere-opensource-src-4.8.7/src/corelib/tools/qlocale_icu.cpp~ 2017-04-25 07:42:22.000000000 +0000
|
||||||
|
+++ qt-everywhere-opensource-src-4.8.7/src/corelib/tools/qlocale_icu.cpp 2017-04-25 07:44:34.675363008 +0000
|
||||||
|
@@ -43,6 +43,8 @@
|
||||||
|
#include "qlibrary.h"
|
||||||
|
#include "qdebug.h"
|
||||||
|
|
||||||
|
+#define UCHAR_TYPE unsigned short
|
||||||
|
+
|
||||||
|
#include "unicode/uversion.h"
|
||||||
|
#include "unicode/ucol.h"
|
||||||
|
|
17
libqt4-4.8.7-libboost-1.65.patch
Normal file
17
libqt4-4.8.7-libboost-1.65.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
diff -up qt-everywhere-opensource-src-4.8.7/src/tools/moc/main.cpp.QTBUG-22829 qt-everywhere-opensource-src-4.8.7/src/tools/moc/main.cpp
|
||||||
|
--- qt-everywhere-opensource-src-4.8.7/src/tools/moc/main.cpp.QTBUG-22829 2015-05-07 09:14:44.000000000 -0500
|
||||||
|
+++ qt-everywhere-opensource-src-4.8.7/src/tools/moc/main.cpp 2016-12-08 12:32:46.638962448 -0600
|
||||||
|
@@ -188,8 +188,12 @@ int runMoc(int _argc, char **_argv)
|
||||||
|
pp.macros["Q_MOC_RUN"];
|
||||||
|
pp.macros["__cplusplus"];
|
||||||
|
|
||||||
|
- // Workaround a bug while parsing the boost/type_traits/has_operator.hpp header. See QTBUG-22829
|
||||||
|
+ // Workaround a bugs while parsing some boost headers. See QTBUG-22829
|
||||||
|
pp.macros["BOOST_TT_HAS_OPERATOR_HPP_INCLUDED"];
|
||||||
|
+ pp.macros["BOOST_LEXICAL_CAST_INCLUDED"];
|
||||||
|
+ pp.macros["BOOST_NEXT_PRIOR_HPP_INCLUDED"];
|
||||||
|
+ pp.macros["BOOST_TYPE_TRAITS_HPP"];
|
||||||
|
+ pp.macros["_SYS_SYSMACROS_H_OUTER"];
|
||||||
|
|
||||||
|
QByteArray filename;
|
||||||
|
QByteArray output;
|
11
libqt4.spec
11
libqt4.spec
@ -23,7 +23,7 @@
|
|||||||
|
|
||||||
Name: libqt4
|
Name: libqt4
|
||||||
Version: 4.8.7
|
Version: 4.8.7
|
||||||
Release: 3mamba
|
Release: 4mamba
|
||||||
Summary: A multiplatform, C++ GUI application development framework
|
Summary: A multiplatform, C++ GUI application development framework
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -53,6 +53,9 @@ Patch6: libqt4-4.8.6-glib-honor-ExcludeSocketNotifiers-flag.patch
|
|||||||
Patch7: libqt4-4.8.6-qclipboard_fix_recursive.patch
|
Patch7: libqt4-4.8.6-qclipboard_fix_recursive.patch
|
||||||
Patch8: libqt4-4.8.6-qclipboard_delay.patch
|
Patch8: libqt4-4.8.6-qclipboard_delay.patch
|
||||||
Patch9: libqt4-4.8.7-gcc-6.1.0.patch
|
Patch9: libqt4-4.8.7-gcc-6.1.0.patch
|
||||||
|
Patch10: libqt4-4.8.7-libboost-1.65.patch
|
||||||
|
Patch11: libqt4-4.8.7-QT_VERSION_CHECK.patch
|
||||||
|
Patch12: libqt4-4.8.7-icu-59.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -547,6 +550,9 @@ Phonon development files for %{name}.
|
|||||||
%patch7 -p0
|
%patch7 -p0
|
||||||
%patch8 -p0
|
%patch8 -p0
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
|
%patch10 -p1
|
||||||
|
%patch11 -p1
|
||||||
|
%patch12 -p1
|
||||||
|
|
||||||
sed -i -e "s|-O2|%{optflags}|g" mkspecs/%{platform}/qmake.conf
|
sed -i -e "s|-O2|%{optflags}|g" mkspecs/%{platform}/qmake.conf
|
||||||
|
|
||||||
@ -1162,6 +1168,9 @@ echo "\
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 23 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.7-4mamba
|
||||||
|
- added patch to fix moc with libboost 1.65
|
||||||
|
|
||||||
* Fri Jul 15 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.7-3mamba
|
* Fri Jul 15 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.7-3mamba
|
||||||
- rollback enabling debug because if breaks e.g. VirtualBox
|
- rollback enabling debug because if breaks e.g. VirtualBox
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user