added gcc 4.7 build patch [release 2.0.3-2mamba;Thu Jan 24 2013]
This commit is contained in:
parent
be99666de5
commit
d59b1ea260
@ -1,2 +1,5 @@
|
||||
# libqca
|
||||
|
||||
Taking a hint from the similarly-named Java Cryptography Architecture, QCA aims to provide a straightforward and cross-platform crypto API, using Qt datatypes and conventions.
|
||||
QCA separates the API from the implementation, using plugins known as Providers.
|
||||
|
||||
|
100
libqca.spec
Normal file
100
libqca.spec
Normal file
@ -0,0 +1,100 @@
|
||||
%define majorminor %(echo %version | cut -d. -f 1-2)
|
||||
|
||||
Name: libqca
|
||||
Version: 2.0.3
|
||||
Release: 2mamba
|
||||
Summary: Qt Cryptographic Architecture (QCA)
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Aleph0 <aleph0@openmamba.org>
|
||||
URL: http://delta.affinix.com/qca/
|
||||
Source: http://delta.affinix.com/download/qca/%{majorminor}/qca-%{version}.tar.bz2
|
||||
Patch0: qca-2.0.3-gcc-4.7.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Taking a hint from the similarly-named Java Cryptography Architecture, QCA aims to provide a straightforward and cross-platform crypto API, using Qt datatypes and conventions.
|
||||
QCA separates the API from the implementation, using plugins known as Providers.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Taking a hint from the similarly-named Java Cryptography Architecture, QCA aims to provide a straightforward and cross-platform crypto API, using Qt datatypes and conventions.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q -n qca-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
./configure \
|
||||
--release \
|
||||
--prefix=%{_qt4_prefix} \
|
||||
--bindir=%{_qt4_bindir} \
|
||||
--datadir=%{_qt4_datadir} \
|
||||
--includedir=%{_qt4_headerdir} \
|
||||
--libdir=%{_qt4_libdir}
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
make install INSTALL_ROOT=%{buildroot}
|
||||
|
||||
install -d %{buildroot}%{_mandir}/man1
|
||||
mv %{buildroot}%{_qt4_datadir}/man/man1/qcatool2.1 \
|
||||
%{buildroot}%{_mandir}/man1/qcatool2.1
|
||||
|
||||
rm -f %{buildroot}%{_qt4_libdir}/libqca.so.*.debug
|
||||
rm -f %{buildroot}%{_qt4_bindir}/qcatool2.debug
|
||||
# FIXME
|
||||
rm -fr %{buildroot}%{_qt4_datadir}/qca/certs
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_qt4_bindir}/qcatool2
|
||||
%{_qt4_libdir}/libqca.so.*
|
||||
%{_mandir}/man1/qcatool*
|
||||
%doc COPYING README TODO
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_qt4_datadir}/mkspecs/features/crypto.prf
|
||||
%{_qt4_headerdir}/QtCrypto/
|
||||
%{_qt4_libdir}/libqca.prl
|
||||
%{_qt4_libdir}/libqca.so
|
||||
%{_libdir}/pkgconfig/qca2.pc
|
||||
|
||||
%changelog
|
||||
* Thu Jan 24 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.3-2mamba
|
||||
- added gcc 4.7 build patch
|
||||
|
||||
* Wed Dec 01 2010 Automatic Build System <autodist@mambasoft.it> 2.0.3-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Apr 30 2009 Automatic Build System <autodist@mambasoft.it> 2.0.2-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Oct 12 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.1-2mamba
|
||||
- rebuilt
|
||||
|
||||
* Fri Aug 29 2008 Aleph0 <aleph0@openmamba.org> 2.0.1-1mamba
|
||||
- package created by autospec
|
12
qca-2.0.3-gcc-4.7.patch
Normal file
12
qca-2.0.3-gcc-4.7.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru qca-2.0.3.orig/src/botantools/botan/botan/secmem.h qca-2.0.3/src/botantools/botan/botan/secmem.h
|
||||
--- qca-2.0.3.orig/src/botantools/botan/botan/secmem.h 2007-04-19 23:26:13.000000000 +0200
|
||||
+++ qca-2.0.3/src/botantools/botan/botan/secmem.h 2013-01-24 11:44:22.356084926 +0100
|
||||
@@ -214,7 +214,7 @@
|
||||
|
||||
SecureVector(u32bit n = 0) { MemoryRegion<T>::init(true, n); }
|
||||
SecureVector(const T in[], u32bit n)
|
||||
- { MemoryRegion<T>::init(true); set(in, n); }
|
||||
+ { MemoryRegion<T>::init(true); this->set(in, n); }
|
||||
SecureVector(const MemoryRegion<T>& in)
|
||||
{ MemoryRegion<T>::init(true); set(in); }
|
||||
SecureVector(const MemoryRegion<T>& in1, const MemoryRegion<T>& in2)
|
Loading…
Reference in New Issue
Block a user