upstream headers patch to use Q_SLOT and Q_SIGNAL [release 2.1.0.3-3mamba;Fri Jul 22 2016]
This commit is contained in:
parent
166b599cbd
commit
1439f4ab5c
28
libqca-2.1.0.3-use-Q_SLOT-and-Q_SIGNAL.patch
Normal file
28
libqca-2.1.0.3-use-Q_SLOT-and-Q_SIGNAL.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From: Jan Grulich <jgrulich@redhat.com>
|
||||
Date: Thu, 17 Sep 2015 14:14:24 +0000
|
||||
Subject: Use Q_SLOTS/Q_SIGNALS instead of slots/signals in all headers from include dir
|
||||
X-Git-Url: http://quickgit.kde.org/?p=qca.git&a=commitdiff&h=66b9754170759d9333d5fc1e348642814d0310dd
|
||||
---
|
||||
Use Q_SLOTS/Q_SIGNALS instead of slots/signals in all headers from include dir
|
||||
REVIEW:125289
|
||||
---
|
||||
|
||||
|
||||
--- a/include/QtCrypto/qca_safetimer.h
|
||||
+++ b/include/QtCrypto/qca_safetimer.h
|
||||
@@ -44,12 +44,12 @@
|
||||
void setSingleShot(bool singleShot);
|
||||
int timerId() const;
|
||||
|
||||
-public slots:
|
||||
+public Q_SLOTS:
|
||||
void start(int msec);
|
||||
void start();
|
||||
void stop();
|
||||
|
||||
-signals:
|
||||
+Q_SIGNALS:
|
||||
void timeout();
|
||||
|
||||
protected:
|
||||
|
14
libqca.spec
14
libqca.spec
@ -2,7 +2,7 @@
|
||||
|
||||
Name: libqca
|
||||
Version: 2.1.0.3
|
||||
Release: 2mamba
|
||||
Release: 3mamba
|
||||
Summary: Qt Cryptographic Architecture (QCA)
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -12,6 +12,7 @@ URL: http://delta.affinix.com/qca/
|
||||
Source: http://download.kde.org/stable/qca-qt5/%{version}/src/qca-qt5-%{version}.tar.xz
|
||||
Patch0: qca-2.0.3-gcc-4.7.patch
|
||||
Patch1: libqca-2.1.0.3-qt5-5.5.patch
|
||||
Patch2: libqca-2.1.0.3-use-Q_SLOT-and-Q_SIGNAL.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -64,19 +65,23 @@ This package contains static libraries and header files need for development.
|
||||
%setup -q -n qca-qt5-%{version}
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build \
|
||||
-DQT4_BUILD=ON
|
||||
-DQT4_BUILD=ON \
|
||||
|
||||
|
||||
%make
|
||||
|
||||
cd ..
|
||||
|
||||
%cmake -d build-qt5 \
|
||||
-DQT4_BUILD=OFF \
|
||||
-DQCA_SUFFIX=qt5 \
|
||||
-DBUILD_TESTS=OFF \
|
||||
-DQCA_INSTALL_IN_QT_PREFIX=ON
|
||||
-DQCA_INSTALL_IN_QT_PREFIX=ON \
|
||||
-DCMAKE_CXX_FLAGS="%{optflags} -Wno-narrowing"
|
||||
|
||||
%make
|
||||
|
||||
@ -167,6 +172,9 @@ rm -fr %{buildroot}%{_qt4_datadir}/qca/certs
|
||||
%doc README TODO
|
||||
|
||||
%changelog
|
||||
* Fri Jul 22 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.0.3-3mamba
|
||||
- upstream headers patch to use Q_SLOT and Q_SIGNAL
|
||||
|
||||
* Wed Dec 23 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.0.3-2mamba
|
||||
- patched to fix missing qt5 include in header
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user