update to 2.3.8
added qt6 subpackages [release 2.3.8-1mamba;Sun Jan 14 2024]
This commit is contained in:
parent
b18b70a58c
commit
017df66acb
@ -1,11 +0,0 @@
|
|||||||
--- qca-qt5-2.1.0.3/include/QtCrypto/qca_basic.h.orig 2015-12-23 00:59:20.549274673 +0100
|
|
||||||
+++ qca-qt5-2.1.0.3/include/QtCrypto/qca_basic.h 2015-12-23 00:59:34.135167811 +0100
|
|
||||||
@@ -35,6 +35,8 @@
|
|
||||||
|
|
||||||
#include "qca_core.h"
|
|
||||||
|
|
||||||
+#include <QIODevice>
|
|
||||||
+
|
|
||||||
// Qt5 comes with QStringLiteral for wrapping string literals, which Qt4 does
|
|
||||||
// not have. It is needed if the headers are built with QT_NO_CAST_FROM_ASCII.
|
|
||||||
// Defining it here as QString::fromUtf8 for convenience.
|
|
@ -1,28 +0,0 @@
|
|||||||
From: Jan Grulich <jgrulich@redhat.com>
|
|
||||||
Date: Thu, 17 Sep 2015 14:14:24 +0000
|
|
||||||
Subject: Use Q_SLOTS/Q_SIGNALS instead of slots/signals in all headers from include dir
|
|
||||||
X-Git-Url: http://quickgit.kde.org/?p=qca.git&a=commitdiff&h=66b9754170759d9333d5fc1e348642814d0310dd
|
|
||||||
---
|
|
||||||
Use Q_SLOTS/Q_SIGNALS instead of slots/signals in all headers from include dir
|
|
||||||
REVIEW:125289
|
|
||||||
---
|
|
||||||
|
|
||||||
|
|
||||||
--- a/include/QtCrypto/qca_safetimer.h
|
|
||||||
+++ b/include/QtCrypto/qca_safetimer.h
|
|
||||||
@@ -44,12 +44,12 @@
|
|
||||||
void setSingleShot(bool singleShot);
|
|
||||||
int timerId() const;
|
|
||||||
|
|
||||||
-public slots:
|
|
||||||
+public Q_SLOTS:
|
|
||||||
void start(int msec);
|
|
||||||
void start();
|
|
||||||
void stop();
|
|
||||||
|
|
||||||
-signals:
|
|
||||||
+Q_SIGNALS:
|
|
||||||
void timeout();
|
|
||||||
|
|
||||||
protected:
|
|
||||||
|
|
62
libqca.spec
62
libqca.spec
@ -1,7 +1,7 @@
|
|||||||
%define majorminor %(echo %version | cut -d. -f 1-2)
|
%define majorminor %(echo %version | cut -d. -f 1-2)
|
||||||
|
|
||||||
Name: libqca
|
Name: libqca
|
||||||
Version: 2.3.7
|
Version: 2.3.8
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Qt Cryptographic Architecture (QCA)
|
Summary: Qt Cryptographic Architecture (QCA)
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -10,15 +10,10 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://userbase.kde.org/QCA
|
URL: https://userbase.kde.org/QCA
|
||||||
Source: https://download.kde.org/stable/qca/%{version}/qca-%{version}.tar.xz
|
Source: https://download.kde.org/stable/qca/%{version}/qca-%{version}.tar.xz
|
||||||
Patch0: qca-2.0.3-gcc-4.7.patch
|
|
||||||
Patch1: libqca-2.1.0.3-qt5-5.5.patch
|
|
||||||
Patch2: libqca-2.1.0.3-use-Q_SLOT-and-Q_SIGNAL.patch
|
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
%ifnarch arm
|
BuildRequires: libbotan2-devel
|
||||||
BuildRequires: libbotan-devel
|
|
||||||
%endif
|
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libgcrypt-devel
|
BuildRequires: libgcrypt-devel
|
||||||
BuildRequires: libgpg-error-devel
|
BuildRequires: libgpg-error-devel
|
||||||
@ -28,6 +23,8 @@ BuildRequires: libopenssl-devel
|
|||||||
BuildRequires: libsasl2-devel
|
BuildRequires: libsasl2-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: qt5-qtbase-devel
|
BuildRequires: qt5-qtbase-devel
|
||||||
|
BuildRequires: qt6-qt5compat-devel
|
||||||
|
BuildRequires: qt6-qtbase-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
%ifnarch arm
|
%ifnarch arm
|
||||||
BuildRequires: libbotan-devel >= 2.19.0
|
BuildRequires: libbotan-devel >= 2.19.0
|
||||||
@ -54,13 +51,27 @@ Requires: %{name}-qt5 = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
Taking a hint from the similarly-named Java Cryptography Architecture, QCA aims to provide a straightforward and cross-platform crypto API, using Qt datatypes and conventions.
|
Taking a hint from the similarly-named Java Cryptography Architecture, QCA aims to provide a straightforward and cross-platform crypto API, using Qt datatypes and conventions.
|
||||||
This package contains static libraries and header files needed for development.
|
This package contains static libraries and header files needed for development.
|
||||||
|
|
||||||
|
%package qt6
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: Qt Cryptographic Architecture (QCA)
|
||||||
|
|
||||||
|
%description qt6
|
||||||
|
Taking a hint from the similarly-named Java Cryptography Architecture, QCA aims to provide a straightforward and cross-platform crypto API, using Qt datatypes and conventions.
|
||||||
|
QCA separates the API from the implementation, using plugins known as Providers.
|
||||||
|
|
||||||
|
%package qt6-devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{name}-qt6
|
||||||
|
Requires: %{name}-qt6 = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description qt6-devel
|
||||||
|
Taking a hint from the similarly-named Java Cryptography Architecture, QCA aims to provide a straightforward and cross-platform crypto API, using Qt datatypes and conventions.
|
||||||
|
This package contains static libraries and header files needed for development.
|
||||||
|
|
||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n qca-%{version}
|
%setup -q -n qca-%{version}
|
||||||
#%patch0 -p1
|
|
||||||
#%patch1 -p1
|
|
||||||
#%patch2 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
@ -70,9 +81,19 @@ This package contains static libraries and header files needed for development.
|
|||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
|
cd ..
|
||||||
|
%cmake -d build-qt6 \
|
||||||
|
-DBUILD_TESTS=OFF \
|
||||||
|
-DQT6=ON \
|
||||||
|
-DQCA_INSTALL_IN_QT_PREFIX=ON \
|
||||||
|
-DCMAKE_CXX_FLAGS="%{optflags} -Wno-narrowing"
|
||||||
|
|
||||||
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall -C build
|
%makeinstall -C build
|
||||||
|
%makeinstall -C build-qt6
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -103,7 +124,28 @@ This package contains static libraries and header files needed for development.
|
|||||||
%{_libdir}/pkgconfig/qca2-qt5.pc
|
%{_libdir}/pkgconfig/qca2-qt5.pc
|
||||||
#%doc README TODO
|
#%doc README TODO
|
||||||
|
|
||||||
|
%files qt6
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_qt6_archdatadir}/bin/mozcerts-qt6
|
||||||
|
%{_qt6_archdatadir}/bin/qcatool-qt6
|
||||||
|
%{_libdir}/libqca-qt6.so.*
|
||||||
|
%{_qt6_plugindir}/crypto/libqca-*.so
|
||||||
|
%{_datadir}/qt6/man/man1/qcatool-qt6.1*
|
||||||
|
%doc COPYING
|
||||||
|
|
||||||
|
%files qt6-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_qt6_headerdir}/Qca-qt6/QtCrypto
|
||||||
|
%{_qt6_headerdir}/Qca-qt6/QtCrypto/*
|
||||||
|
%{_libdir}/libqca-qt6.so
|
||||||
|
%dir %{_libdir}/cmake/Qca-qt6
|
||||||
|
%{_libdir}/cmake/Qca-qt6/Qca-qt6*.cmake
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jan 14 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.8-1mamba
|
||||||
|
- update to 2.3.8
|
||||||
|
- added qt6 subpackages
|
||||||
|
|
||||||
* Tue Nov 07 2023 Automatic Build System <autodist@mambasoft.it> 2.3.7-1mamba
|
* Tue Nov 07 2023 Automatic Build System <autodist@mambasoft.it> 2.3.7-1mamba
|
||||||
- automatic update by autodist
|
- automatic update by autodist
|
||||||
|
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -Nru qca-2.0.3.orig/src/botantools/botan/botan/secmem.h qca-2.0.3/src/botantools/botan/botan/secmem.h
|
|
||||||
--- qca-2.0.3.orig/src/botantools/botan/botan/secmem.h 2007-04-19 23:26:13.000000000 +0200
|
|
||||||
+++ qca-2.0.3/src/botantools/botan/botan/secmem.h 2013-01-24 11:44:22.356084926 +0100
|
|
||||||
@@ -214,7 +214,7 @@
|
|
||||||
|
|
||||||
SecureVector(u32bit n = 0) { MemoryRegion<T>::init(true, n); }
|
|
||||||
SecureVector(const T in[], u32bit n)
|
|
||||||
- { MemoryRegion<T>::init(true); set(in, n); }
|
|
||||||
+ { MemoryRegion<T>::init(true); this->set(in, n); }
|
|
||||||
SecureVector(const MemoryRegion<T>& in)
|
|
||||||
{ MemoryRegion<T>::init(true); set(in); }
|
|
||||||
SecureVector(const MemoryRegion<T>& in1, const MemoryRegion<T>& in2)
|
|
Loading…
Reference in New Issue
Block a user