rebuilt with python 2.7 [release 0.4.11-3mamba;Fri May 17 2013]
This commit is contained in:
parent
c3ef5507e0
commit
c8fff77fcb
@ -1,2 +1,4 @@
|
||||
# libproxy
|
||||
|
||||
libproxy is a library that provides automatic proxy configuration management.
|
||||
|
||||
|
13
libproxy-0.4.11-kde-4.10.patch
Normal file
13
libproxy-0.4.11-kde-4.10.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -Nru libproxy-0.4.11.orig/libproxy/modules/config_kde4.cpp libproxy-0.4.11/libproxy/modules/config_kde4.cpp
|
||||
--- libproxy-0.4.11.orig/libproxy/modules/config_kde4.cpp 2012-07-05 18:50:06.000000000 +0200
|
||||
+++ libproxy-0.4.11/libproxy/modules/config_kde4.cpp 2013-04-22 13:29:01.905639524 +0200
|
||||
@@ -64,7 +64,8 @@
|
||||
};
|
||||
// The result of toLatin1() is undefined for non-Latin1 strings.
|
||||
// However, KDE saves this entry using IDN and percent-encoding, so no problem...
|
||||
- response.push_back(string(prxy.toLatin1().data()));
|
||||
+ // Workaround: since recent kde versions a space is used instead of ':'
|
||||
+ response.push_back(string(prxy.replace(' ',':').toLatin1().data()));
|
||||
break;
|
||||
case 2: // Use a manual PAC
|
||||
// The result of toLatin1() is undefined for non-Latin1 strings.
|
80
libproxy-0.4.7-gcc-4.7.patch
Normal file
80
libproxy-0.4.7-gcc-4.7.patch
Normal file
@ -0,0 +1,80 @@
|
||||
From 8dbcf9b358f50f7a7c1f1368d167999c31b1e86b Mon Sep 17 00:00:00 2001
|
||||
From: "dominique.leuenberger@gmail.com"
|
||||
<dominique.leuenberger@gmail.com@c587cffe-e639-0410-9787-d7902ae8ed56>
|
||||
Date: Fri, 9 Mar 2012 17:47:15 +0000
|
||||
Subject: [PATCH] Fix build with gcc 4.7. Fixes issue 173
|
||||
|
||||
git-svn-id: http://libproxy.googlecode.com/svn/trunk@833 c587cffe-e639-0410-9787-d7902ae8ed56
|
||||
---
|
||||
libproxy/modules/config_sysconfig.cpp | 3 +++
|
||||
libproxy/modules/pacrunner_mozjs.cpp | 1 +
|
||||
libproxy/modules/pacrunner_natus.cpp | 1 +
|
||||
libproxy/modules/pacrunner_webkit.cpp | 1 +
|
||||
libproxy/url.cpp | 1 +
|
||||
5 files changed, 7 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/libproxy/modules/config_sysconfig.cpp b/libproxy/modules/config_sysconfig.cpp
|
||||
index 616585a..6e97ae8 100644
|
||||
--- a/libproxy/modules/config_sysconfig.cpp
|
||||
+++ b/libproxy/modules/config_sysconfig.cpp
|
||||
@@ -21,6 +21,9 @@
|
||||
#include <cstdlib>
|
||||
#include <map>
|
||||
#include <fstream>
|
||||
+#include <unistd.h>
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
|
||||
#include "../extension_config.hpp"
|
||||
using namespace libproxy;
|
||||
diff --git a/libproxy/modules/pacrunner_mozjs.cpp b/libproxy/modules/pacrunner_mozjs.cpp
|
||||
index 3283e91..abb4b9d 100644
|
||||
--- a/libproxy/modules/pacrunner_mozjs.cpp
|
||||
+++ b/libproxy/modules/pacrunner_mozjs.cpp
|
||||
@@ -18,6 +18,7 @@
|
||||
******************************************************************************/
|
||||
|
||||
#include <cstring> // ?
|
||||
+#include <unistd.h> // gethostname
|
||||
|
||||
#include "../extension_pacrunner.hpp"
|
||||
using namespace libproxy;
|
||||
diff --git a/libproxy/modules/pacrunner_natus.cpp b/libproxy/modules/pacrunner_natus.cpp
|
||||
index f7bd4fc..ce79943 100644
|
||||
--- a/libproxy/modules/pacrunner_natus.cpp
|
||||
+++ b/libproxy/modules/pacrunner_natus.cpp
|
||||
@@ -18,6 +18,7 @@
|
||||
******************************************************************************/
|
||||
|
||||
#include "../extension_pacrunner.hpp"
|
||||
+#include <unistd.h> // gethostname
|
||||
using namespace libproxy;
|
||||
|
||||
#define I_ACKNOWLEDGE_THAT_NATUS_IS_NOT_STABLE
|
||||
diff --git a/libproxy/modules/pacrunner_webkit.cpp b/libproxy/modules/pacrunner_webkit.cpp
|
||||
index b9abf34..c51b869 100644
|
||||
--- a/libproxy/modules/pacrunner_webkit.cpp
|
||||
+++ b/libproxy/modules/pacrunner_webkit.cpp
|
||||
@@ -18,6 +18,7 @@
|
||||
******************************************************************************/
|
||||
|
||||
#include "../extension_pacrunner.hpp"
|
||||
+#include <unistd.h> // gethostname
|
||||
using namespace libproxy;
|
||||
|
||||
#ifdef __APPLE__
|
||||
diff --git a/libproxy/url.cpp b/libproxy/url.cpp
|
||||
index df75022..cd781df 100644
|
||||
--- a/libproxy/url.cpp
|
||||
+++ b/libproxy/url.cpp
|
||||
@@ -33,6 +33,7 @@
|
||||
#include <cstdlib> // For atoi()
|
||||
#include <sys/stat.h> // For stat()
|
||||
#include <algorithm> // For transform()
|
||||
+#include <unistd.h> // For read() close()
|
||||
|
||||
#ifdef WIN32
|
||||
#include <io.h>
|
||||
--
|
||||
1.7.8.6
|
||||
|
46
libproxy-0.4.7-xulrunner.patch
Normal file
46
libproxy-0.4.7-xulrunner.patch
Normal file
@ -0,0 +1,46 @@
|
||||
Index: libproxy/libproxy/cmake/modules/pacrunner_mozjs.cmk
|
||||
===================================================================
|
||||
--- libproxy/libproxy/cmake/modules/pacrunner_mozjs.cmk (révision 814)
|
||||
+++ libproxy/libproxy/cmake/modules/pacrunner_mozjs.cmk (révision 815)
|
||||
@@ -7,19 +7,15 @@
|
||||
include_directories("${MOZJS_INCLUDE_DIR}")
|
||||
endif()
|
||||
elseif(NOT APPLE)
|
||||
- set(MOZJS_SEARCH_ORDER "mozilla-js;xulrunner-js;firefox-js;seamonkey-js" CACHE STRING "MozJS search order")
|
||||
option(WITH_MOZJS "Search for MOZJS package" ON)
|
||||
if (WITH_MOZJS)
|
||||
- foreach(MOZJSLIB ${MOZJS_SEARCH_ORDER})
|
||||
- pkg_search_module(MOZJS ${MOZJSLIB}>=2.0b12)
|
||||
- if(MOZJS_FOUND)
|
||||
- include_directories(${MOZJS_INCLUDE_DIRS})
|
||||
- link_directories(${MOZJS_LIBRARY_DIRS})
|
||||
- break()
|
||||
- else()
|
||||
- set(MOZJS_FOUND 0)
|
||||
- endif()
|
||||
- endforeach()
|
||||
+ pkg_search_module(MOZJS mozjs185>=1.8.5)
|
||||
+ if(MOZJS_FOUND)
|
||||
+ include_directories(${MOZJS_INCLUDE_DIRS})
|
||||
+ link_directories(${MOZJS_LIBRARY_DIRS})
|
||||
+ else()
|
||||
+ set(MOZJS_FOUND 0)
|
||||
+ endif()
|
||||
else()
|
||||
set(MOZJS_FOUND 0)
|
||||
endif()
|
||||
Index: libproxy/NEWS
|
||||
===================================================================
|
||||
--- libproxy/NEWS (révision 814)
|
||||
+++ libproxy/NEWS (révision 815)
|
||||
@@ -1,3 +1,10 @@
|
||||
+New in version 0.4.8 (not yet released)
|
||||
+==============================
|
||||
+* Only support standalone mozjs185 as mozilla js engine.
|
||||
+ xulrunner being part of the now lightning fast moving firefox
|
||||
+ is impossible to be tracked as a dependency and it is not
|
||||
+ supported by Mozilla to be used in this scenario.
|
||||
+
|
||||
New in version 0.4.7
|
||||
==============================
|
||||
* Support/require xulrunner 2.0+
|
226
libproxy.spec
Normal file
226
libproxy.spec
Normal file
@ -0,0 +1,226 @@
|
||||
Name: libproxy
|
||||
Version: 0.4.11
|
||||
Release: 3mamba
|
||||
Summary: A library that provides automatic proxy configuration management.
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://libproxy.googlecode.com
|
||||
Source: http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
|
||||
Patch0: libproxy-0.4.7-gcc-4.7.patch
|
||||
Patch1: libproxy-0.4.7-xulrunner.patch
|
||||
Patch2: libproxy-0.4.11-kde-4.10.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: kdelibs-devel
|
||||
%endif
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libsoup-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libwebkit-gtk-devel
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: pkg-config
|
||||
## AUTOBUILDREQ-END
|
||||
#%if "%{stage1}" != "1"
|
||||
#BuildRequires: xulrunner-devel
|
||||
#%endif
|
||||
BuildRequires: glproto-devel
|
||||
BuildRequires: libnm-devel
|
||||
Provides: %{name}-mozjs
|
||||
Obsoletes: %{name}-mozjs
|
||||
Provides: %{name}-webkit
|
||||
Obsoletes: %{name}-webkit
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
libproxy is a library that provides automatic proxy configuration management.
|
||||
|
||||
%package tools
|
||||
Summary: A simple application using libproxy
|
||||
Group: System/Tools
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description tools
|
||||
A simple application that will use libproxy to give the results you can expect from other applications.
|
||||
It can be used to debug what would happen in various cases.
|
||||
|
||||
%package -n python-libproxy
|
||||
Summary: Pythin binding for %{name}
|
||||
Group: System/Libraries/Python
|
||||
|
||||
%description -n python-libproxy
|
||||
%{summary}.
|
||||
|
||||
%package -n perl-Net-Libproxy
|
||||
Summary: Perl binding for %{name}
|
||||
Group: System/Libraries/Perl
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n perl-Net-Libproxy
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
libproxy is a library that provides automatic proxy configuration management.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package kde
|
||||
Summary: KDE plugin for %{name}
|
||||
Group: System/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description kde
|
||||
libproxy is a library that provides automatic proxy configuration management.
|
||||
|
||||
This package contains the plugin for the KDE desktop enviroment.
|
||||
|
||||
%package gnome
|
||||
Summary: Gnome plugin for %{name}
|
||||
Group: System/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description gnome
|
||||
libproxy is a library that provides automatic proxy configuration management.
|
||||
|
||||
This package contains the plugin for the KDE desktop enviroment.
|
||||
|
||||
%package mozjs
|
||||
Summary: Mozilla plugin for %{name}
|
||||
Group: System/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description mozjs
|
||||
libproxy is a library that provides automatic proxy configuration management.
|
||||
|
||||
This package contains the mozilla plugin.
|
||||
|
||||
%package webkit
|
||||
Summary: WebKit plugin for %{name}
|
||||
Group: System/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description webkit
|
||||
libproxy is a library that provides automatic proxy configuration management.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
#export NetworkManager_CFLAGS="-I/usr/include/NetworkManager `pkg-config --cflags --libs dbus-1`"
|
||||
%cmake \
|
||||
-DPERL_VENDORINSTALL=yes \
|
||||
-DLIBEXEC_INSTALL_DIR=%{_libexecdir}
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libproxy.so.*
|
||||
#%{_libdir}/libmodman.so.*
|
||||
%{_libdir}/libproxy/%{version}/modules/network_networkmanager.so
|
||||
%{_libexecdir}/pxgsettings
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files tools
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/proxy
|
||||
|
||||
%files -n python-libproxy
|
||||
%defattr(-,root,root)
|
||||
%{python_sitearch}/libproxy.py
|
||||
|
||||
%files -n perl-Net-Libproxy
|
||||
%defattr(-,root,root)
|
||||
%{perl_vendorarch}/Net/Libproxy.pm
|
||||
%{perl_vendorarch}/auto/Net/Libproxy/Libproxy.so
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/*.h
|
||||
%{_libdir}/libproxy.so
|
||||
#%{_libdir}/libmodman.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%{_datadir}/cmake/Modules/Findlibproxy.cmake
|
||||
#%doc ChangeLog README
|
||||
|
||||
%files gnome
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libproxy/%{version}/modules/config_gnome3.so
|
||||
|
||||
%if "%{stage1}" != "1"
|
||||
#%files mozjs
|
||||
#%defattr(-,root,root)
|
||||
##%{_libdir}/libproxy/%{version}/modules/pacrunner_mozjs.so
|
||||
#
|
||||
#%files webkit
|
||||
#%defattr(-,root,root)
|
||||
##%{_libdir}/libproxy/%{version}/modules/pacrunner_webkit.so
|
||||
|
||||
%files kde
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libproxy/%{version}/modules/config_kde4.so
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.11-3mamba
|
||||
- rebuilt with python 2.7
|
||||
|
||||
* Mon Apr 22 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.11-2mamba
|
||||
- added a patch to fix kde4 module when using recent kde versions
|
||||
|
||||
* Mon Apr 15 2013 Automatic Build System <autodist@mambasoft.it> 0.4.11-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Nov 07 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.10-1mamba
|
||||
- update to 0.4.10
|
||||
|
||||
* Sun Sep 02 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.7-1mamba
|
||||
- update to 0.4.7
|
||||
|
||||
* Mon Oct 31 2011 Davide Madrisan <davide.madrisan@gmail.com> 0.4.6-3mamba
|
||||
- do not own %{_includedir}
|
||||
- run ldconfig
|
||||
- new subpackages python-libproxy and perl-Net-Libproxy
|
||||
- buid perl module using the PERL_VENDORINSTALL=yes flag
|
||||
- move %{_bindir}/proxy to libproxy-tools
|
||||
|
||||
* Sun Sep 04 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.6-2mamba
|
||||
- added -mozjs and -webkit subpackages
|
||||
|
||||
* Wed Dec 15 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.6-1mamba
|
||||
- update to 0.4.6
|
||||
|
||||
* Sun Mar 22 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.3-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user