automatic version update by autodist [release 0.5.4-1mamba;Tue Feb 13 2024]
This commit is contained in:
parent
0801c4c700
commit
307e3dcf0d
@ -1,13 +0,0 @@
|
|||||||
diff -Nru libproxy-0.4.11.orig/libproxy/modules/config_kde4.cpp libproxy-0.4.11/libproxy/modules/config_kde4.cpp
|
|
||||||
--- libproxy-0.4.11.orig/libproxy/modules/config_kde4.cpp 2012-07-05 18:50:06.000000000 +0200
|
|
||||||
+++ libproxy-0.4.11/libproxy/modules/config_kde4.cpp 2013-04-22 13:29:01.905639524 +0200
|
|
||||||
@@ -64,7 +64,8 @@
|
|
||||||
};
|
|
||||||
// The result of toLatin1() is undefined for non-Latin1 strings.
|
|
||||||
// However, KDE saves this entry using IDN and percent-encoding, so no problem...
|
|
||||||
- response.push_back(string(prxy.toLatin1().data()));
|
|
||||||
+ // Workaround: since recent kde versions a space is used instead of ':'
|
|
||||||
+ response.push_back(string(prxy.replace(' ',':').toLatin1().data()));
|
|
||||||
break;
|
|
||||||
case 2: // Use a manual PAC
|
|
||||||
// The result of toLatin1() is undefined for non-Latin1 strings.
|
|
@ -1,80 +0,0 @@
|
|||||||
From 8dbcf9b358f50f7a7c1f1368d167999c31b1e86b Mon Sep 17 00:00:00 2001
|
|
||||||
From: "dominique.leuenberger@gmail.com"
|
|
||||||
<dominique.leuenberger@gmail.com@c587cffe-e639-0410-9787-d7902ae8ed56>
|
|
||||||
Date: Fri, 9 Mar 2012 17:47:15 +0000
|
|
||||||
Subject: [PATCH] Fix build with gcc 4.7. Fixes issue 173
|
|
||||||
|
|
||||||
git-svn-id: http://libproxy.googlecode.com/svn/trunk@833 c587cffe-e639-0410-9787-d7902ae8ed56
|
|
||||||
---
|
|
||||||
libproxy/modules/config_sysconfig.cpp | 3 +++
|
|
||||||
libproxy/modules/pacrunner_mozjs.cpp | 1 +
|
|
||||||
libproxy/modules/pacrunner_natus.cpp | 1 +
|
|
||||||
libproxy/modules/pacrunner_webkit.cpp | 1 +
|
|
||||||
libproxy/url.cpp | 1 +
|
|
||||||
5 files changed, 7 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/libproxy/modules/config_sysconfig.cpp b/libproxy/modules/config_sysconfig.cpp
|
|
||||||
index 616585a..6e97ae8 100644
|
|
||||||
--- a/libproxy/modules/config_sysconfig.cpp
|
|
||||||
+++ b/libproxy/modules/config_sysconfig.cpp
|
|
||||||
@@ -21,6 +21,9 @@
|
|
||||||
#include <cstdlib>
|
|
||||||
#include <map>
|
|
||||||
#include <fstream>
|
|
||||||
+#include <unistd.h>
|
|
||||||
+#include <sys/types.h>
|
|
||||||
+
|
|
||||||
|
|
||||||
#include "../extension_config.hpp"
|
|
||||||
using namespace libproxy;
|
|
||||||
diff --git a/libproxy/modules/pacrunner_mozjs.cpp b/libproxy/modules/pacrunner_mozjs.cpp
|
|
||||||
index 3283e91..abb4b9d 100644
|
|
||||||
--- a/libproxy/modules/pacrunner_mozjs.cpp
|
|
||||||
+++ b/libproxy/modules/pacrunner_mozjs.cpp
|
|
||||||
@@ -18,6 +18,7 @@
|
|
||||||
******************************************************************************/
|
|
||||||
|
|
||||||
#include <cstring> // ?
|
|
||||||
+#include <unistd.h> // gethostname
|
|
||||||
|
|
||||||
#include "../extension_pacrunner.hpp"
|
|
||||||
using namespace libproxy;
|
|
||||||
diff --git a/libproxy/modules/pacrunner_natus.cpp b/libproxy/modules/pacrunner_natus.cpp
|
|
||||||
index f7bd4fc..ce79943 100644
|
|
||||||
--- a/libproxy/modules/pacrunner_natus.cpp
|
|
||||||
+++ b/libproxy/modules/pacrunner_natus.cpp
|
|
||||||
@@ -18,6 +18,7 @@
|
|
||||||
******************************************************************************/
|
|
||||||
|
|
||||||
#include "../extension_pacrunner.hpp"
|
|
||||||
+#include <unistd.h> // gethostname
|
|
||||||
using namespace libproxy;
|
|
||||||
|
|
||||||
#define I_ACKNOWLEDGE_THAT_NATUS_IS_NOT_STABLE
|
|
||||||
diff --git a/libproxy/modules/pacrunner_webkit.cpp b/libproxy/modules/pacrunner_webkit.cpp
|
|
||||||
index b9abf34..c51b869 100644
|
|
||||||
--- a/libproxy/modules/pacrunner_webkit.cpp
|
|
||||||
+++ b/libproxy/modules/pacrunner_webkit.cpp
|
|
||||||
@@ -18,6 +18,7 @@
|
|
||||||
******************************************************************************/
|
|
||||||
|
|
||||||
#include "../extension_pacrunner.hpp"
|
|
||||||
+#include <unistd.h> // gethostname
|
|
||||||
using namespace libproxy;
|
|
||||||
|
|
||||||
#ifdef __APPLE__
|
|
||||||
diff --git a/libproxy/url.cpp b/libproxy/url.cpp
|
|
||||||
index df75022..cd781df 100644
|
|
||||||
--- a/libproxy/url.cpp
|
|
||||||
+++ b/libproxy/url.cpp
|
|
||||||
@@ -33,6 +33,7 @@
|
|
||||||
#include <cstdlib> // For atoi()
|
|
||||||
#include <sys/stat.h> // For stat()
|
|
||||||
#include <algorithm> // For transform()
|
|
||||||
+#include <unistd.h> // For read() close()
|
|
||||||
|
|
||||||
#ifdef WIN32
|
|
||||||
#include <io.h>
|
|
||||||
--
|
|
||||||
1.7.8.6
|
|
||||||
|
|
@ -1,46 +0,0 @@
|
|||||||
Index: libproxy/libproxy/cmake/modules/pacrunner_mozjs.cmk
|
|
||||||
===================================================================
|
|
||||||
--- libproxy/libproxy/cmake/modules/pacrunner_mozjs.cmk (révision 814)
|
|
||||||
+++ libproxy/libproxy/cmake/modules/pacrunner_mozjs.cmk (révision 815)
|
|
||||||
@@ -7,19 +7,15 @@
|
|
||||||
include_directories("${MOZJS_INCLUDE_DIR}")
|
|
||||||
endif()
|
|
||||||
elseif(NOT APPLE)
|
|
||||||
- set(MOZJS_SEARCH_ORDER "mozilla-js;xulrunner-js;firefox-js;seamonkey-js" CACHE STRING "MozJS search order")
|
|
||||||
option(WITH_MOZJS "Search for MOZJS package" ON)
|
|
||||||
if (WITH_MOZJS)
|
|
||||||
- foreach(MOZJSLIB ${MOZJS_SEARCH_ORDER})
|
|
||||||
- pkg_search_module(MOZJS ${MOZJSLIB}>=2.0b12)
|
|
||||||
- if(MOZJS_FOUND)
|
|
||||||
- include_directories(${MOZJS_INCLUDE_DIRS})
|
|
||||||
- link_directories(${MOZJS_LIBRARY_DIRS})
|
|
||||||
- break()
|
|
||||||
- else()
|
|
||||||
- set(MOZJS_FOUND 0)
|
|
||||||
- endif()
|
|
||||||
- endforeach()
|
|
||||||
+ pkg_search_module(MOZJS mozjs185>=1.8.5)
|
|
||||||
+ if(MOZJS_FOUND)
|
|
||||||
+ include_directories(${MOZJS_INCLUDE_DIRS})
|
|
||||||
+ link_directories(${MOZJS_LIBRARY_DIRS})
|
|
||||||
+ else()
|
|
||||||
+ set(MOZJS_FOUND 0)
|
|
||||||
+ endif()
|
|
||||||
else()
|
|
||||||
set(MOZJS_FOUND 0)
|
|
||||||
endif()
|
|
||||||
Index: libproxy/NEWS
|
|
||||||
===================================================================
|
|
||||||
--- libproxy/NEWS (révision 814)
|
|
||||||
+++ libproxy/NEWS (révision 815)
|
|
||||||
@@ -1,3 +1,10 @@
|
|
||||||
+New in version 0.4.8 (not yet released)
|
|
||||||
+==============================
|
|
||||||
+* Only support standalone mozjs185 as mozilla js engine.
|
|
||||||
+ xulrunner being part of the now lightning fast moving firefox
|
|
||||||
+ is impossible to be tracked as a dependency and it is not
|
|
||||||
+ supported by Mozilla to be used in this scenario.
|
|
||||||
+
|
|
||||||
New in version 0.4.7
|
|
||||||
==============================
|
|
||||||
* Support/require xulrunner 2.0+
|
|
150
libproxy.spec
150
libproxy.spec
@ -1,6 +1,6 @@
|
|||||||
Name: libproxy
|
Name: libproxy
|
||||||
Version: 0.4.18
|
Version: 0.5.4
|
||||||
Release: 2mamba
|
Release: 1mamba
|
||||||
Summary: A library that provides automatic proxy configuration management.
|
Summary: A library that provides automatic proxy configuration management.
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,35 +8,41 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://libproxy.github.io/libproxy/
|
URL: https://libproxy.github.io/libproxy/
|
||||||
Source: https://github.com/libproxy/libproxy.git/%{version}/libproxy-%{version}.tar.bz2
|
Source: https://github.com/libproxy/libproxy.git/%{version}/libproxy-%{version}.tar.bz2
|
||||||
Patch0: libproxy-0.4.7-gcc-4.7.patch
|
|
||||||
Patch1: libproxy-0.4.7-xulrunner.patch
|
|
||||||
Patch2: libproxy-0.4.11-kde-4.10.patch
|
|
||||||
Patch3: libproxy-0.4.16-upstream-fix-python-argtypes_must_be_a_sequence.patch
|
Patch3: libproxy-0.4.16-upstream-fix-python-argtypes_must_be_a_sequence.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libdbus-devel
|
BuildRequires: libcurl-devel
|
||||||
BuildRequires: libduktape-devel
|
BuildRequires: libduktape-devel
|
||||||
BuildRequires: libgcc
|
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
BuildRequires: libnm-devel
|
|
||||||
BuildRequires: libperl
|
|
||||||
BuildRequires: libpython311-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
|
||||||
BuildRequires: perl-devel
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libpython3-devel >= 3.11
|
BuildRequires: libpython3-devel >= 3.11
|
||||||
BuildRequires: glproto-devel
|
BuildRequires: glproto-devel
|
||||||
BuildRequires: libnm-devel
|
BuildRequires: libnm-devel
|
||||||
|
Requires: %{name}-tools = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
Provides: %{name}-mozjs
|
Provides: %{name}-mozjs
|
||||||
Obsoletes: %{name}-mozjs < 0.4.18
|
Obsoletes: %{name}-mozjs < 0.4.18
|
||||||
Provides: %{name}-webkit
|
Provides: %{name}-webkit
|
||||||
Obsoletes: %{name}-webkit < 0.4.18
|
Obsoletes: %{name}-webkit < 0.4.18
|
||||||
Obsoletes: python-libproxy-py310 < 0.4.18-2mamba
|
Obsoletes: python-libproxy-py310 < 0.4.18-2mamba
|
||||||
|
Obsoletes: python-libproxy-py3 < 0.5.4
|
||||||
|
Obsoletes: libproxy-gnome < 0.5.4
|
||||||
|
Obsoletes: libproxy-kde < 0.5.4
|
||||||
|
Obsoletes: libproxy-networkmanager < 0.5.4
|
||||||
|
Obsoletes: libproxy-pacrunner < 0.5.4
|
||||||
|
|
||||||
%description
|
%description
|
||||||
libproxy is a library that provides automatic proxy configuration management.
|
libproxy is a library that provides automatic proxy configuration management.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Devel package for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
libproxy is a library that provides automatic proxy configuration management.
|
||||||
|
This package contains static libraries and header files needed for development.
|
||||||
|
|
||||||
%package tools
|
%package tools
|
||||||
Summary: A simple application using libproxy
|
Summary: A simple application using libproxy
|
||||||
Group: System/Tools
|
Group: System/Tools
|
||||||
@ -61,15 +67,6 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
%description -n perl-Net-Libproxy
|
%description -n perl-Net-Libproxy
|
||||||
%{summary}.
|
%{summary}.
|
||||||
|
|
||||||
%package devel
|
|
||||||
Summary: Devel package for %{name}
|
|
||||||
Group: Development/Libraries
|
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
|
|
||||||
%description devel
|
|
||||||
libproxy is a library that provides automatic proxy configuration management.
|
|
||||||
This package contains static libraries and header files needed for development.
|
|
||||||
|
|
||||||
%package networkmanager
|
%package networkmanager
|
||||||
Summary: NetworkManager plugin for %{name}
|
Summary: NetworkManager plugin for %{name}
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -115,15 +112,6 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
libproxy is a library that provides automatic proxy configuration management.
|
libproxy is a library that provides automatic proxy configuration management.
|
||||||
This package contains the Mozilla plugin.
|
This package contains the Mozilla plugin.
|
||||||
|
|
||||||
%package webkit
|
|
||||||
Summary: WebKit plugin for %{name}
|
|
||||||
Group: System/Libraries
|
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
|
|
||||||
%description webkit
|
|
||||||
libproxy is a library that provides automatic proxy configuration management.
|
|
||||||
This package contains the Webkit plugin.
|
|
||||||
|
|
||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
@ -131,40 +119,13 @@ This package contains the Webkit plugin.
|
|||||||
#%patch3 -p1
|
#%patch3 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#export NetworkManager_CFLAGS="-I/usr/include/NetworkManager `pkg-config --cflags --libs dbus-1`"
|
%meson
|
||||||
%cmake -d build \
|
|
||||||
-DPERL_VENDORINSTALL=yes \
|
|
||||||
-DWITH_WEBKIT3=OFF \
|
|
||||||
-DWITH_WEBKIT=OFF \
|
|
||||||
-DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
|
|
||||||
-DPYTHON3_EXECUTABLE=%{__python3}
|
|
||||||
|
|
||||||
%make
|
%meson_build
|
||||||
|
|
||||||
#cd ..
|
|
||||||
#
|
|
||||||
#% ifnarch aarch64
|
|
||||||
#% cmake -d build_py36 \
|
|
||||||
# -DPERL_VENDORINSTALL=yes \
|
|
||||||
# -DWITH_WEBKIT3=OFF \
|
|
||||||
# -DWITH_WEBKIT=OFF \
|
|
||||||
# -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
|
|
||||||
# -DPYTHON3_EXECUTABLE=%{__python36}
|
|
||||||
#
|
|
||||||
#% make
|
|
||||||
#% endif
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
#%ifnarch aarch64
|
%meson_install
|
||||||
#% makeinstall -C build_py36
|
|
||||||
#%endif
|
|
||||||
|
|
||||||
%makeinstall -C build
|
|
||||||
|
|
||||||
%ifarch x86_64 aarch64
|
|
||||||
mv %{buildroot}%{_prefix}/lib/python3* %{buildroot}%{_libdir}
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -175,60 +136,59 @@ mv %{buildroot}%{_prefix}/lib/python3* %{buildroot}%{_libdir}
|
|||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libproxy.so.*
|
%{_libdir}/libproxy.so.*
|
||||||
#%{_libdir}/libmodman.so.*
|
%{_libdir}/libproxy/libpxbackend-1.0.so
|
||||||
%{_libexecdir}/pxgsettings
|
%{_libdir}/girepository-1.0/Libproxy-1.0.typelib
|
||||||
%doc AUTHORS COPYING
|
%doc COPYING
|
||||||
|
|
||||||
%files tools
|
%files tools
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/proxy
|
%{_bindir}/proxy
|
||||||
|
%{_mandir}/man8/proxy.8*
|
||||||
|
|
||||||
%files -n python-libproxy-py3
|
#%files -n python-libproxy-py3
|
||||||
%defattr(-,root,root)
|
#%defattr(-,root,root)
|
||||||
%{python3_sitearch}/libproxy.py
|
#%{python3_sitearch}/libproxy.py
|
||||||
|
|
||||||
%files -n perl-Net-Libproxy
|
#%files -n perl-Net-Libproxy
|
||||||
%defattr(-,root,root)
|
#%defattr(-,root,root)
|
||||||
%{perl_vendorarch}/Net/Libproxy.pm
|
#%{perl_vendorarch}/Net/Libproxy.pm
|
||||||
%{perl_vendorarch}/auto/Net/Libproxy/Libproxy.so
|
#%{perl_vendorarch}/auto/Net/Libproxy/Libproxy.so
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_includedir}/*.h
|
%dir %{_includedir}/libproxy
|
||||||
|
%{_includedir}/libproxy/proxy.h
|
||||||
%{_libdir}/libproxy.so
|
%{_libdir}/libproxy.so
|
||||||
#%{_libdir}/libmodman.so
|
%{_datadir}/gir-1.0/Libproxy-1.0.gir
|
||||||
|
%{_datadir}/vala/vapi/libproxy-1.0.*
|
||||||
%{_libdir}/pkgconfig/*.pc
|
%{_libdir}/pkgconfig/*.pc
|
||||||
%{_datadir}/cmake/Modules/Findlibproxy.cmake
|
%dir %{_docdir}/libproxy-1.0
|
||||||
#%doc ChangeLog README
|
%{_docdir}/libproxy-1.0/*
|
||||||
|
#%doc CHANGELOG.md README.md
|
||||||
|
|
||||||
%files gnome
|
#%files gnome
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_libdir}/libproxy/%{version}/modules/config_gnome3.so
|
|
||||||
|
|
||||||
%if "%{stage1}" != "1"
|
|
||||||
#%files mozjs
|
|
||||||
#%defattr(-,root,root)
|
#%defattr(-,root,root)
|
||||||
##%{_libdir}/libproxy/%{version}/modules/pacrunner_mozjs.so
|
#%{_libdir}/libproxy/%{version}/modules/config_gnome3.so
|
||||||
#
|
|
||||||
#%files webkit
|
#%if "%{stage1}" != "1"
|
||||||
|
#%files kde
|
||||||
#%defattr(-,root,root)
|
#%defattr(-,root,root)
|
||||||
##%{_libdir}/libproxy/%{version}/modules/pacrunner_webkit.so
|
#%{_libdir}/libproxy/%{version}/modules/config_kde.so
|
||||||
|
#%endif
|
||||||
|
|
||||||
%files kde
|
#%files networkmanager
|
||||||
%defattr(-,root,root)
|
#%defattr(-,root,root)
|
||||||
%{_libdir}/libproxy/%{version}/modules/config_kde.so
|
#%{_libdir}/libproxy/%{version}/modules/network_networkmanager.so
|
||||||
%endif
|
|
||||||
|
|
||||||
%files networkmanager
|
#%files pacrunner
|
||||||
%defattr(-,root,root)
|
#%defattr(-,root,root)
|
||||||
%{_libdir}/libproxy/%{version}/modules/network_networkmanager.so
|
#%{_libdir}/libproxy/%{version}/modules/config_pacrunner.so
|
||||||
|
|
||||||
%files pacrunner
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_libdir}/libproxy/%{version}/modules/config_pacrunner.so
|
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 13 2024 Automatic Build System <autodist@openmamba.org> 0.5.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Wed Oct 04 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.18-2mamba
|
* Wed Oct 04 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.18-2mamba
|
||||||
- rebuilt with python3 == 3.11
|
- rebuilt with python3 == 3.11
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user