automatic version update by autodist [release 4.0.0-1mamba;Sun Feb 18 2024]

This commit is contained in:
Automatic Build System 2024-03-05 22:39:49 +01:00
parent d92edc75f6
commit c470e3132d
7 changed files with 20 additions and 325 deletions

View File

@ -1,33 +0,0 @@
Index: projectM.cpp
===================================================================
--- projectM.cpp (revision 1048)
+++ projectM.cpp (revision 1049)
@@ -907,3 +907,13 @@
}
+void projectM::changeTextureSize(int size) {
+ _settings.textureSize = size;
+
+ delete renderer;
+ renderer = new Renderer(_settings.windowWidth, _settings.windowHeight,
+ _settings.meshX, _settings.meshY,
+ _settings.textureSize, beatDetect, _settings.presetURL,
+ _settings.titleFontURL, _settings.menuFontURL);
+}
+
Index: projectM.hpp
===================================================================
--- projectM.hpp (revision 1048)
+++ projectM.hpp (revision 1049)
@@ -153,9 +153,9 @@
virtual ~projectM();
+ void changeTextureSize(int size);
-
const Settings & settings() const {
return _settings;
}

View File

@ -1,37 +0,0 @@
Index: TimeKeeper.hpp
===================================================================
--- TimeKeeper.hpp (revision 1063)
+++ TimeKeeper.hpp (revision 1064)
@@ -37,6 +37,8 @@
double sampledPresetDuration();
+ void ChangePresetDuration(int seconds) { _presetDuration = seconds; }
+
#ifndef WIN32
/* The first ticks value of the application */
struct timeval startTime;
Index: projectM.cpp
===================================================================
--- projectM.cpp (revision 1063)
+++ projectM.cpp (revision 1064)
@@ -917,3 +917,7 @@
_settings.titleFontURL, _settings.menuFontURL);
}
+void projectM::changePresetDuration(int seconds) {
+ timeKeeper->ChangePresetDuration(seconds);
+}
+
Index: projectM.hpp
===================================================================
--- projectM.hpp (revision 1063)
+++ projectM.hpp (revision 1064)
@@ -154,6 +154,7 @@
void changeTextureSize(int size);
+ void changePresetDuration(int seconds);
const Settings & settings() const {

View File

@ -1,26 +0,0 @@
Index: Renderer/TextureManager.cpp
===================================================================
--- Renderer/TextureManager.cpp (revision 1065)
+++ Renderer/TextureManager.cpp (working copy)
@@ -219,7 +219,7 @@
// Allocate a new a stream given the current directory name
if ((m_dir = opendir(dirname.c_str())) == NULL)
{
- std::cout<<"No Textures Loaded from "<<dirname<<std::endl;
+ //std::cout<<"No Textures Loaded from "<<dirname<<std::endl;
return; // no files loaded. m_entries is empty
}
Index: PresetLoader.cpp
===================================================================
--- PresetLoader.cpp (revision 1065)
+++ PresetLoader.cpp (working copy)
@@ -84,6 +84,8 @@
while ( ( dir_entry = readdir ( _dir ) ) != NULL )
{
+ if (dir_entry->d_name == 0)
+ continue;
std::ostringstream out;
// Convert char * to friendly string

View File

@ -1,81 +0,0 @@
Index: MilkdropPresetFactory/Parser.cpp
===================================================================
--- MilkdropPresetFactory/Parser.cpp (revision 1510)
+++ MilkdropPresetFactory/Parser.cpp (working copy)
@@ -1269,28 +1269,13 @@
/* Parses a floating point number */
int Parser::string_to_float(char * string, float * float_ptr)
{
+ std::istringstream stream(string);
+ stream >> *float_ptr;
- char ** error_ptr;
-
- if (*string == 0)
+ if (stream.fail())
return PROJECTM_PARSE_ERROR;
- error_ptr = (char**)wipemalloc(sizeof(char**));
-
- (*float_ptr) = strtod(string, error_ptr);
-
- /* These imply a succesful parse of the string */
- if ((**error_ptr == '\0') || (**error_ptr == '\r'))
- {
- free(error_ptr);
- error_ptr = NULL;
- return PROJECTM_SUCCESS;
- }
-
- (*float_ptr) = 0;
- free(error_ptr);
- error_ptr = NULL;
- return PROJECTM_PARSE_ERROR;
+ return PROJECTM_SUCCESS;
}
/* Parses a floating point number */
@@ -1298,11 +1283,9 @@
{
char string[MAX_TOKEN_SIZE];
- char ** error_ptr;
token_t token;
int sign;
- error_ptr =(char**) wipemalloc(sizeof(char**));
token = parseToken(fs, string);
@@ -1322,28 +1305,13 @@
if (string[0] == 0)
{
- free(error_ptr);
- error_ptr = NULL;
return PROJECTM_PARSE_ERROR;
}
- (*float_ptr) = sign*strtod(string, error_ptr);
+ std::istringstream stream(string);
+ stream >> *float_ptr;
- /* No conversion was performed */
- if ((**error_ptr == '\0') || (**error_ptr == '\r'))
- {
- free(error_ptr);
- error_ptr = NULL;
- return PROJECTM_SUCCESS;
- }
-
- if (PARSE_DEBUG) printf("parse_float: float conversion failed for string \"%s\"\n", string);
-
- (*float_ptr) = 0;
- free(error_ptr);
- error_ptr = NULL;
- return PROJECTM_PARSE_ERROR;
-
+ return PROJECTM_SUCCESS;
}
/* Parses a per frame equation. That is, interprets a stream of data as a per frame equation */

View File

@ -1,21 +0,0 @@
diff -Naur libprojectM-2.0.1-orig/CMakeLists.txt libprojectM-2.0.1/CMakeLists.txt
--- libprojectM-2.0.1-orig/CMakeLists.txt 2010-02-08 09:11:11.000000000 -0500
+++ libprojectM-2.0.1/CMakeLists.txt 2010-02-08 09:20:37.000000000 -0500
@@ -112,7 +112,7 @@
SET_TARGET_PROPERTIES(projectM PROPERTIES VERSION 2.0.1 SOVERSION 2.0.1)
-ADD_DEFINITIONS(-DUSE_THREADS)
+#ADD_DEFINITIONS(-DUSE_THREADS)
if (APPLE)
ADD_DEFINITIONS(-DMACOS -DSTBI_NO_DDS -DUSE_THREADS)
@@ -123,7 +123,7 @@
ADD_DEFINITIONS(-DWIN32 -DSTBI_NO_DDS -DUSE_THREADS)
else(WIN32)
set (RESOURCE_PREFIX "share/projectM")
-ADD_DEFINITIONS(-DLINUX -DSTBI_NO_DDS -DUSE_THREADS)
+ADD_DEFINITIONS(-DLINUX -DSTBI_NO_DDS)
endif(WIN32)
endif(APPLE)

View File

@ -1,12 +0,0 @@
diff -Naur libprojectM-2.0.1-orig/CMakeLists.txt libprojectM-2.0.1/CMakeLists.txt
--- libprojectM-2.0.1-orig/CMakeLists.txt 2010-01-16 17:23:11.000000000 -0500
+++ libprojectM-2.0.1/CMakeLists.txt 2010-01-16 17:23:40.000000000 -0500
@@ -110,7 +110,7 @@
ADD_LIBRARY(projectM SHARED ${projectM_SOURCES})
endif(BUILD_PROJECTM_STATIC)
-SET_TARGET_PROPERTIES(projectM PROPERTIES VERSION 2.00 SOVERSION 2)
+SET_TARGET_PROPERTIES(projectM PROPERTIES VERSION 2.0.1 SOVERSION 2.0.1)
ADD_DEFINITIONS(-DUSE_THREADS)

View File

@ -1,36 +1,22 @@
Name: libprojectM
Version: 3.1.12
Version: 4.0.0
Release: 1mamba
Summary: An advanced MilkDrop-compatible music visualization library
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://projectm.sourceforge.net/
URL: https://github.com/projectM-visualizer/projectm
Source: https://github.com/projectM-visualizer/projectm.git/v%{version}/projectm-%{version}.tar.bz2
#Source: http://downloads.sourceforge.net/project/projectm/%{version}/projectM-complete-%{version}-Source.tar.gz
Patch0: libprojectM-2.0.1-soname.patch
Patch1: libprojectM-2.0.1-USE_THREADS.patch
# patches for clementine
Patch2: 01-change-texture-size.patch
Patch3: 04-change-preset-duration.patch
Patch4: 05-fix-windows-crashes.patch
Patch5: 06-fix-numeric-locale.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: ldconfig
BuildRequires: libGL-devel
BuildRequires: libSDL2-devel
BuildRequires: libgcc
BuildRequires: libjack-devel
BuildRequires: libpulseaudio-devel
BuildRequires: libqt5-devel
BuildRequires: libglvnd-devel
BuildRequires: libgomp-devel
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
Requires: %{name}-common = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
projectM is an OpenGL based advanced music visualization program for Linux, Mac OSX, and Windows.
@ -46,79 +32,19 @@ projectM is an OpenGL based advanced music visualization program for Linux, Mac
It is backward compatible with all the features of Milkdrop 1.x, but has many new toys and enhancements.
This package contains static libraries and header files needed for development.
%package common
Group: System/Libraries
Summary: Common files provided with %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description common
projectM is an OpenGL based advanced music visualization program for Linux, Mac OSX, and Windows.
It is backward compatible with all the features of Milkdrop 1.x, but has many new toys and enhancements.
This package contains the common files provided with %{name}.
%package qt
Group: System/Libraries
Summary: An advanced MilkDrop-compatible music visualization library for Qt
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description qt
projectM is an OpenGL based advanced music visualization program for Linux, Mac OSX, and Windows.
It is backward compatible with all the features of Milkdrop 1.x, but has many new toys and enhancements.
This package contains the Qt library.
%package qt-devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}-qt
Requires: %{name}-qt = %{?epoch:%epoch:}%{version}-%{release}
%description qt-devel
projectM is an OpenGL based advanced music visualization program for Linux, Mac OSX, and Windows.
It is backward compatible with all the features of Milkdrop 1.x, but has many new toys and enhancements.
This package contains static libraries and header files needed for development.
%package -n projectM-pulseaudio
Group: Applications/Multimedia
Summary: Pulseaudio tool for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n projectM-pulseaudio
projectM is an OpenGL based advanced music visualization program for Linux, Mac OSX, and Windows.
It is backward compatible with all the features of Milkdrop 1.x, but has many new toys and enhancements.
This package contains the Pulseaudio tool for %{name}.
%package -n projectM-jack
Group: Applications/Multimedia
Summary: Jack tool for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n projectM-jack
projectM is an OpenGL based advanced music visualization program for Linux, Mac OSX, and Windows.
It is backward compatible with all the features of Milkdrop 1.x, but has many new toys and enhancements.
This package contains the Pulseaudio tool for %{name}.
%debug_package
%prep
%setup -q -n projectm-%{version}
#-D -T
#:<< _EOF
./autogen.sh
%build
#:<< _EOF
%configure \
--enable-qt \
--enable-pulseaudio \
--enable-jack \
%ifarch arm aarch64
--enable-gles
%endif
%cmake
%make
%cmake_build
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%cmake_install
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@ -126,47 +52,26 @@ This package contains the Pulseaudio tool for %{name}.
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%post qt -p /sbin/ldconfig
%postun qt -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libprojectM.so.*
%files common
%defattr(-,root,root)
%{_bindir}/projectMSDL
%dir %{_datadir}/projectM
%{_datadir}/projectM/config.inp
%dir %{_datadir}/projectM/fonts
%{_datadir}/projectM/fonts/*.ttf
%{_datadir}/projectM/presets
%{_datadir}/icons/hicolor/scalable/apps/projectM.svg
%{_libdir}/libprojectM-%{MAJver}.so.*
%{_libdir}/libprojectM-%{MAJver}-playlist.so.*
%files devel
%defattr(-,root,root)
%{_bindir}/projectM-unittest
%dir %{_includedir}/libprojectM
%{_includedir}/libprojectM/*.hpp
%{_includedir}/libprojectM/*.h
%{_libdir}/libprojectM.a
%{_libdir}/libprojectM.la
%{_libdir}/libprojectM.so
%{_libdir}/pkgconfig/libprojectM.pc
%files -n projectM-pulseaudio
%defattr(-,root,root)
%{_bindir}/projectM-pulseaudio
%{_datadir}/applications/projectM-pulseaudio.desktop
%{_mandir}/man1/projectM-pulseaudio.1*
%files -n projectM-jack
%defattr(-,root,root)
%{_bindir}/projectM-jack
%{_datadir}/applications/projectM-jack.desktop
%{_mandir}/man1/projectM-jack.1*
%dir %{_includedir}/projectM-%{MAJver}
%{_includedir}/projectM-%{MAJver}/*
%{_libdir}/libprojectM-%{MAJver}.so
%dir %{_libdir}/cmake/projectM%{MAJver}
%{_libdir}/cmake/projectM%{MAJver}/*
%dir %{_libdir}/cmake/projectM%{MAJver}Playlist
%{_libdir}/cmake/projectM%{MAJver}Playlist/*
%{_libdir}/libprojectM-%{MAJver}-playlist.so
%changelog
* Sun Feb 18 2024 Automatic Build System <autodist@openmamba.org> 4.0.0-1mamba
- automatic version update by autodist
* Sun Feb 21 2021 Automatic Build System <autodist@mambasoft.it> 3.1.12-1mamba
- automatic version update by autodist