update to 1.2.51 [release 1.2.51-1mamba;Sat Mar 15 2014]
This commit is contained in:
parent
7e7672d477
commit
135cf5e806
@ -1,2 +1,4 @@
|
||||
# libpng12
|
||||
|
||||
This package contains the library needed to run programs dynamically linked with libpng.
|
||||
|
||||
|
1666
libpng-1.2.41-apng.patch
Normal file
1666
libpng-1.2.41-apng.patch
Normal file
File diff suppressed because it is too large
Load Diff
49
libpng-1.2.8-link_to_proper_libs.patch
Normal file
49
libpng-1.2.8-link_to_proper_libs.patch
Normal file
@ -0,0 +1,49 @@
|
||||
diff -ur libpng-1.2.8/scripts/libpng.pc.in libpng-1.2.8-fix/scripts/libpng.pc.in
|
||||
--- libpng-1.2.8/scripts/libpng.pc.in 2004-12-03 00:14:31.000000000 +0000
|
||||
+++ libpng-1.2.8-fix/scripts/libpng.pc.in 2005-02-16 07:57:32.000000000 +0000
|
||||
@@ -7,5 +7,5 @@
|
||||
Name: libpng12
|
||||
Description: Loads and saves PNG files
|
||||
Version: 1.2.8
|
||||
-Libs: -L${libdir} -lpng12 -lz -lm
|
||||
+Libs: -L${libdir} -lpng12
|
||||
Cflags: -I${includedir}/libpng12
|
||||
diff -ur libpng-1.2.8/scripts/makefile.linux libpng-1.2.8-fix/scripts/makefile.linux
|
||||
--- libpng-1.2.8/scripts/makefile.linux 2005-02-16 07:56:58.000000000 +0000
|
||||
+++ libpng-1.2.8-fix/scripts/makefile.linux 2005-02-16 08:00:21.000000000 +0000
|
||||
@@ -32,8 +32,9 @@
|
||||
CFLAGS=-I$(ZLIBINC) -Wall -O3 -funroll-loops \
|
||||
$(ALIGN) # $(WARNMORE) -g -DPNG_DEBUG=5
|
||||
|
||||
-LDFLAGS=-L. -Wl,-rpath,. -L$(ZLIBLIB) -Wl,-rpath,$(ZLIBLIB) -lpng12 -lz -lm
|
||||
-LDFLAGS_A=-L$(ZLIBLIB) -Wl,-rpath,$(ZLIBLIB) libpng.a -lz -lm
|
||||
+LIBS=-lz -lm
|
||||
+LDFLAGS=-L. -Wl,-rpath,. -L$(ZLIBLIB) -Wl,-rpath,$(ZLIBLIB) -lpng12
|
||||
+LDFLAGS_A=-L$(ZLIBLIB) -Wl,-rpath,$(ZLIBLIB) libpng.a $(LIBS)
|
||||
|
||||
RANLIB=ranlib
|
||||
#RANLIB=echo
|
||||
@@ -81,7 +82,7 @@
|
||||
echo I_opts=\"-I$(INCPATH)/$(LIBNAME)\"; \
|
||||
echo L_opts=\"-L$(LIBPATH)\"; \
|
||||
echo R_opts=\"-Wl,-rpath,$(LIBPATH)\"; \
|
||||
- echo libs=\"-lpng12 -lz -lm\"; \
|
||||
+ echo libs=\"-lpng12\"; \
|
||||
cat scripts/libpng-config-body.in ) > libpng-config
|
||||
chmod +x libpng-config
|
||||
|
||||
@@ -94,12 +95,12 @@
|
||||
$(LIBNAME).so.$(PNGVER): $(OBJSDLL)
|
||||
$(CC) -shared -Wl,-soname,$(LIBNAME).so.$(PNGMAJ) \
|
||||
-o $(LIBNAME).so.$(PNGVER) \
|
||||
- $(OBJSDLL)
|
||||
+ $(OBJSDLL) $(LIBS)
|
||||
|
||||
libpng.so.3.$(PNGMIN): $(OBJSDLL)
|
||||
$(CC) -shared -Wl,-soname,libpng.so.3 \
|
||||
-o libpng.so.3.$(PNGMIN) \
|
||||
- $(OBJSDLL)
|
||||
+ $(OBJSDLL) $(LIBS)
|
||||
|
||||
pngtest: pngtest.o $(LIBNAME).so
|
||||
$(CC) -o pngtest $(CFLAGS) pngtest.o $(LDFLAGS)
|
170
libpng12.spec
Normal file
170
libpng12.spec
Normal file
@ -0,0 +1,170 @@
|
||||
Name: libpng12
|
||||
Version: 1.2.51
|
||||
Release: 1mamba
|
||||
Summary: A library of functions for manipulating PNG image format files
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.libpng.org/pub/png/libpng.html
|
||||
Source: ftp://ftp.simplesystems.org/pub/png/src/libpng12/libpng-%{version}.tar.xz
|
||||
Patch1: libpng-1.2.8-link_to_proper_libs.patch
|
||||
Patch3: libpng-1.2.41-apng.patch
|
||||
License: OSI Approved
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
This package contains the library needed to run programs dynamically linked with libpng.
|
||||
|
||||
%package devel
|
||||
Summary: Development tools for programs to manipulate PNG image format files
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The libpng-devel package contains the header files and libraries necessary for developing programs using the PNG (Portable Network Graphics) library.
|
||||
|
||||
If you want to develop programs which will manipulate PNG image format files, you should install libpng-devel.
|
||||
You'll also need to install the libpng package.
|
||||
|
||||
%prep
|
||||
%setup -q -n libpng-%{version}
|
||||
#%patch3 -p0
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
%configure --enable-shared --enable-static
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
rm -f %{buildroot}%{_bindir}/libpng-config
|
||||
rm -f %{buildroot}%{_includedir}/png.h
|
||||
rm -f %{buildroot}%{_includedir}/pngconf.h
|
||||
rm -f %{buildroot}%{_libdir}/libpng.{a,la,so}
|
||||
rm -f %{buildroot}%{_libdir}/pkgconfig/libpng.pc
|
||||
rm -f %{buildroot}%{_mandir}/man3/libpng.*
|
||||
rm -f %{buildroot}%{_mandir}/man3/libpngpf.*
|
||||
rm -f %{buildroot}%{_mandir}/man5/png.*
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libpng.so.*
|
||||
%{_libdir}/libpng12.so.*
|
||||
%doc LICENSE
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/libpng12-config
|
||||
%{_includedir}/libpng12/
|
||||
%{_libdir}/libpng12.a
|
||||
%{_libdir}/libpng12.la
|
||||
%{_libdir}/libpng12.so
|
||||
%{_libdir}/pkgconfig/libpng12.pc
|
||||
%doc ANNOUNCE CHANGES KNOWNBUG LICENSE TODO
|
||||
%doc pngbar.jpg pngbar.png pngnow.png
|
||||
|
||||
%changelog
|
||||
* Sat Mar 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.51-1mamba
|
||||
- update to 1.2.51
|
||||
|
||||
* Sat Dec 01 2012 Automatic Build System <autodist@mambasoft.it> 1.2.50-1mamba
|
||||
- update to 1.2.50
|
||||
|
||||
* Tue Jul 26 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.46-1mamba
|
||||
- update to 1.2.46
|
||||
|
||||
* Sat Jun 26 2010 Automatic Build System <autodist@mambasoft.it> 1.2.41-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Tue Jun 08 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.41-2mamba
|
||||
- rebuilt as legacy package
|
||||
|
||||
* Mon Dec 21 2009 Automatic Build System <autodist@mambasoft.it> 1.2.41-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Nov 21 2009 Automatic Build System <autodist@mambasoft.it> 1.2.40-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Jul 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.37-1mamba
|
||||
- update to 1.2.37
|
||||
|
||||
* Thu May 28 2009 Automatic Build System <autodist@mambasoft.it> 1.2.36-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Mar 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.35-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Jan 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.34-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Nov 30 2008 gil <puntogil@libero.it> 1.2.33-1mamba
|
||||
- update to 1.2.33
|
||||
|
||||
* Thu Jun 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.29-2mamba
|
||||
- added apng (animated png) patch from cblfs.cross-lfs.org/index.php/Libpng
|
||||
|
||||
* Sat May 31 2008 gil <puntogil@libero.it> 1.2.29-1mamba
|
||||
- update to 1.2.29
|
||||
|
||||
* Fri Jul 27 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.18-2mamba
|
||||
- re-enable build of static library needed by splashutils
|
||||
|
||||
* Tue Jun 05 2007 Aleph0 <aleph0@openmamba.org> 1.2.18-1mamba
|
||||
- security update to 1.2.18 to fix CVE-2007-2445
|
||||
- do not build the static library
|
||||
|
||||
* Wed Feb 21 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.16-2qilnx
|
||||
- don't exclude static library libpng.a
|
||||
|
||||
* Fri Feb 09 2007 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.16-1qilnx
|
||||
- update to version 1.2.16 by autospec
|
||||
- dropped patch against CVE-2006-3334: merged upstream
|
||||
- dropped patches used to fix link libraries and installation paths: fixed
|
||||
upstream
|
||||
- man pages moved to devel package
|
||||
|
||||
* Thu Jul 20 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.8-2qilnx
|
||||
- fixed buffer overflow in chunk error processing (CVE-2006-3334, qibug#202)
|
||||
|
||||
* Wed Feb 16 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.8-1qilnx
|
||||
- update to version 1.2.8 by autospec
|
||||
- specfile updates
|
||||
|
||||
* Tue Dec 21 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.5-8qilnx
|
||||
- added patch to link library to proper libs
|
||||
|
||||
* Sat Nov 06 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.5-7qilnx
|
||||
- specfile cleanups, added patch 'libpng-1.2.5-qilinux-paths'
|
||||
- libpng-config and libpng12-config scripts moved to devel package
|
||||
- added documentation
|
||||
|
||||
* Fri Nov 05 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.5-6qilnx
|
||||
- security fix QSA-2004-051 (CAN-2004-0768)
|
||||
|
||||
* Thu Jul 05 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.5-5qilnx
|
||||
- security fix for CAN-2004-0597, CAN-2004-0598, CAN-2004-0599
|
||||
|
||||
* Mon May 03 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.5-4qilnx
|
||||
- security fix for CAN-2004-0421
|
||||
|
||||
* Tue Jul 08 2003 Silvan Calarco <silvan.calarco@qinet.it> 1.2.5-3qilnx
|
||||
- rebuilt with minor changes
|
||||
|
||||
* Tue May 13 2003 Silvan Calarco <silvan.calarco@qinet.it> 1.2.5-2qilnx
|
||||
- added symlinks libpng.so and libpng12.so to devel package
|
||||
|
||||
* Thu Apr 17 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it> 1.2.5-1qilnx
|
||||
- creation of libpng package
|
Loading…
Reference in New Issue
Block a user