232 lines
7.9 KiB
RPMSpec
232 lines
7.9 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: libplasma
|
|
Epoch: 1
|
|
Version: 6.2.3
|
|
Release: 1mamba
|
|
Summary: KDE Plasma library and runtime components
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://kde.org/it/plasma-desktop/
|
|
Source: https://download.kde.org/%{stable_kf6}/plasma/%{version}/libplasma-%{version}.tar.xz
|
|
Source1: openmamba.svgz
|
|
Source2: openmamba-light-metadata.json.cmake
|
|
Source3: openmamba-dark-metadata.json.cmake
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libICE-devel
|
|
BuildRequires: libSM-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libXext-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libglvnd-devel
|
|
BuildRequires: libkf6-karchive-devel
|
|
BuildRequires: libkf6-kcmutils-devel
|
|
BuildRequires: libkf6-kcolorscheme-devel
|
|
BuildRequires: libkf6-kcompletion-devel
|
|
BuildRequires: libkf6-kconfig-devel
|
|
BuildRequires: libkf6-kconfigwidgets-devel
|
|
BuildRequires: libkf6-kcoreaddons-devel
|
|
BuildRequires: libkf6-kglobalaccel-devel
|
|
BuildRequires: libkf6-kguiaddons-devel
|
|
BuildRequires: libkf6-ki18n-devel
|
|
BuildRequires: libkf6-kiconthemes-devel
|
|
BuildRequires: libkf6-kio-devel
|
|
BuildRequires: libkf6-kirigami-devel
|
|
BuildRequires: libkf6-kjobwidgets-devel
|
|
BuildRequires: libkf6-knotifications-devel
|
|
BuildRequires: libkf6-kpackage-devel
|
|
BuildRequires: libkf6-kservice-devel
|
|
BuildRequires: libkf6-ksvg-devel
|
|
BuildRequires: libkf6-kwidgetsaddons-devel
|
|
BuildRequires: libkf6-kwindowsystem-devel
|
|
BuildRequires: libkf6-solid-devel
|
|
BuildRequires: libplasma-activities-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libwayland-devel
|
|
BuildRequires: libxcb-devel
|
|
BuildRequires: libxkbcommon-devel
|
|
BuildRequires: qt6-qtbase-devel
|
|
BuildRequires: qt6-qtdeclarative-devel
|
|
BuildRequires: qt6-qtsvg-devel
|
|
BuildRequires: qt6-qtwayland-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
BuildRequires: kf6-rpm-macros
|
|
BuildRequires: extra-cmake-modules
|
|
|
|
%description
|
|
KDE Plasma library and runtime components.
|
|
|
|
%package devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%package desktopthemes
|
|
Group: Graphical Desktop/Look 'n' feel
|
|
Summary: Additional Plasma desktop themes
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Provides: plasma-framework-desktopthemes
|
|
Obsoletes: plasma-framework-desktopthemes <= 5.115.0-1mamba
|
|
|
|
%description desktopthemes
|
|
Additional Plasma desktop themes.
|
|
|
|
%package -n plasma-desktoptheme-openmamba
|
|
Group: Graphical Desktop/Look 'n' feel
|
|
Summary: Plasma desktop theme for openmamba
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n plasma-desktoptheme-openmamba
|
|
Plasma desktop theme for openmamba.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
cp -a src/desktoptheme/{breeze-dark,openmamba-dark}
|
|
cp -a src/desktoptheme/{breeze-light,openmamba-light}
|
|
cp -a %{SOURCE2} src/desktoptheme/openmamba-light/metadata.json.cmake
|
|
cp -a %{SOURCE3} src/desktoptheme/openmamba-dark/metadata.json.cmake
|
|
sed -i "s|61,174,233|82,174,50|" src/desktoptheme/openmamba-{light,dark}/colors
|
|
sed -i "s|defaultWallpaperTheme=.*|defaultWallpaperTheme=openmambaRandom|" src/desktoptheme/openmamba-{light,dark}/plasmarc
|
|
sed -i "s|desktoptheme/breeze|desktoptheme/openmamba|" src/desktoptheme/openmamba-{light,dark}/CMakeLists.txt
|
|
cat >> src/desktoptheme/CMakeLists.txt << _EOF
|
|
add_subdirectory( openmamba-dark )
|
|
add_subdirectory( openmamba-light )
|
|
_EOF
|
|
|
|
%build
|
|
%cmake_kf6
|
|
|
|
%cmake_build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%cmake_install
|
|
|
|
# Replace desktop menu icon (start.svgz) with openmamba icon
|
|
for d in %{buildroot}%{_datadir}/plasma/desktoptheme/*; do
|
|
[ -e ${d}/icons/start.svgz ] && install -m0644 %{SOURCE1} ${d}/icons/start.svgz
|
|
done
|
|
|
|
%find_lang %{name} --with-qt --with-man --with-html --all-name || touch %{name}.lang
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
|
|
|
|
%files -f %{name}.lang
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libPlasma.so.*
|
|
%{_libdir}/libPlasmaQuick.so.*
|
|
%{_kf6_plugindir}/kirigami/platform/KirigamiPlasmaStyle.so
|
|
%{_kf6_plugindir}/packagestructure/plasma_*.so
|
|
%dir %{_qt6_qmldir}/org/kde/kirigami/styles/Plasma
|
|
%{_qt6_qmldir}/org/kde/kirigami/styles/Plasma/*
|
|
%dir %{_qt6_qmldir}/org/kde/plasma
|
|
%{_qt6_qmldir}/org/kde/plasma/*
|
|
%{_datadir}/kdevappwizard/templates/*.tar.bz2
|
|
%dir %{_datadir}/plasma/desktoptheme/default
|
|
%{_datadir}/plasma/desktoptheme/default/*
|
|
%{_datadir}/qlogging-categories6/plasma-framework.categories
|
|
%{_datadir}/qlogging-categories6/plasma-framework.renamecategories
|
|
%doc LICENSES
|
|
|
|
%files desktopthemes
|
|
%defattr(-,root,root)
|
|
%dir %{_datadir}/plasma/desktoptheme/breeze-dark
|
|
%{_datadir}/plasma/desktoptheme/breeze-dark/*
|
|
%dir %{_datadir}/plasma/desktoptheme/breeze-light
|
|
%{_datadir}/plasma/desktoptheme/breeze-light/*
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/Plasma
|
|
%{_includedir}/Plasma/*
|
|
%dir %{_includedir}/PlasmaQuick
|
|
%{_includedir}/PlasmaQuick/*
|
|
%{_libdir}/libPlasma.so
|
|
%{_libdir}/libPlasmaQuick.so
|
|
%dir %{_libdir}/cmake/Plasma
|
|
%{_libdir}/cmake/Plasma/Plasma*.cmake
|
|
%dir %{_libdir}/cmake/PlasmaQuick
|
|
%{_libdir}/cmake/PlasmaQuick/PlasmaQuick*.cmake
|
|
%{_qt6_docdir}/Plasma.*
|
|
|
|
%files -n plasma-desktoptheme-openmamba
|
|
%defattr(-,root,root)
|
|
%dir %{_datadir}/plasma/desktoptheme/openmamba-dark
|
|
%{_datadir}/plasma/desktoptheme/openmamba-dark/*
|
|
%dir %{_datadir}/plasma/desktoptheme/openmamba-light
|
|
%{_datadir}/plasma/desktoptheme/openmamba-light/*
|
|
|
|
%changelog
|
|
* Thu Nov 07 2024 Automatic Build System <autodist@openmamba.org> 6.2.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 25 2024 Automatic Build System <autodist@openmamba.org> 6.2.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Oct 16 2024 Automatic Build System <autodist@openmamba.org> 6.2.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 10 2024 Automatic Build System <autodist@openmamba.org> 6.2.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 13 2024 Automatic Build System <autodist@openmamba.org> 6.1.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Aug 07 2024 Automatic Build System <autodist@openmamba.org> 6.1.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jul 18 2024 Automatic Build System <autodist@openmamba.org> 6.1.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jul 03 2024 Automatic Build System <autodist@openmamba.org> 6.1.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 26 2024 Automatic Build System <autodist@openmamba.org> 6.1.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 19 2024 Automatic Build System <autodist@openmamba.org> 6.1.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 24 2024 Automatic Build System <autodist@openmamba.org> 6.0.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Apr 17 2024 Automatic Build System <autodist@openmamba.org> 6.0.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 30 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0.3-3mamba
|
|
- desktopthemes: update obsolete version for plasma-framework-desktopthemes
|
|
|
|
* Fri Mar 29 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0.3-2mamba
|
|
- libplasma: don't obsolete plasma-framework
|
|
|
|
* Thu Mar 28 2024 Automatic Build System <autodist@openmamba.org> 6.0.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Mar 13 2024 Automatic Build System <autodist@openmamba.org> 6.0.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Mar 07 2024 Automatic Build System <autodist@openmamba.org> 6.0.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 02 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0.0-1mamba
|
|
- update to 6.0.0
|
|
|
|
* Sat Feb 03 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 5.93.0-1mamba
|
|
- update to 5.93.0
|
|
|
|
* Thu Feb 01 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 5.92.0-1mamba
|
|
- package created using the webbuild interface
|