libphonon/libphonon.spec

234 lines
7.3 KiB
RPMSpec

Name: libphonon
Version: 4.12.0
Release: 1mamba
Summary: Multimedia API for KDE4
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://community.kde.org/Phonon
Source: http://download.kde.org/stable/phonon/%{version}/phonon-%{version}.tar.xz
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libglvnd-devel
BuildRequires: libpulseaudio-devel
BuildRequires: libpulseaudio-glib-devel
BuildRequires: libstdc++6-devel
BuildRequires: qt5-qtbase-devel
BuildRequires: qt5-qttools-devel
BuildRequires: qt6-qt5compat-devel
BuildRequires: qt6-qtbase-devel
BuildRequires: qt6-qttools-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
BuildRequires: automoc4
#%if "%{stage1}" != "1"
#BuildRequires: kdelibs-devel
#%endif
%if "%{stage1}" != "1"
Requires: phonon_backend
%endif
Provides: libphonon-qt5
Obsoletes: libphonon-qt5 < 4.12.0
Requires: %{name}-tools = %{?epoch:%epoch:}%{version}-%{release}
%description
Phonon is the multimedia API for KDE.
Phonon was created to allow KDE to be independent of any single multimedia framework such as GStreamer or Xine and to provide a stable API for KDE4's lifetime.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libphonon-qt5-devel
Obsoletes: libphonon-qt5-devel < 4.12.0
%description devel
Phonon is the multimedia API for KDE.
Phonon was created to allow KDE to be independent of any single multimedia framework such as GStreamer or Xine and to provide a stable API for KDE's lifetime.
This package contains static libraries and header files needed for development.
%package designer
Group: Development/Tools
Summary: libphonon widgets for Qt Designer
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libphonon-qt5-designer
Obsoletes: libphonon-qt5-designer < 4.12.0
%description designer
Phonon is the multimedia API for KDE.
Phonon was created to allow KDE to be independent of any single multimedia framework such as GStreamer or Xine and to provide a stable API for KDE4's lifetime.
This package contains the libphonon widgets for Qt Designer.
%package qt6
Group: System/Libraries
Summary: Qt6 shared libraries for %{name}
Requires: %{name}-tools = %{?epoch:%epoch:}%{version}-%{release}
%description qt6
This package contains shared libraries for %{name}.
%package qt6-devel
Group: Development/Libraries
Summary: Development files for %{name}-qt6
Requires: %{name}-qt6 = %{?epoch:%epoch:}%{version}-%{release}
%description qt6-devel
This package contains libraries and header files for developing applications that use %{name}-qt6.
%package designer-qt6
Group: Development/Tools
Summary: libphonon widgets for Qt Designer
Requires: %{name}-qt6 = %{?epoch:%epoch:}%{version}-%{release}
%description designer-qt6
Phonon is the multimedia API for KDE.
Phonon was created to allow KDE to be independent of any single multimedia framework such as GStreamer or Xine and to provide a stable API for KDE4's lifetime.
This package contains the libphonon widgets for Qt Designer.
%package tools
Group: Graphical Desktop/Applications/Multimedia
Summary: Tools provided by %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description tools
Phonon is the multimedia API for KDE.
Phonon was created to allow KDE to be independent of any single multimedia framework such as GStreamer or Xine and to provide a stable API for KDE's lifetime.
This package contains the phononsettings tool.
%debug_package
%prep
%setup -q -n phonon-%{version}
%build
%cmake -d build \
-DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=ON \
-DPHONON_BUILD_QT6=OFF
%make
cd ..
%cmake -d build-qt6 \
-DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=ON \
-DPHONON_BUILD_QT5=OFF
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
%makeinstall -C build-qt6
%find_lang %{name} --with-qt --with-man --all-name || touch %{name}.lang
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libphonon4qt5.so.*
%{_libdir}/libphonon4qt5experimental.so.*
%doc COPYING.LIB
%files qt6
%defattr(-,root,root)
%{_libdir}/libphonon4qt6.so.*
%{_libdir}/libphonon4qt6experimental.so.*
%files qt6-devel
%defattr(-,root,root)
%dir %{_includedir}/phonon4qt6
%dir %{_includedir}/phonon4qt6/phonon
%{_includedir}/phonon4qt6/phonon/*
%{_libdir}/libphonon4qt6.so
%{_libdir}/libphonon4qt6experimental.so
%dir %{_libdir}/cmake/phonon4qt6
%{_libdir}/cmake/phonon4qt6/Phonon*.cmake
%{_libdir}/pkgconfig/phonon4qt6.pc
%files devel
%defattr(-,root,root)
%dir %{_includedir}/phonon4qt5
%dir %{_includedir}/phonon4qt5/KDE
%dir %{_includedir}/phonon4qt5/KDE/Phonon
%{_includedir}/phonon4qt5/KDE/Phonon/*
%dir %{_includedir}/phonon4qt5/phonon
%{_includedir}/phonon4qt5/phonon/*
%dir %{_libdir}/cmake/phonon4qt5
%{_libdir}/cmake/phonon4qt5/Phonon*.cmake
%{_libdir}/libphonon4qt5.so
%{_libdir}/libphonon4qt5experimental.so
%{_libdir}/pkgconfig/phonon4qt5.pc
%{_libdir}/qt5/mkspecs/modules/qt_phonon4qt5.pri
%files tools -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/phononsettings
%files designer
%defattr(-,root,root)
%{_qt5_plugindir}/designer/phonon4qt5widgets.so
%files designer-qt6
%defattr(-,root,root)
%{_qt6_plugindir}/designer/phonon4qt6widgets.so
%changelog
* Tue Feb 06 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 4.12.0-1mamba
- update to 4.12.0
* Thu Jan 02 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.11.1-1mamba
- update to 4.11.1
* Sun Feb 03 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 4.10.2-1mamba
- update to 4.10.2
* Sat May 14 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.9.0-1mamba
- update to 4.9.0
* Sat Feb 14 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.3-2mamba
- added qt5 subpackage
* Thu Jan 15 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.3-1mamba
- update to 4.8.3
* Wed Jun 04 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.7.1-1mamba
- update to 4.7.1
* Fri Mar 02 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.6.0-1mamba
- update to 4.6.0
* Thu Aug 04 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.0-1mamba
- update to 4.5.0
* Sun Feb 20 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.4-3mamba
- added virtual requirement for phonon_backend
* Sat Jan 29 2011 Davide Madrisan <davide.madrisan@gmail.com> 4.4.4-2mamba
- rebuilt moving libraries to %{_libdir}
* Sun Jan 23 2011 Davide Madrisan <davide.madrisan@gmail.com> 4.4.4-1mamba
- update to 4.4.4
- move phonon.pc to %{_libdir}/pkgconfig (pkg-config doesn't work otherwise)
* Thu Jan 06 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.3-1mamba
- update to 4.4.3
* Tue Feb 03 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3.0-1mamba
- update to 4.3.0
* Tue Oct 07 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.0-3mamba
- removed conflicts with libqt4-phonon
* Thu Aug 28 2008 Aleph0 <aleph0@openmamba.org> 4.2.0-2mamba
- add libphonon conflict against libqt4-phonon
* Thu Aug 28 2008 Aleph0 <aleph0@openmamba.org> 4.2.0-1mamba
- package created by autospec