automatic version update by autodist [release 8.13.31-1mamba;Mon Feb 26 2024]
This commit is contained in:
parent
062ee675bf
commit
fa7158aab3
@ -1,56 +0,0 @@
|
|||||||
diff --git i/cpp/CMakeLists.txt w/cpp/CMakeLists.txt
|
|
||||||
index 3899006a..8e7458d9 100644
|
|
||||||
--- i/cpp/CMakeLists.txt
|
|
||||||
+++ w/cpp/CMakeLists.txt
|
|
||||||
@@ -18,7 +18,7 @@ cmake_minimum_required (VERSION 3.11)
|
|
||||||
|
|
||||||
# Pick the C++ standard to compile with.
|
|
||||||
# Abseil currently supports C++11, C++14, and C++17.
|
|
||||||
-set(CMAKE_CXX_STANDARD 11)
|
|
||||||
+set(CMAKE_CXX_STANDARD 17)
|
|
||||||
set(CMAKE_CXX_STANDARD_REQUIRED ON)
|
|
||||||
|
|
||||||
project (libphonenumber)
|
|
||||||
@@ -126,6 +126,8 @@ if (${USE_BOOST} STREQUAL "OFF" AND ${USE_STDMUTEX} STREQUAL "OFF")
|
|
||||||
find_package (Threads)
|
|
||||||
endif()
|
|
||||||
|
|
||||||
+find_package (absl REQUIRED)
|
|
||||||
+
|
|
||||||
find_or_build_gtest ()
|
|
||||||
|
|
||||||
if (${USE_RE2} STREQUAL "ON")
|
|
||||||
diff --git i/tools/cpp/CMakeLists.txt w/tools/cpp/CMakeLists.txt
|
|
||||||
index b0941656..58a9b3ba 100644
|
|
||||||
--- i/tools/cpp/CMakeLists.txt
|
|
||||||
+++ w/tools/cpp/CMakeLists.txt
|
|
||||||
@@ -26,29 +26,6 @@ project (generate_geocoding_data)
|
|
||||||
# Helper functions dealing with finding libraries and programs this library
|
|
||||||
# depends on.
|
|
||||||
include (gtest.cmake)
|
|
||||||
-include (FetchContent)
|
|
||||||
-
|
|
||||||
-# Downloading the abseil sources.
|
|
||||||
-FetchContent_Declare(
|
|
||||||
- abseil-cpp
|
|
||||||
- GIT_REPOSITORY https://github.com/abseil/abseil-cpp.git
|
|
||||||
- GIT_TAG origin/master
|
|
||||||
-)
|
|
||||||
-
|
|
||||||
-# Building the abseil binaries
|
|
||||||
-FetchContent_GetProperties(abseil-cpp)
|
|
||||||
-if (NOT abseil-cpp_POPULATED)
|
|
||||||
- FetchContent_Populate(abseil-cpp)
|
|
||||||
-endif ()
|
|
||||||
-
|
|
||||||
-if (NOT abseil-cpp_POPULATED)
|
|
||||||
- message (FATAL_ERROR "Could not build abseil-cpp binaries.")
|
|
||||||
-endif ()
|
|
||||||
-
|
|
||||||
-# Safeguarding against any potential link errors as mentioned in
|
|
||||||
-# https://github.com/abseil/abseil-cpp/issues/225
|
|
||||||
-set(CMAKE_POSITION_INDEPENDENT_CODE TRUE)
|
|
||||||
-add_subdirectory(${abseil-cpp_SOURCE_DIR} ${abseil-cpp_BINARY_DIR})
|
|
||||||
|
|
||||||
find_or_build_gtest ()
|
|
||||||
set (
|
|
22
libphonenumber-8.13.31-protobuf-25.3.patch
Normal file
22
libphonenumber-8.13.31-protobuf-25.3.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
diff --git i/cpp/CMakeLists.txt w/cpp/CMakeLists.txt
|
||||||
|
index 96def5c8f..304a1a2af 100644
|
||||||
|
--- i/cpp/CMakeLists.txt
|
||||||
|
+++ w/cpp/CMakeLists.txt
|
||||||
|
@@ -170,13 +170,11 @@ if (USE_RE2)
|
||||||
|
endif ()
|
||||||
|
|
||||||
|
if (USE_PROTOBUF_LITE)
|
||||||
|
- find_required_library (PROTOBUF google/protobuf/message_lite.h protobuf-lite
|
||||||
|
- "Google Protocol Buffers")
|
||||||
|
- check_library_version (PC_PROTOBUF protobuf-lite>=2.4)
|
||||||
|
+ find_package (Protobuf CONFIG)
|
||||||
|
+ set (PROTOBUF_LIB protobuf::libprotobuf-lite)
|
||||||
|
else ()
|
||||||
|
- find_required_library (PROTOBUF google/protobuf/message_lite.h protobuf
|
||||||
|
- "Google Protocol Buffers")
|
||||||
|
- check_library_version (PC_PROTOBUF protobuf>=2.4)
|
||||||
|
+ find_package (Protobuf CONFIG)
|
||||||
|
+ set (PROTOBUF_LIB protobuf::libprotobuf)
|
||||||
|
endif ()
|
||||||
|
|
||||||
|
find_required_library (ICU_UC unicode/uchar.h icuuc "ICU")
|
@ -1,11 +0,0 @@
|
|||||||
--- libphonenumber-8.13.5/tools/cpp/CMakeLists.txt.orig 2023-02-01 14:53:18.841253443 +0100
|
|
||||||
+++ libphonenumber-8.13.5/tools/cpp/CMakeLists.txt 2023-02-01 14:53:59.415031644 +0100
|
|
||||||
@@ -18,7 +18,7 @@
|
|
||||||
|
|
||||||
# Pick the C++ standard to compile with.
|
|
||||||
# Abseil currently supports C++11, C++14, and C++17.
|
|
||||||
-set(CMAKE_CXX_STANDARD 11)
|
|
||||||
+set(CMAKE_CXX_STANDARD 11 CACHE STRING "C++ standard used to compile this project")
|
|
||||||
set(CMAKE_CXX_STANDARD_REQUIRED ON)
|
|
||||||
|
|
||||||
project (generate_geocoding_data)
|
|
@ -1,5 +1,5 @@
|
|||||||
Name: libphonenumber
|
Name: libphonenumber
|
||||||
Version: 8.13.30
|
Version: 8.13.31
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Google's common Java, C++ and JavaScript library for parsing, formatting, and validating international phone numbers
|
Summary: Google's common Java, C++ and JavaScript library for parsing, formatting, and validating international phone numbers
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -8,8 +8,7 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://github.com/google/libphonenumber
|
URL: https://github.com/google/libphonenumber
|
||||||
Source: https://github.com/google/libphonenumber.git/v%{version}/libphonenumber-%{version}.tar.bz2
|
Source: https://github.com/google/libphonenumber.git/v%{version}/libphonenumber-%{version}.tar.bz2
|
||||||
Patch0: libphonenumber-8.12.47-system-abseil-cpp.patch
|
Patch0: libphonenumber-8.13.31-protobuf-25.3.patch
|
||||||
Patch1: libphonenumber-8.13.5-libabseil-cpp-20230125.0.patch
|
|
||||||
License: Apache License 2.0
|
License: Apache License 2.0
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -38,8 +37,7 @@ This package contains libraries and header files for developing applications tha
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1 -b .system-abseil-cpp
|
%patch 0 -p1 -b .protobuf-25.3
|
||||||
#%patch 1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
@ -79,6 +77,9 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%doc README.md
|
%doc README.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 26 2024 Automatic Build System <autodist@openmamba.org> 8.13.31-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Fri Feb 09 2024 Automatic Build System <autodist@openmamba.org> 8.13.30-1mamba
|
* Fri Feb 09 2024 Automatic Build System <autodist@openmamba.org> 8.13.30-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user