170 lines
6.0 KiB
RPMSpec
170 lines
6.0 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f 1-2)
|
|
%define apiver 2.48
|
|
Name: libpangomm
|
|
Version: 2.54.0
|
|
Release: 1mamba
|
|
Summary: C++ interface for Pango
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.gtkmm.org/en/index.html
|
|
Source: http://ftp.acc.umu.se/pub/GNOME/sources/pangomm/%{majver}/pangomm-%{version}.tar.xz
|
|
License: LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libcairomm-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libglibmm-devel
|
|
BuildRequires: libpango-devel
|
|
BuildRequires: libsigc++-devel
|
|
BuildRequires: libstdc++6-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: doxygen
|
|
BuildRequires: graphviz
|
|
|
|
%description
|
|
%{name} provides a C++ interface to the Pango library. Highlights include typesafe callbacks, widgets extensible via inheritance and a comprehensive set of widget classes that can be freely combined to quickly create complex user interfaces.
|
|
|
|
%package devel
|
|
Group: Development/Libraries
|
|
Summary: Static libraries and headers for %{name}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
%{name} provides a C++ interface to the Pango library. Highlights include typesafe callbacks, widgets extensible via inheritance and a comprehensive set of widget classes that can be freely combined to quickly create complex user interfaces.
|
|
This package contains static libraries and header files needed for development.
|
|
|
|
%package apidocs
|
|
Summary: %{name} API documentation
|
|
Group: Documentation
|
|
Requires: gtk-doc
|
|
|
|
%description apidocs
|
|
%{name} provides a C++ interface to the Pango library. Highlights include typesafe callbacks, widgets extensible via inheritance and a comprehensive set of widget classes that can be freely combined to quickly create complex user interfaces.
|
|
This package contains %{name} API documentation.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n pangomm-%{version}
|
|
|
|
%build
|
|
%meson \
|
|
-Dbuild-documentation=true
|
|
|
|
%meson_build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%meson_install
|
|
|
|
## Fix documentation installation
|
|
#mkdir -p %{buildroot}%{_datadir}/gtk-doc/html/pangomm-1.4
|
|
#mv %{buildroot}%{_docdir}/pangomm-1.4/* %{buildroot}%{_datadir}/gtk-doc/html/pangomm-1.4/
|
|
#mv %{buildroot}%{_datadir}/devhelp/books/pangomm-1.4/*.devhelp %{buildroot}%{_datadir}/gtk-doc/html/pangomm-1.4
|
|
#sed -i 's:../../../doc/pangomm-1.4/docs/:docs/:' %{buildroot}%{_datadir}/gtk-doc/html/pangomm-1.4/*.devhelp
|
|
#rm -r %{buildroot}%{_docdir}/pangomm-1.4
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libpangomm-%{apiver}.so.*
|
|
%doc COPYING
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/pangomm-%{apiver}
|
|
%{_includedir}/pangomm-%{apiver}/*.h
|
|
%dir %{_includedir}/pangomm-%{apiver}/pangomm
|
|
%{_includedir}/pangomm-%{apiver}/pangomm/*.h
|
|
%dir %{_includedir}/pangomm-%{apiver}/pangomm/private
|
|
%{_includedir}/pangomm-%{apiver}/pangomm/private/*.h
|
|
%{_libdir}/libpangomm-*.so
|
|
%{_libdir}/pangomm-%{apiver}/proc/m4/convert*.m4
|
|
%{_libdir}/pangomm-%{apiver}/include/pangommconfig.h
|
|
%{_datadir}/devhelp/books/pangomm-2.48/pangomm-2.48.devhelp2
|
|
%{_libdir}/pkgconfig/*.pc
|
|
%doc ChangeLog NEWS README.md
|
|
|
|
%files apidocs
|
|
%defattr(-,root,root)
|
|
%dir %{_docdir}/pangomm-%{apiver}
|
|
%{_docdir}/pangomm-%{apiver}/*
|
|
|
|
%changelog
|
|
* Fri Jul 26 2024 Automatic Build System <autodist@openmamba.org> 2.54.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 17 2024 Automatic Build System <autodist@openmamba.org> 2.52.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jan 30 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.50.2-1mamba
|
|
- update to 2.50.2
|
|
|
|
* Fri Sep 23 2022 Automatic Build System <autodist@mambasoft.it> 2.50.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jan 09 2022 Automatic Build System <autodist@mambasoft.it> 2.50.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 30 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.48.1-1mamba
|
|
- update to 2.48.1
|
|
|
|
* Thu Apr 15 2021 Automatic Build System <autodist@mambasoft.it> 2.48.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 28 2021 Automatic Build System <autodist@mambasoft.it> 2.46.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Dec 29 2020 Automatic Build System <autodist@mambasoft.it> 2.42.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 22 2020 Automatic Build System <autodist@mambasoft.it> 2.42.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 06 2018 Automatic Build System <autodist@mambasoft.it> 2.42.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 20 2016 Automatic Build System <autodist@mambasoft.it> 2.40.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed May 04 2016 Automatic Build System <autodist@mambasoft.it> 2.40.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Nov 29 2015 Automatic Build System <autodist@mambasoft.it> 2.38.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 09 2015 Automatic Build System <autodist@mambasoft.it> 2.36.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Apr 24 2013 Automatic Build System <autodist@mambasoft.it> 2.34.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Oct 26 2011 Automatic Build System <autodist@mambasoft.it> 2.28.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Oct 01 2011 Automatic Build System <autodist@mambasoft.it> 2.28.3-1mamba
|
|
- update to 2.28.3
|
|
|
|
* Wed Apr 06 2011 Automatic Build System <autodist@mambasoft.it> 2.28.2-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Dec 09 2010 Automatic Build System <autodist@mambasoft.it> 2.26.3-1mamba
|
|
- automatic update to 2.26.3 by autodist
|
|
|
|
* Mon Oct 25 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.26.2-2mamba
|
|
- rebuilt with libpng 1.4
|
|
|
|
* Sun May 30 2010 Automatic Build System <autodist@mambasoft.it> 2.26.2-1mamba
|
|
- automatic update to 2.26.2 by autodist
|
|
|
|
* Mon Dec 01 2008 gil <puntogil@libero.it> 2.14.1-1mamba
|
|
- package created by autospec
|