automatic version update by autodist [release 1.38.1-1mamba;Sat Nov 14 2015]
This commit is contained in:
parent
d400b3bafb
commit
d67c4d6173
@ -1,44 +0,0 @@
|
|||||||
From c41144ce0d72cb19d347a46ef9386f257f14fb58 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Gilles Dartiguelongue <eva@gentoo.org>
|
|
||||||
Date: Sun, 28 Oct 2012 23:19:39 +0100
|
|
||||||
Subject: [PATCH] Add multilib support
|
|
||||||
|
|
||||||
pango.modules list modules specific to a host architecture.
|
|
||||||
Add host triplet in path so that machine able to run multiple
|
|
||||||
triplet have a proper file per pango library.
|
|
||||||
---
|
|
||||||
pango/Makefile.am | 1 +
|
|
||||||
pango/pango-utils.c | 4 ++--
|
|
||||||
2 files changed, 3 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/pango/Makefile.am b/pango/Makefile.am
|
|
||||||
index ab092c9..558108b 100644
|
|
||||||
--- a/pango/Makefile.am
|
|
||||||
+++ b/pango/Makefile.am
|
|
||||||
@@ -17,6 +17,7 @@ INCLUDES = \
|
|
||||||
-DPANGO_ENABLE_BACKEND \
|
|
||||||
-DPANGO_ENABLE_ENGINE \
|
|
||||||
-DSYSCONFDIR=\"$(sysconfdir)\" \
|
|
||||||
+ -DHOST=\"$(host_triplet)\" \
|
|
||||||
-DLIBDIR=\"$(libdir)\" \
|
|
||||||
-I$(top_srcdir) \
|
|
||||||
-I$(top_builddir) \
|
|
||||||
diff --git a/pango/pango-utils.c b/pango/pango-utils.c
|
|
||||||
index 18ffa26..3b88f15 100644
|
|
||||||
--- a/pango/pango-utils.c
|
|
||||||
+++ b/pango/pango-utils.c
|
|
||||||
@@ -738,9 +738,9 @@ pango_get_sysconf_subdirectory (void)
|
|
||||||
#else
|
|
||||||
const char *sysconfdir = g_getenv ("PANGO_SYSCONFDIR");
|
|
||||||
if (sysconfdir != NULL)
|
|
||||||
- tmp_result = g_build_filename (sysconfdir, "pango", NULL);
|
|
||||||
+ tmp_result = g_build_filename (sysconfdir, "pango", HOST, NULL);
|
|
||||||
else
|
|
||||||
- tmp_result = SYSCONFDIR "/pango";
|
|
||||||
+ tmp_result = SYSCONFDIR "/pango/" HOST;
|
|
||||||
#endif
|
|
||||||
g_once_init_leave((gsize*)&result, (gsize)tmp_result);
|
|
||||||
}
|
|
||||||
--
|
|
||||||
1.7.12.4
|
|
||||||
|
|
24
libpango-1.38-lib64.patch
Normal file
24
libpango-1.38-lib64.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
--- pango-1.38.0/pango/pango-utils.c.orig 2015-10-10 15:03:27.799554998 +0200
|
||||||
|
+++ pango-1.38.0/pango/pango-utils.c 2015-10-10 15:38:46.820822615 +0200
|
||||||
|
@@ -607,9 +607,9 @@
|
||||||
|
const char *tmp_result = NULL;
|
||||||
|
const char *sysconfdir = g_getenv ("PANGO_SYSCONFDIR");
|
||||||
|
if (sysconfdir != NULL)
|
||||||
|
- tmp_result = g_build_filename (sysconfdir, "pango", NULL);
|
||||||
|
+ tmp_result = g_build_filename (sysconfdir, "pango", HOST, NULL);
|
||||||
|
else
|
||||||
|
- tmp_result = SYSCONFDIR "/pango";
|
||||||
|
+ tmp_result = SYSCONFDIR "/pango/" HOST;
|
||||||
|
g_once_init_leave(&result, tmp_result);
|
||||||
|
}
|
||||||
|
return result;
|
||||||
|
--- pango-1.38.0/pango/Makefile.am.orig 2015-09-01 00:47:11.000000000 +0200
|
||||||
|
+++ pango-1.38.0/pango/Makefile.am 2015-10-10 15:03:27.799554998 +0200
|
||||||
|
@@ -18,6 +18,7 @@
|
||||||
|
-DPANGO_ENABLE_BACKEND \
|
||||||
|
-DPANGO_ENABLE_ENGINE \
|
||||||
|
-DSYSCONFDIR=\"$(sysconfdir)\" \
|
||||||
|
+ -DHOST=\"$(host_triplet)\" \
|
||||||
|
-DLIBDIR=\"$(libdir)\" \
|
||||||
|
-I$(top_srcdir) \
|
||||||
|
-I$(top_builddir) \
|
@ -1,6 +1,6 @@
|
|||||||
%define majver %(echo %version | cut -d. -f 1-2)
|
%define majver %(echo %version | cut -d. -f 1-2)
|
||||||
%define libver 1.0
|
%define libver 1.0
|
||||||
%define modulesver 1.8.0
|
%define modulesver 1.10.0
|
||||||
|
|
||||||
%ifarch x86_64
|
%ifarch x86_64
|
||||||
%define arch_suffix -64
|
%define arch_suffix -64
|
||||||
@ -9,8 +9,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: libpango
|
Name: libpango
|
||||||
Version: 1.36.8
|
Version: 1.38.1
|
||||||
Release: 3mamba
|
Release: 1mamba
|
||||||
Summary: System for layout and rendering of internationalized text
|
Summary: System for layout and rendering of internationalized text
|
||||||
Group: System/Internationalization
|
Group: System/Internationalization
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -19,7 +19,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: http://www.pango.org
|
URL: http://www.pango.org
|
||||||
# bugfixes: http://ftp.acc.umu.se/pub/GNOME/sources/%{pkgname}
|
# bugfixes: http://ftp.acc.umu.se/pub/GNOME/sources/%{pkgname}
|
||||||
Source: http://ftp.gnome.org/pub/GNOME/sources/pango/%{majver}/pango-%{version}.tar.xz
|
Source: http://ftp.gnome.org/pub/GNOME/sources/pango/%{majver}/pango-%{version}.tar.xz
|
||||||
Patch0: libpango-1.36.8-lib64.patch
|
Patch0: libpango-1.38-lib64.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -110,16 +110,17 @@ install -d -m0755 %{buildroot}%{_sysconfdir}/pango
|
|||||||
|
|
||||||
%posttrans
|
%posttrans
|
||||||
if [ $1 -ge 1 ]; then
|
if [ $1 -ge 1 ]; then
|
||||||
mkdir -p %{_sysconfdir}/pango/%{_target_platform}
|
# mkdir -p %{_sysconfdir}/pango/%{_target_platform}
|
||||||
%{_bindir}/pango-querymodules%{arch_suffix} > %{_sysconfdir}/pango/%{_target_platform}/pango.modules
|
# %{_bindir}/pango-querymodules%{arch_suffix} > %{_sysconfdir}/pango/%{_target_platform}/pango.modules
|
||||||
%ifnarch x86_64
|
#%ifnarch x86_64
|
||||||
if [ ! -e /usr/bin/pango-querymodules-64 ]; then
|
# if [ ! -e /usr/bin/pango-querymodules-64 ]; then
|
||||||
%endif
|
#%endif
|
||||||
ln -snf pango-querymodules%{arch_suffix} %{_bindir}/pango-querymodules
|
# ln -snf pango-querymodules%{arch_suffix} %{_bindir}/pango-querymodules
|
||||||
ln -snf pango-view%{arch_suffix} %{_bindir}/pango-view
|
ln -snf pango-view%{arch_suffix} %{_bindir}/pango-view
|
||||||
%ifnarch x86_64
|
[ -L %{_bindir}/pango-querymodules ] && rm -f %{_bindir}/pango-querymodules
|
||||||
fi
|
#%ifnarch x86_64
|
||||||
%endif
|
# fi
|
||||||
|
#%endif
|
||||||
fi
|
fi
|
||||||
# legacy cleanups
|
# legacy cleanups
|
||||||
rm -f /etc/pango/pango.modules
|
rm -f /etc/pango/pango.modules
|
||||||
@ -130,22 +131,22 @@ exit 0
|
|||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_sysconfdir}/pango
|
%dir %{_sysconfdir}/pango
|
||||||
%{_bindir}/pango-querymodules%{arch_suffix}
|
#%{_bindir}/pango-querymodules%{arch_suffix}
|
||||||
%{_bindir}/pango-view%{arch_suffix}
|
%{_bindir}/pango-view%{arch_suffix}
|
||||||
%{_libdir}/libpango-%{libver}.so.*
|
%{_libdir}/libpango-%{libver}.so.*
|
||||||
%{_libdir}/libpangocairo-%{libver}.so.*
|
%{_libdir}/libpangocairo-%{libver}.so.*
|
||||||
%{_libdir}/libpangoft2-%{libver}.so.*
|
%{_libdir}/libpangoft2-%{libver}.so.*
|
||||||
#%{_libdir}/libpangox-%{libver}.so.*
|
#%{_libdir}/libpangox-%{libver}.so.*
|
||||||
%{_libdir}/libpangoxft-%{libver}.*
|
%{_libdir}/libpangoxft-%{libver}.*
|
||||||
%{_libdir}/pango/%{modulesver}/modules/*.la
|
#%{_libdir}/pango/%{modulesver}/modules/*.la
|
||||||
%{_libdir}/pango/%{modulesver}/modules/*.so
|
#%{_libdir}/pango/%{modulesver}/modules/*.so
|
||||||
%if "%{stage1}" != "1"
|
%if "%{stage1}" != "1"
|
||||||
%{_libdir}/girepository-1.0/Pango*.typelib
|
%{_libdir}/girepository-1.0/Pango*.typelib
|
||||||
%endif
|
%endif
|
||||||
%{_mandir}/man1/pango-querymodules%{arch_suffix}.1*
|
#%{_mandir}/man1/pango-querymodules%{arch_suffix}.1*
|
||||||
%{_mandir}/man1/pango-view%{arch_suffix}.1*
|
%{_mandir}/man1/pango-view%{arch_suffix}.1*
|
||||||
#%{_mandir}/man1/preload.1.gz
|
#%{_mandir}/man1/preload.1.gz
|
||||||
%doc AUTHORS ChangeLog
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -160,7 +161,7 @@ exit 0
|
|||||||
%{_libdir}/libpangoft2-%{libver}.so
|
%{_libdir}/libpangoft2-%{libver}.so
|
||||||
#%{_libdir}/libpangox-%{libver}.so
|
#%{_libdir}/libpangox-%{libver}.so
|
||||||
%{_datadir}/gir-1.0/Pango*.gir
|
%{_datadir}/gir-1.0/Pango*.gir
|
||||||
#%doc COPYING NEWS README
|
%doc NEWS README ChangeLog
|
||||||
|
|
||||||
%files apidocs
|
%files apidocs
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -168,6 +169,9 @@ exit 0
|
|||||||
%{_datadir}/gtk-doc/html/pango/*
|
%{_datadir}/gtk-doc/html/pango/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Nov 14 2015 Automatic Build System <autodist@mambasoft.it> 1.38.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Tue Mar 31 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.36.8-3mamba
|
* Tue Mar 31 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.36.8-3mamba
|
||||||
- add patch to support biarch configuration
|
- add patch to support biarch configuration
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user