rebuilt with boost 1.55 [release 0.5.1-2mamba;Mon Dec 02 2013]
This commit is contained in:
parent
3988efb090
commit
6cecdce389
@ -1,2 +1,4 @@
|
||||
# liborcus
|
||||
|
||||
Standalone file import filter library for spreadsheet documents. Currently under development are ODS, XLSX and CSV import filters.
|
||||
|
||||
|
10
liborcus-0.3.0-libboost-1.52.patch
Normal file
10
liborcus-0.3.0-libboost-1.52.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- liborcus_0.3.0.orig/src/liborcus/dom_tree.cpp 2012-11-28 13:21:10.000000000 +0100
|
||||
+++ liborcus_0.3.0/src/liborcus/dom_tree.cpp 2013-02-12 22:34:45.213647053 +0100
|
||||
@@ -28,6 +28,7 @@
|
||||
#include "orcus/dom_tree.hpp"
|
||||
#include "orcus/exception.hpp"
|
||||
#include "orcus/xml_namespace.hpp"
|
||||
+#include "boost/noncopyable.hpp"
|
||||
|
||||
#include "string_pool.hpp"
|
||||
|
12
liborcus-0.5.1-libboost-1.54.patch
Normal file
12
liborcus-0.5.1-libboost-1.54.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru liborcus-0.5.1.orig/src/Makefile.am liborcus-0.5.1/src/Makefile.am
|
||||
--- liborcus-0.5.1.orig/src/Makefile.am 2013-03-25 01:18:18.000000000 +0100
|
||||
+++ liborcus-0.5.1/src/Makefile.am 2013-08-08 15:33:32.699834987 +0200
|
||||
@@ -22,7 +22,7 @@
|
||||
orcus_zip_dump_SOURCES = \
|
||||
orcus_zip_dump.cpp
|
||||
|
||||
-orcus_zip_dump_LDADD = \
|
||||
+orcus_zip_dump_LDADD = $(BOOST_SYSTEM_LIB) \
|
||||
parser/liborcus-parser-@ORCUS_API_VERSION@.la
|
||||
|
||||
orcus_zip_dump_CPPFLAGS =
|
11
liborcus-0.5.1-libmdds-0.8.patch
Normal file
11
liborcus-0.5.1-libmdds-0.8.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- liborcus-0.5.1/src/spreadsheet/sheet.cpp.orig 2013-08-08 10:18:56.779004541 +0200
|
||||
+++ liborcus-0.5.1/src/spreadsheet/sheet.cpp 2013-08-08 10:19:02.839946649 +0200
|
||||
@@ -734,7 +734,7 @@
|
||||
con.build_tree();
|
||||
|
||||
size_t index;
|
||||
- if (!con.search_tree(col, index))
|
||||
+ if (!con.search_tree(row, index).second)
|
||||
return 0;
|
||||
|
||||
return index;
|
110
liborcus.spec
Normal file
110
liborcus.spec
Normal file
@ -0,0 +1,110 @@
|
||||
Name: liborcus
|
||||
Version: 0.5.1
|
||||
Release: 2mamba
|
||||
Summary: Standalone file import filter library for spreadsheet documents
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://gitorious.org/orcus
|
||||
Source: http://dev-www.libreoffice.org/src/ea2acaf140ae40a87a952caa75184f4d-liborcus-%{version}.tar.bz2
|
||||
#Source: git://gitorious.org/orcus/orcus.git/master/orcus-%{version}.tar.bz2
|
||||
#Source: http://kohei.us/files/orcus/src/liborcus_%{version}.tar.bz2
|
||||
Patch0: liborcus-0.3.0-libboost-1.52.patch
|
||||
Patch1: liborcus-0.5.1-libmdds-0.8.patch
|
||||
Patch2: liborcus-0.5.1-libboost-1.54.patch
|
||||
License: MIT
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libixion-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Standalone file import filter library for spreadsheet documents. Currently under development are ODS, XLSX and CSV import filters.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
## note: you can add this requirement if .pc files are provided by this package
|
||||
#Requires: pkg-config
|
||||
|
||||
%description devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
%package tools
|
||||
Group: Applications/Publishing
|
||||
Summary: Utility applications for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description tools
|
||||
This package contains utility applications for %{name}.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/liborcus-*.so.*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/liborcus-*/orcus
|
||||
%{_includedir}/liborcus-*/orcus/*.hpp
|
||||
%dir %{_includedir}/liborcus-*/orcus/ooxml
|
||||
%{_includedir}/liborcus-*/orcus/ooxml/encryption_info.hpp
|
||||
%dir %{_includedir}/liborcus-*/orcus/spreadsheet
|
||||
%{_includedir}/liborcus-*/orcus/spreadsheet/*.hpp
|
||||
%{_libdir}/liborcus-*.a
|
||||
%{_libdir}/liborcus-*.la
|
||||
%{_libdir}/liborcus-*.so
|
||||
%{_libdir}/pkgconfig/liborcus-*.pc
|
||||
%doc NEWS README
|
||||
|
||||
%files tools
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/orcus-csv
|
||||
%{_bindir}/orcus-gnumeric
|
||||
%{_bindir}/orcus-mso-encryption
|
||||
%{_bindir}/orcus-ods
|
||||
%{_bindir}/orcus-xlsx
|
||||
%{_bindir}/orcus-xml
|
||||
%{_bindir}/orcus-xml-dump
|
||||
#%{_bindir}/orcus-xls-xml
|
||||
%{_bindir}/orcus-zip-dump
|
||||
|
||||
%changelog
|
||||
* Mon Dec 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-2mamba
|
||||
- rebuilt with boost 1.55
|
||||
|
||||
* Wed Aug 07 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1mamba
|
||||
- update to 0.5.1
|
||||
|
||||
* Tue Feb 12 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.0-1mamba
|
||||
- package created by silvan using the webbuild interface
|
Loading…
Reference in New Issue
Block a user