automatic version update by autodist [release 1.24.0-1mamba;Mon Nov 18 2024]
This commit is contained in:
parent
a10a9d9940
commit
23f913fe4f
@ -1,21 +0,0 @@
|
||||
diff -Naur openal-0.0.8-orig/common/include/AL/alc.h openal-0.0.8/common/include/AL/alc.h
|
||||
--- openal-0.0.8-orig/common/include/AL/alc.h 2006-02-11 03:36:55.000000000 -0600
|
||||
+++ openal-0.0.8/common/include/AL/alc.h 2007-02-13 14:33:57.000000000 -0600
|
||||
@@ -187,7 +187,7 @@
|
||||
|
||||
ALC_API void ALC_APIENTRY alcDestroyContext( ALCcontext *context );
|
||||
|
||||
-ALC_API ALCcontext * ALC_APIENTRY alcGetCurrentContext( ALCvoid );
|
||||
+ALC_API ALCcontext * ALC_APIENTRY alcGetCurrentContext( void );
|
||||
|
||||
ALC_API ALCdevice* ALC_APIENTRY alcGetContextsDevice( ALCcontext *context );
|
||||
|
||||
@@ -248,7 +248,7 @@
|
||||
typedef void (ALC_APIENTRY *LPALCPROCESSCONTEXT)( ALCcontext *context );
|
||||
typedef void (ALC_APIENTRY *LPALCSUSPENDCONTEXT)( ALCcontext *context );
|
||||
typedef void (ALC_APIENTRY *LPALCDESTROYCONTEXT)( ALCcontext *context );
|
||||
-typedef ALCcontext * (ALC_APIENTRY *LPALCGETCURRENTCONTEXT)( ALCvoid );
|
||||
+typedef ALCcontext * (ALC_APIENTRY *LPALCGETCURRENTCONTEXT)( void );
|
||||
typedef ALCdevice * (ALC_APIENTRY *LPALCGETCONTEXTSDEVICE)( ALCcontext *context );
|
||||
typedef ALCdevice * (ALC_APIENTRY *LPALCOPENDEVICE)( const ALCchar *devicename );
|
||||
typedef ALCboolean (ALC_APIENTRY *LPALCCLOSEDEVICE)( ALCdevice *device );
|
@ -1,78 +0,0 @@
|
||||
diff --git i/examples/alhrtf.c w/examples/alhrtf.c
|
||||
index 2be28a91..dfa01e5c 100644
|
||||
--- i/examples/alhrtf.c
|
||||
+++ w/examples/alhrtf.c
|
||||
@@ -30,8 +30,6 @@
|
||||
#include <string.h>
|
||||
|
||||
#include "SDL_sound.h"
|
||||
-#include "SDL_audio.h"
|
||||
-#include "SDL_stdinc.h"
|
||||
|
||||
#include "AL/al.h"
|
||||
#include "AL/alc.h"
|
||||
diff --git i/examples/allatency.c w/examples/allatency.c
|
||||
index a61fb820..5705506a 100644
|
||||
--- i/examples/allatency.c
|
||||
+++ w/examples/allatency.c
|
||||
@@ -28,8 +28,6 @@
|
||||
#include <assert.h>
|
||||
|
||||
#include "SDL_sound.h"
|
||||
-#include "SDL_audio.h"
|
||||
-#include "SDL_stdinc.h"
|
||||
|
||||
#include "AL/al.h"
|
||||
#include "AL/alext.h"
|
||||
diff --git i/examples/almultireverb.c w/examples/almultireverb.c
|
||||
index a90b3368..65e444f5 100644
|
||||
--- i/examples/almultireverb.c
|
||||
+++ w/examples/almultireverb.c
|
||||
@@ -35,8 +35,6 @@
|
||||
#include <string.h>
|
||||
|
||||
#include "SDL_sound.h"
|
||||
-#include "SDL_audio.h"
|
||||
-#include "SDL_stdinc.h"
|
||||
|
||||
#include "AL/al.h"
|
||||
#include "AL/alc.h"
|
||||
diff --git i/examples/alplay.c w/examples/alplay.c
|
||||
index 09ad96b4..01cf769d 100644
|
||||
--- i/examples/alplay.c
|
||||
+++ w/examples/alplay.c
|
||||
@@ -28,8 +28,6 @@
|
||||
#include <assert.h>
|
||||
|
||||
#include "SDL_sound.h"
|
||||
-#include "SDL_audio.h"
|
||||
-#include "SDL_stdinc.h"
|
||||
|
||||
#include "AL/al.h"
|
||||
|
||||
diff --git i/examples/alreverb.c w/examples/alreverb.c
|
||||
index d789dffe..a6dd141d 100644
|
||||
--- i/examples/alreverb.c
|
||||
+++ w/examples/alreverb.c
|
||||
@@ -28,8 +28,6 @@
|
||||
#include <assert.h>
|
||||
|
||||
#include "SDL_sound.h"
|
||||
-#include "SDL_audio.h"
|
||||
-#include "SDL_stdinc.h"
|
||||
|
||||
#include "AL/al.h"
|
||||
#include "AL/alc.h"
|
||||
diff --git i/examples/alstream.c w/examples/alstream.c
|
||||
index 56505ddb..103492c7 100644
|
||||
--- i/examples/alstream.c
|
||||
+++ w/examples/alstream.c
|
||||
@@ -30,8 +30,6 @@
|
||||
#include <assert.h>
|
||||
|
||||
#include "SDL_sound.h"
|
||||
-#include "SDL_audio.h"
|
||||
-#include "SDL_stdinc.h"
|
||||
|
||||
#include "AL/al.h"
|
||||
|
@ -1,5 +1,5 @@
|
||||
Name: libopenal
|
||||
Version: 1.23.1
|
||||
Version: 1.24.0
|
||||
Release: 1mamba
|
||||
Summary: Open Audio Library
|
||||
Group: System/Libraries
|
||||
@ -9,34 +9,29 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://openal-soft.org/
|
||||
Source0: https://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
|
||||
Source1: openalrc
|
||||
Patch0: openal-conf.patch
|
||||
Patch1: openal-etc_openalrc.patch
|
||||
Patch2: openal-incl.patch
|
||||
Patch3: %{name}-0.0.8-gcc42.patch
|
||||
Patch4: libopenal-1.20.1-libSDL2-2.0.12.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libQt5Core
|
||||
BuildRequires: libQt5Gui
|
||||
BuildRequires: libQt5Widgets
|
||||
BuildRequires: libSDL2-devel
|
||||
BuildRequires: libatomic-devel
|
||||
BuildRequires: libavcodec-ffmpeg-devel
|
||||
BuildRequires: libavformat-ffmpeg-devel
|
||||
BuildRequires: libavutil-ffmpeg-devel
|
||||
BuildRequires: libavcodec-devel
|
||||
BuildRequires: libavformat-devel
|
||||
BuildRequires: libavutil-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libswresample-ffmpeg-devel
|
||||
BuildRequires: libswscale-ffmpeg-devel
|
||||
BuildRequires: libswresample-devel
|
||||
BuildRequires: libswscale-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
## AUTOBUILDREQ-END
|
||||
#BuildRequires: libSDL_sound-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libpulseaudio-devel
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
#BuildRequires: libesound-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: texinfo
|
||||
@ -65,19 +60,10 @@ OpenAL is an audio library designed in the spirit of OpenGL - machine independen
|
||||
|
||||
%prep
|
||||
%setup -q -n openal-soft-%{version}
|
||||
#%patch4 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
|
||||
# --enable-arts \
|
||||
# --enable-alsa \
|
||||
# --enable-esd \
|
||||
# --enable-vorbis \
|
||||
# --enable-sdl \
|
||||
# --enable-mp3 \
|
||||
# --enable-capture
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
@ -93,7 +79,6 @@ install -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/openalrc
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
|
||||
|
||||
%preun
|
||||
@ -101,8 +86,6 @@ if [ "$1" -eq 0 ]; then
|
||||
/sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
|
||||
fi
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/libopenal.so.*
|
||||
@ -111,16 +94,7 @@ fi
|
||||
%files -n openal
|
||||
%defattr(-,root,root,-)
|
||||
%config %{_sysconfdir}/openalrc
|
||||
%{_bindir}/allatency
|
||||
%{_bindir}/alffplay
|
||||
%{_bindir}/alhrtf
|
||||
%{_bindir}/alloopback
|
||||
%{_bindir}/almultireverb
|
||||
%{_bindir}/alplay
|
||||
%{_bindir}/alrecord
|
||||
%{_bindir}/alreverb
|
||||
%{_bindir}/alstream
|
||||
%{_bindir}/altonegen
|
||||
%{_bindir}/al*
|
||||
%dir %{_datadir}/openal
|
||||
%{_datadir}/openal/alsoftrc.sample
|
||||
%dir %{_datadir}/openal/hrtf
|
||||
@ -132,15 +106,17 @@ fi
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/alsoft-config
|
||||
%{_bindir}/openal-info
|
||||
%{_includedir}/AL
|
||||
#%{_libdir}/libopenal.a
|
||||
#%{_libdir}/libopenal.la
|
||||
%dir %{_includedir}/AL
|
||||
%{_includedir}/AL/*
|
||||
%{_libdir}/libopenal.so
|
||||
%dir %{_libdir}/cmake/OpenAL
|
||||
%{_libdir}/cmake/OpenAL/OpenAL*.cmake
|
||||
%{_libdir}/pkgconfig/openal.pc
|
||||
|
||||
%changelog
|
||||
* Mon Nov 18 2024 Automatic Build System <autodist@openmamba.org> 1.24.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Apr 12 2023 Automatic Build System <autodist@mambasoft.it> 1.23.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
@ -1,14 +0,0 @@
|
||||
diff -ru openal.orig/linux/Makefile.in openal/linux/Makefile.in
|
||||
--- openal.orig/linux/Makefile.in 2002-09-06 00:54:36.000000000 +0200
|
||||
+++ openal/linux/Makefile.in 2002-10-29 18:23:31.000000000 +0100
|
||||
@@ -52,8 +52,8 @@
|
||||
install_minor_libs:
|
||||
$(INSTALL) -d -m 755 $(DESTLIB)
|
||||
$(INSTALL) -m 755 src/libopenal.$(SO_EXT).$(VERSION) $(DESTLIB)
|
||||
- $(LN_S) -f $(DESTLIB)/libopenal.$(SO_EXT).$(VERSION) $(DESTLIB)/libopenal.$(SO_EXT).$(MAJOR_VERSION)
|
||||
- $(LN_S) -f $(DESTLIB)/libopenal.$(SO_EXT).$(VERSION) $(DESTLIB)/libopenal.so
|
||||
+ $(LN_S) -f libopenal.$(SO_EXT).$(VERSION) $(DESTLIB)/libopenal.$(SO_EXT).$(MAJOR_VERSION)
|
||||
+ $(LN_S) -f libopenal.$(SO_EXT).$(VERSION) $(DESTLIB)/libopenal.so
|
||||
|
||||
install_major_lib_only:
|
||||
$(INSTALL) -d -m 755 $(DESTLIB)
|
@ -1,22 +0,0 @@
|
||||
--- linux/src/al_config.c
|
||||
+++ linux/src/al_config.c
|
||||
@@ -356,7 +356,18 @@
|
||||
|
||||
/* for later malloc, get size */
|
||||
filelen = buf.st_size;
|
||||
- }
|
||||
+ } else {
|
||||
+ /*
|
||||
+ * try system wide OpenAL config file
|
||||
+ */
|
||||
+ sprintf(pathname, "/etc/%s", _AL_FNAME);
|
||||
+ if(stat(pathname, &buf) != -1) {
|
||||
+ fh = fopen(pathname, "rb");
|
||||
+
|
||||
+ /* for later malloc, get size */
|
||||
+ filelen = buf.st_size;
|
||||
+ }
|
||||
+ }
|
||||
|
||||
if( fh == NULL ) {
|
||||
return NULL;
|
@ -1,35 +0,0 @@
|
||||
diff -ru openal.orig/linux/src/arch/sdl/sdl.c openal/linux/src/arch/sdl/sdl.c
|
||||
--- openal.orig/linux/src/arch/sdl/sdl.c 2002-09-09 06:45:39.000000000 +0200
|
||||
+++ openal/linux/src/arch/sdl/sdl.c 2002-10-30 13:55:45.000000000 +0100
|
||||
@@ -11,6 +11,7 @@
|
||||
|
||||
#include <fcntl.h>
|
||||
#include <stdio.h>
|
||||
+#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/time.h>
|
||||
diff -ru openal.orig/linux/src/extensions/al_ext_mp3.c openal/linux/src/extensions/al_ext_mp3.c
|
||||
--- openal.orig/linux/src/extensions/al_ext_mp3.c 2002-03-18 15:41:44.000000000 +0100
|
||||
+++ openal/linux/src/extensions/al_ext_mp3.c 2002-10-30 13:56:21.000000000 +0100
|
||||
@@ -7,6 +7,9 @@
|
||||
*/
|
||||
#include "al_siteconfig.h"
|
||||
#include <stdio.h>
|
||||
+#include <string.h>
|
||||
+
|
||||
+#include "AL/al.h"
|
||||
|
||||
#include "al_ext_needed.h"
|
||||
#include "al_ext_mp3.h"
|
||||
diff -ru openal.orig/linux/src/extensions/al_ext_vorbis.c openal/linux/src/extensions/al_ext_vorbis.c
|
||||
--- openal.orig/linux/src/extensions/al_ext_vorbis.c 2002-09-26 02:51:23.000000000 +0200
|
||||
+++ openal/linux/src/extensions/al_ext_vorbis.c 2002-10-30 13:56:40.000000000 +0100
|
||||
@@ -12,6 +12,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
|
||||
#include "al_ext_needed.h"
|
||||
#include "al_ext_vorbis.h"
|
Loading…
Reference in New Issue
Block a user