automatic version update by autodist [release 1.15.1-1mamba;Wed Dec 12 2012]

This commit is contained in:
Automatic Build System 2024-01-06 05:17:03 +01:00
parent 4ac3189502
commit 08e4abfcdc
7 changed files with 244 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# libopenal # libopenal
OpenAL is an audio library designed in the spirit of OpenGL - machine independent, cross platform, and data format neutral, with a clean, simple C-based API.

View File

@ -0,0 +1,21 @@
diff -Naur openal-0.0.8-orig/common/include/AL/alc.h openal-0.0.8/common/include/AL/alc.h
--- openal-0.0.8-orig/common/include/AL/alc.h 2006-02-11 03:36:55.000000000 -0600
+++ openal-0.0.8/common/include/AL/alc.h 2007-02-13 14:33:57.000000000 -0600
@@ -187,7 +187,7 @@
ALC_API void ALC_APIENTRY alcDestroyContext( ALCcontext *context );
-ALC_API ALCcontext * ALC_APIENTRY alcGetCurrentContext( ALCvoid );
+ALC_API ALCcontext * ALC_APIENTRY alcGetCurrentContext( void );
ALC_API ALCdevice* ALC_APIENTRY alcGetContextsDevice( ALCcontext *context );
@@ -248,7 +248,7 @@
typedef void (ALC_APIENTRY *LPALCPROCESSCONTEXT)( ALCcontext *context );
typedef void (ALC_APIENTRY *LPALCSUSPENDCONTEXT)( ALCcontext *context );
typedef void (ALC_APIENTRY *LPALCDESTROYCONTEXT)( ALCcontext *context );
-typedef ALCcontext * (ALC_APIENTRY *LPALCGETCURRENTCONTEXT)( ALCvoid );
+typedef ALCcontext * (ALC_APIENTRY *LPALCGETCURRENTCONTEXT)( void );
typedef ALCdevice * (ALC_APIENTRY *LPALCGETCONTEXTSDEVICE)( ALCcontext *context );
typedef ALCdevice * (ALC_APIENTRY *LPALCOPENDEVICE)( const ALCchar *devicename );
typedef ALCboolean (ALC_APIENTRY *LPALCCLOSEDEVICE)( ALCdevice *device );

141
libopenal.spec Normal file
View File

@ -0,0 +1,141 @@
Name: libopenal
Version: 1.15.1
Release: 1mamba
Summary: Open Audio Library
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.openal.org/
Source0: http://kcat.strangesoft.net/openal-releases/openal-soft-%{version}.tar.bz2
#Source0: http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
Source1: openalrc
Patch0: openal-conf.patch
Patch1: openal-etc_openalrc.patch
Patch2: openal-incl.patch
Patch3: %{name}-0.0.8-gcc42.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
## AUTOBUILDREQ-END
BuildRequires: libalsa-devel
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libesound-devel
BuildRequires: libogg-devel
BuildRequires: libvorbis-devel
BuildRequires: libSDL-devel
BuildRequires: texinfo
BuildRoot: %{_tmppath}/%{name}-%{version}-root
Obsoletes: libopenal-test
%description
OpenAL is an audio library designed in the spirit of OpenGL - machine independent, cross platform, and data format neutral, with a clean, simple C-based API.
%package devel
Summary: Static libraries and header files for openal library
Requires: %{name} = %{version}-%{release}
Group: Development/Libraries
%description devel
This package contains static libraries and header files for the openal library.
OpenAL is an audio library designed in the spirit of OpenGL - machine independent, cross platform, and data format neutral, with a clean, simple C-based API.
%prep
%setup -q -n openal-soft-%{version}
#%patch0 -p1
#%patch1
#%patch2 -p1
#%patch3 -p1
%build
%cmake
# --enable-arts \
# --enable-alsa \
# --enable-esd \
# --enable-vorbis \
# --enable-sdl \
# --enable-mp3 \
# --enable-capture
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
#
# configuration
install -m0755 -d %{buildroot}/etc
install -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/openalrc
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post
/sbin/ldconfig
/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
%preun
if [ "$1" -eq 0 ]; then
/sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
fi
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%config %{_sysconfdir}/openalrc
%{_bindir}/allatency
%{_bindir}/alreverb
%{_bindir}/alstream
%{_bindir}/makehrtf
%{_libdir}/libopenal.so.*
%dir %{_datadir}/openal
%{_datadir}/openal/alsoftrc.sample
%doc COPYING
%files devel
%defattr(-,root,root,-)
%{_bindir}/openal-info
%{_includedir}/AL
#%{_libdir}/libopenal.a
#%{_libdir}/libopenal.la
%{_libdir}/libopenal.so
%{_libdir}/pkgconfig/openal.pc
%changelog
* Wed Dec 12 2012 Automatic Build System <autodist@mambasoft.it> 1.15.1-1mamba
- automatic version update by autodist
* Sat Dec 08 2012 Automatic Build System <autodist@mambasoft.it> 1.15-1mamba
- update to 1.15
* Fri Jan 07 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12.854-1mamba
- update to 1.12.854
- removed build requirement for arts
* Thu Jun 03 2010 Automatic Build System <autodist@mambasoft.it> 1.11.753-1mamba
- update to 1.11.753
* Sat Jul 11 2009 Automatic Build System <autodist@mambasoft.it> 1.8.466-1mamba
- automatic update by autodist
* Thu Apr 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.411-1mamba
- update to 1.7.411
* Sat May 19 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.8-2mamba
- added patch for gcc 4.2
* Tue Jan 30 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.8-1qilnx
- update to version 0.0.8 by autospec
* Tue Apr 05 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.0-3qilnx
- Added changelog
* Tue Apr 05 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.0-2qilnx
- Rebuild and moved from devel-contrib repository to devel repository
* Wed Mar 16 2005 Matteo Bernasconi <voyagernm@virgilio.it> 0.0-1qilnx
- First Build

14
openal-conf.patch Normal file
View File

@ -0,0 +1,14 @@
diff -ru openal.orig/linux/Makefile.in openal/linux/Makefile.in
--- openal.orig/linux/Makefile.in 2002-09-06 00:54:36.000000000 +0200
+++ openal/linux/Makefile.in 2002-10-29 18:23:31.000000000 +0100
@@ -52,8 +52,8 @@
install_minor_libs:
$(INSTALL) -d -m 755 $(DESTLIB)
$(INSTALL) -m 755 src/libopenal.$(SO_EXT).$(VERSION) $(DESTLIB)
- $(LN_S) -f $(DESTLIB)/libopenal.$(SO_EXT).$(VERSION) $(DESTLIB)/libopenal.$(SO_EXT).$(MAJOR_VERSION)
- $(LN_S) -f $(DESTLIB)/libopenal.$(SO_EXT).$(VERSION) $(DESTLIB)/libopenal.so
+ $(LN_S) -f libopenal.$(SO_EXT).$(VERSION) $(DESTLIB)/libopenal.$(SO_EXT).$(MAJOR_VERSION)
+ $(LN_S) -f libopenal.$(SO_EXT).$(VERSION) $(DESTLIB)/libopenal.so
install_major_lib_only:
$(INSTALL) -d -m 755 $(DESTLIB)

22
openal-etc_openalrc.patch Normal file
View File

@ -0,0 +1,22 @@
--- linux/src/al_config.c
+++ linux/src/al_config.c
@@ -356,7 +356,18 @@
/* for later malloc, get size */
filelen = buf.st_size;
- }
+ } else {
+ /*
+ * try system wide OpenAL config file
+ */
+ sprintf(pathname, "/etc/%s", _AL_FNAME);
+ if(stat(pathname, &buf) != -1) {
+ fh = fopen(pathname, "rb");
+
+ /* for later malloc, get size */
+ filelen = buf.st_size;
+ }
+ }
if( fh == NULL ) {
return NULL;

35
openal-incl.patch Normal file
View File

@ -0,0 +1,35 @@
diff -ru openal.orig/linux/src/arch/sdl/sdl.c openal/linux/src/arch/sdl/sdl.c
--- openal.orig/linux/src/arch/sdl/sdl.c 2002-09-09 06:45:39.000000000 +0200
+++ openal/linux/src/arch/sdl/sdl.c 2002-10-30 13:55:45.000000000 +0100
@@ -11,6 +11,7 @@
#include <fcntl.h>
#include <stdio.h>
+#include <string.h>
#include <stdlib.h>
#include <sys/stat.h>
#include <sys/time.h>
diff -ru openal.orig/linux/src/extensions/al_ext_mp3.c openal/linux/src/extensions/al_ext_mp3.c
--- openal.orig/linux/src/extensions/al_ext_mp3.c 2002-03-18 15:41:44.000000000 +0100
+++ openal/linux/src/extensions/al_ext_mp3.c 2002-10-30 13:56:21.000000000 +0100
@@ -7,6 +7,9 @@
*/
#include "al_siteconfig.h"
#include <stdio.h>
+#include <string.h>
+
+#include "AL/al.h"
#include "al_ext_needed.h"
#include "al_ext_mp3.h"
diff -ru openal.orig/linux/src/extensions/al_ext_vorbis.c openal/linux/src/extensions/al_ext_vorbis.c
--- openal.orig/linux/src/extensions/al_ext_vorbis.c 2002-09-26 02:51:23.000000000 +0200
+++ openal/linux/src/extensions/al_ext_vorbis.c 2002-10-30 13:56:40.000000000 +0100
@@ -12,6 +12,7 @@
#include <stdio.h>
#include <stdlib.h>
+#include <string.h>
#include "al_ext_needed.h"
#include "al_ext_vorbis.h"

9
openalrc Normal file
View File

@ -0,0 +1,9 @@
;;(define devices '(alsa native))
;; uncomment this to output via the 2nd soundcard
;;(define alsa-device "plughw:2,0")
(define speaker-num 2)
(define devices '(alsa))
(define alsa-out-device default)
(define alsa-in-device default)