automatic version update by autodist [release 0.13-1mamba;Sun Feb 16 2014]

This commit is contained in:
Automatic Build System 2024-01-06 05:15:33 +01:00
parent fef0210eb0
commit 01154d8653
4 changed files with 165 additions and 0 deletions

View File

@ -1,2 +1,8 @@
# libode # libode
ODE is an open source, high performance library for simulating rigid body dynamics.
ODE is fully featured, stable, mature and platform independent with an easy to use C/C++ API.
It has advanced joint types and integrated collision detection with friction.
ODE is useful for simulating vehicles, objects in virtual reality environments and virtual creatures.
It is currently used in many computer games, 3D authoring tools and simulation tools.

View File

@ -0,0 +1,46 @@
diff -ru ode-0.9/Makefile.am ode-0.9-makeso/Makefile.am
--- ode-0.9/Makefile.am 2007-02-21 15:54:54.000000000 +0100
+++ ode-0.9-makeso/Makefile.am 2007-12-28 11:51:25.000000000 +0100
@@ -25,13 +25,12 @@
if USE_SONAME
install-exec-hook:
- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
- $(libdir)/libode.so
- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
- $(libdir)/@ODE_SONAME@
- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
- $(libdir)/@ODE_SONAME@.@ODE_REVISION@
- /sbin/ldconfig
+ ln -s @ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
+ $(DESTDIR)/$(libdir)/libode.so
+ ln -s @ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
+ $(DESTDIR)/$(libdir)/@ODE_SONAME@
+ ln -s @ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
+ $(DESTDIR)/$(libdir)/@ODE_SONAME@.@ODE_REVISION@
else
install-exec-hook:
endif
diff -ru ode-0.9/Makefile.in ode-0.9-makeso/Makefile.in
--- ode-0.9/Makefile.in 2007-10-12 14:36:49.000000000 +0200
+++ ode-0.9-makeso/Makefile.in 2007-12-28 11:52:39.000000000 +0100
@@ -652,13 +652,12 @@
rm -rf ${PACKAGE}-${VERSION}
@USE_SONAME_TRUE@install-exec-hook:
-@USE_SONAME_TRUE@ ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
-@USE_SONAME_TRUE@ $(libdir)/libode.so
-@USE_SONAME_TRUE@ ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
-@USE_SONAME_TRUE@ $(libdir)/@ODE_SONAME@
-@USE_SONAME_TRUE@ ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
-@USE_SONAME_TRUE@ $(libdir)/@ODE_SONAME@.@ODE_REVISION@
-@USE_SONAME_TRUE@ /sbin/ldconfig
+@USE_SONAME_TRUE@ ln -s @ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
+@USE_SONAME_TRUE@ $(DESTDIR)/$(libdir)/libode.so
+@USE_SONAME_TRUE@ ln -s @ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
+@USE_SONAME_TRUE@ $(DESTDIR)/$(libdir)/@ODE_SONAME@
+@USE_SONAME_TRUE@ ln -s @ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
+@USE_SONAME_TRUE@ $(DESTDIR)/$(libdir)/@ODE_SONAME@.@ODE_REVISION@
@USE_SONAME_FALSE@install-exec-hook:
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.

View File

@ -0,0 +1,20 @@
diff -up ode-0.9/include/ode/odemath.h~ ode-0.9/include/ode/odemath.h
--- ode-0.9/include/ode/odemath.h~ 2007-10-12 22:08:55.000000000 +0200
+++ ode-0.9/include/ode/odemath.h 2007-10-12 22:08:55.000000000 +0200
@@ -294,14 +294,14 @@ ODE_API int dSafeNormalize4 (dVector4 a
static __inline void _dNormalize3(dVector3 a)
{
int bNormalizationResult = dSafeNormalize3(a);
- dIASSERT(bNormalizationResult);
+/* dIASSERT(bNormalizationResult); */
dVARIABLEUSED(bNormalizationResult);
}
static __inline void _dNormalize4(dVector4 a)
{
int bNormalizationResult = dSafeNormalize4(a);
- dIASSERT(bNormalizationResult);
+/* dIASSERT(bNormalizationResult); */
dVARIABLEUSED(bNormalizationResult);
}

93
libode.spec Normal file
View File

@ -0,0 +1,93 @@
Name: libode
Version: 0.13
Release: 1mamba
Summary: An open source, high performance library for simulating rigid body dynamics
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
URL: http://ode.org/
Source: http://downloads.sourceforge.net/project/opende/ODE/%{version}/ode-%{version}.tar.bz2
Patch0: %{name}-0.9-makefileso.patch
Patch1: %{name}-0.9-no-normalize-assert.patch
License: LGPL, BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
ODE is an open source, high performance library for simulating rigid body dynamics.
ODE is fully featured, stable, mature and platform independent with an easy to use C/C++ API.
It has advanced joint types and integrated collision detection with friction.
ODE is useful for simulating vehicles, objects in virtual reality environments and virtual creatures.
It is currently used in many computer games, 3D authoring tools and simulation tools.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
ODE is an open source, high performance library for simulating rigid body dynamics.
ODE is fully featured, stable, mature and platform independent with an easy to use C/C++ API.
It has advanced joint types and integrated collision detection with friction.
ODE is useful for simulating vehicles, objects in virtual reality environments and virtual creatures.
It is currently used in many computer games, 3D authoring tools and simulation tools.
This package contains static libraries and header files need for development.
%prep
%setup -q -n ode-%{version}
#%patch0 -p1 -b .makefileso
#%patch1 -p1
%build
export CFLAGS="%{optflags} -ffast-math -fPIC"
export CXXFLAGS="%{optflags} -ffast-math -fPIC"
%configure \
--enable-shared \
--enable-soname
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libode.so.*
%doc LICENSE*.TXT README.txt
%files devel
%defattr(-,root,root)
%{_bindir}/ode-config
%{_includedir}/ode/
%{_libdir}/libode.a
%{_libdir}/libode.la
%{_libdir}/libode.so
%{_libdir}/pkgconfig/ode.pc
%changelog
* Sun Feb 16 2014 Automatic Build System <autodist@mambasoft.it> 0.13-1mamba
- automatic version update by autodist
* Sun Oct 20 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.12-1mamba
- update to 0.12
* Fri Sep 06 2013 Automatic Build System <autodist@mambasoft.it> 0.9-2mamba
- automatic rebuild by autodist
* Fri Dec 28 2007 Aleph0 <aleph0@openmamba.org> 0.9-1mamba
- update to 0.9
* Tue Oct 24 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 0.7-1qilnx
- package created by autospec