automatic version update by autodist [release 3.57-1mamba;Sat Oct 10 2020]

This commit is contained in:
Automatic Build System 2024-01-06 05:13:02 +01:00
parent 16b329e967
commit 98433f8816
2 changed files with 30 additions and 27 deletions

View File

@ -1,21 +1,17 @@
Submitted By: Xi Ruoyao <xry111_AT_mengyan1223_DOT_wang> Submitted By: Xi Ruoyao <xry111_AT_mengyan1223_DOT_wang>
Date: 2020-05-31 Date: 2020-08-22
Initial Package Version: 3.12.4 Initial Package Version: 3.12.4
Upstream Status: Not applicable Upstream Status: Not applicable
Origin: Self, rediffed for nss-3.53. Origin: Self, adjusted for nss-3.56.
Description: Adds auto-generated nss.pc and nss-config script, and Description: Adds auto-generated nss.pc and nss-config script, and
allows building without nspr in the source tree. allows building without nspr in the source tree.
For 3.40.1, Requires: updated to nspr >= 4.20. Minimum NSPR version is now read out from package,
For 3.46.1, Requires: updated to nspr >= 4.21. instead of hardcoded value in the patch.
For 3.48, Requires: updated to nspr >= 4.24.
For 3.51.1, Requires: updated to nspr >= 4.25.
For 3.54, Requires: updated to nspr >= 4.26.
For 3.55, Requires: updated to nspr >= 4.27.
diff -Nuar nss-3.53.orig/nss/config/Makefile nss-3.53/nss/config/Makefile diff --color -uNar nss-3.55.orig/nss/config/Makefile nss-3.55/nss/config/Makefile
--- nss-3.53.orig/nss/config/Makefile 1970-01-01 08:00:00.000000000 +0800 --- nss-3.55.orig/nss/config/Makefile 1970-01-01 08:00:00.000000000 +0800
+++ nss-3.53/nss/config/Makefile 2020-05-31 13:48:14.423566855 +0800 +++ nss-3.55/nss/config/Makefile 2020-07-25 19:34:36.272982957 +0800
@@ -0,0 +1,40 @@ @@ -0,0 +1,42 @@
+CORE_DEPTH = .. +CORE_DEPTH = ..
+DEPTH = .. +DEPTH = ..
+ +
@ -24,6 +20,7 @@ diff -Nuar nss-3.53.orig/nss/config/Makefile nss-3.53/nss/config/Makefile
+NSS_MAJOR_VERSION = `grep "NSS_VMAJOR" ../lib/nss/nss.h | awk '{print $$3}'` +NSS_MAJOR_VERSION = `grep "NSS_VMAJOR" ../lib/nss/nss.h | awk '{print $$3}'`
+NSS_MINOR_VERSION = `grep "NSS_VMINOR" ../lib/nss/nss.h | awk '{print $$3}'` +NSS_MINOR_VERSION = `grep "NSS_VMINOR" ../lib/nss/nss.h | awk '{print $$3}'`
+NSS_PATCH_VERSION = `grep "NSS_VPATCH" ../lib/nss/nss.h | awk '{print $$3}'` +NSS_PATCH_VERSION = `grep "NSS_VPATCH" ../lib/nss/nss.h | awk '{print $$3}'`
+NSS_NSPR_MINIMUM = `head -n1 ../automation/release/nspr-version.txt`
+PREFIX = /usr +PREFIX = /usr
+ +
+all: export libs +all: export libs
@ -38,6 +35,7 @@ diff -Nuar nss-3.53.orig/nss/config/Makefile nss-3.53/nss/config/Makefile
+ -e "s,@NSS_MAJOR_VERSION@,$(NSS_MAJOR_VERSION),g" \ + -e "s,@NSS_MAJOR_VERSION@,$(NSS_MAJOR_VERSION),g" \
+ -e "s,@NSS_MINOR_VERSION@,$(NSS_MINOR_VERSION)," \ + -e "s,@NSS_MINOR_VERSION@,$(NSS_MINOR_VERSION)," \
+ -e "s,@NSS_PATCH_VERSION@,$(NSS_PATCH_VERSION)," \ + -e "s,@NSS_PATCH_VERSION@,$(NSS_PATCH_VERSION)," \
+ -e "s,@NSS_NSPR_MINIMUM@,$(NSS_NSPR_MINIMUM)," \
+ nss.pc.in > nss.pc + nss.pc.in > nss.pc
+ chmod 0644 nss.pc + chmod 0644 nss.pc
+ ln -sf ../../../../nss/config/nss.pc $(DIST)/lib/pkgconfig + ln -sf ../../../../nss/config/nss.pc $(DIST)/lib/pkgconfig
@ -56,9 +54,9 @@ diff -Nuar nss-3.53.orig/nss/config/Makefile nss-3.53/nss/config/Makefile
+ +
+dummy: all export libs +dummy: all export libs
+ +
diff -Nuar nss-3.53.orig/nss/config/nss-config.in nss-3.53/nss/config/nss-config.in diff --color -uNar nss-3.55.orig/nss/config/nss-config.in nss-3.55/nss/config/nss-config.in
--- nss-3.53.orig/nss/config/nss-config.in 1970-01-01 08:00:00.000000000 +0800 --- nss-3.55.orig/nss/config/nss-config.in 1970-01-01 08:00:00.000000000 +0800
+++ nss-3.53/nss/config/nss-config.in 2020-05-31 13:48:14.424566860 +0800 +++ nss-3.55/nss/config/nss-config.in 2020-07-25 19:32:37.239032214 +0800
@@ -0,0 +1,153 @@ @@ -0,0 +1,153 @@
+#!/bin/sh +#!/bin/sh
+ +
@ -213,9 +211,9 @@ diff -Nuar nss-3.53.orig/nss/config/nss-config.in nss-3.53/nss/config/nss-config
+ echo $libdirs + echo $libdirs
+fi +fi
+ +
diff -Nuar nss-3.53.orig/nss/config/nss.pc.in nss-3.53/nss/config/nss.pc.in diff --color -uNar nss-3.55.orig/nss/config/nss.pc.in nss-3.55/nss/config/nss.pc.in
--- nss-3.53.orig/nss/config/nss.pc.in 1970-01-01 08:00:00.000000000 +0800 --- nss-3.55.orig/nss/config/nss.pc.in 1970-01-01 08:00:00.000000000 +0800
+++ nss-3.53/nss/config/nss.pc.in 2020-05-31 13:48:14.424566860 +0800 +++ nss-3.55/nss/config/nss.pc.in 2020-07-25 19:33:05.958889937 +0800
@@ -0,0 +1,12 @@ @@ -0,0 +1,12 @@
+prefix=@prefix@ +prefix=@prefix@
+exec_prefix=@exec_prefix@ +exec_prefix=@exec_prefix@
@ -225,13 +223,13 @@ diff -Nuar nss-3.53.orig/nss/config/nss.pc.in nss-3.53/nss/config/nss.pc.in
+Name: NSS +Name: NSS
+Description: Network Security Services +Description: Network Security Services
+Version: @NSS_MAJOR_VERSION@.@NSS_MINOR_VERSION@.@NSS_PATCH_VERSION@ +Version: @NSS_MAJOR_VERSION@.@NSS_MINOR_VERSION@.@NSS_PATCH_VERSION@
+Requires: nspr >= 4.27 +Requires: nspr >= @NSS_NSPR_MINIMUM@
+Libs: -L@libdir@ -lnss@NSS_MAJOR_VERSION@ -lnssutil@NSS_MAJOR_VERSION@ -lsmime@NSS_MAJOR_VERSION@ -lssl@NSS_MAJOR_VERSION@ -lsoftokn@NSS_MAJOR_VERSION@ +Libs: -L@libdir@ -lnss@NSS_MAJOR_VERSION@ -lnssutil@NSS_MAJOR_VERSION@ -lsmime@NSS_MAJOR_VERSION@ -lssl@NSS_MAJOR_VERSION@ -lsoftokn@NSS_MAJOR_VERSION@
+Cflags: -I${includedir} +Cflags: -I${includedir}
+ +
diff -Nuar nss-3.53.orig/nss/Makefile nss-3.53/nss/Makefile diff --color -uNar nss-3.55.orig/nss/Makefile nss-3.55/nss/Makefile
--- nss-3.53.orig/nss/Makefile 2020-05-30 04:34:42.000000000 +0800 --- nss-3.55.orig/nss/Makefile 2020-07-24 23:10:32.000000000 +0800
+++ nss-3.53/nss/Makefile 2020-05-31 13:48:51.500733022 +0800 +++ nss-3.55/nss/Makefile 2020-07-25 19:32:37.239032214 +0800
@@ -4,6 +4,8 @@ @@ -4,6 +4,8 @@
# License, v. 2.0. If a copy of the MPL was not distributed with this # License, v. 2.0. If a copy of the MPL was not distributed with this
# file, You can obtain one at http://mozilla.org/MPL/2.0/. # file, You can obtain one at http://mozilla.org/MPL/2.0/.
@ -254,9 +252,9 @@ diff -Nuar nss-3.53.orig/nss/Makefile nss-3.53/nss/Makefile
$(MAKE) clobber $(MAKE) clobber
NSPR_CONFIG_STATUS = $(CORE_DEPTH)/../nspr/$(OBJDIR_NAME)/config.status NSPR_CONFIG_STATUS = $(CORE_DEPTH)/../nspr/$(OBJDIR_NAME)/config.status
diff -Nuar nss-3.53.orig/nss/manifest.mn nss-3.53/nss/manifest.mn diff --color -uNar nss-3.55.orig/nss/manifest.mn nss-3.55/nss/manifest.mn
--- nss-3.53.orig/nss/manifest.mn 2020-05-30 04:34:42.000000000 +0800 --- nss-3.55.orig/nss/manifest.mn 2020-07-24 23:10:32.000000000 +0800
+++ nss-3.53/nss/manifest.mn 2020-05-31 13:48:30.652640413 +0800 +++ nss-3.55/nss/manifest.mn 2020-07-25 19:32:37.240032237 +0800
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
RELEASE = nss RELEASE = nss

View File

@ -6,7 +6,7 @@
%define with_test 0 %define with_test 0
%define with_nsspem 0 %define with_nsspem 0
Name: libnss Name: libnss
Version: 3.55 Version: 3.57
Release: 1mamba Release: 1mamba
Summary: Network Security Services Summary: Network Security Services
Group: System/Libraries Group: System/Libraries
@ -32,7 +32,7 @@ Source9: setup-nsssysinit.sh
#%endif #%endif
Patch4: libnss-3.12.9-enable-pem.patch Patch4: libnss-3.12.9-enable-pem.patch
Patch10: libnss-3.15.1-opt_flags.patch Patch10: libnss-3.15.1-opt_flags.patch
Patch15: libnss-3.55-standalone-1.patch Patch15: libnss-3.57-standalone-1.patch
License: GPL, MPL 1.1, LGPL License: GPL, MPL 1.1, LGPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
@ -103,6 +103,7 @@ Default Operating System module that manages applications loading NSS globally o
%setup -q -n nss-%{version} %setup -q -n nss-%{version}
#-D -T #-D -T
#:<< __EOF #:<< __EOF
%define _default_patch_fuzz 2
%if %with_nsspem %if %with_nsspem
tar -xf %{SOURCE10} tar -xf %{SOURCE10}
mv nss-pem-%{version}/nss/lib/ckfw/pem/ nss/lib/ckfw/ mv nss-pem-%{version}/nss/lib/ckfw/pem/ nss/lib/ckfw/
@ -132,6 +133,7 @@ export OPT_FLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
BUILD_OPT=1 \ BUILD_OPT=1 \
NSPR_INCLUDE_DIR=%{_includedir}/nspr \ NSPR_INCLUDE_DIR=%{_includedir}/nspr \
USE_SYSTEM_ZLIB=1 \ USE_SYSTEM_ZLIB=1 \
NSS_ENABLE_WERROR=0 \
ZLIB_LIBS=-lz \ ZLIB_LIBS=-lz \
%ifarch x86_64 %ifarch x86_64
USE_64=1 \ USE_64=1 \
@ -279,6 +281,9 @@ ln -s nss3 %{buildroot}%{_includedir}/nss
%{_includedir}/nss3/* %{_includedir}/nss3/*
%changelog %changelog
* Sat Oct 10 2020 Automatic Build System <autodist@mambasoft.it> 3.57-1mamba
- automatic version update by autodist
* Thu Aug 06 2020 Automatic Build System <autodist@mambasoft.it> 3.55-1mamba * Thu Aug 06 2020 Automatic Build System <autodist@mambasoft.it> 3.55-1mamba
- automatic version update by autodist - automatic version update by autodist