automatic version update by autodist [release 4.10.5-1mamba;Fri May 09 2014]

This commit is contained in:
Automatic Build System 2024-01-06 05:12:24 +01:00
parent 9531734af3
commit c11e5ac7bc
6 changed files with 275 additions and 0 deletions

View File

@ -1,2 +1,8 @@
# libnspr
Netscape Portable Runtime (NSPR) provides a platform-neutral API for system level and libc like functions.
The API is used in the Mozilla client, many of Netscape/AOL/iPlanet's and other software offerings.
I Runtime portabili di Netscape (NSRP) forniscono delle API indipendenti dalla piattaforma per funzioni simili a libc e a livello di sistema.
Le API sono usate nel client di Mozilla e da Netscape/AOL/iPlanet e altri programmi.

View File

@ -0,0 +1,11 @@
--- nspr-4.6.5/mozilla/nsprpub/config/nspr.m4.orig 2007-04-05 09:33:17.000000000 +0200
+++ nspr-4.6.5/mozilla/nsprpub/config/nspr.m4 2007-04-05 09:33:30.000000000 +0200
@@ -5,7 +5,7 @@
dnl AM_PATH_NSPR([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
dnl Test for NSPR, and define NSPR_CFLAGS and NSPR_LIBS
-AC_DEFUN(AM_PATH_NSPR,
+AC_DEFUN([AM_PATH_NSPR],
[dnl
AC_ARG_WITH(nspr-prefix,

View File

@ -0,0 +1,49 @@
diff -Nru nspr-4.8.7/mozilla/nsprpub/config/nspr-config-pc.in nspr-4.8.7-gil/mozilla/nsprpub/config/nspr-config-pc.in
--- nspr-4.8.7/mozilla/nsprpub/config/nspr-config-pc.in 2011-01-25 12:44:30.000000000 +0100
+++ nspr-4.8.7-gil/mozilla/nsprpub/config/nspr-config-pc.in 2011-01-25 12:41:35.000000000 +0100
@@ -98,7 +98,7 @@
includedir=@includedir@
fi
if test -z "$libdir"; then
- libdir=@libdir@
+ libdir=`pkg-config --variable=libdir nspr`
fi
if test "$echo_prefix" = "yes"; then
@@ -132,12 +132,12 @@
if test -n "$lib_nspr"; then
libdirs="$libdirs -lnspr${major_version}"
fi
- os_ldflags="@LDFLAGS@"
+ os_ldflags=`pkg-config --variable=ldflags nspr`
for i in $os_ldflags ; do
if echo $i | grep \^-L >/dev/null; then
libdirs="$libdirs $i"
fi
done
- echo $libdirs @OS_LIBS@
+ echo $libdirs `pkg-config --variable=os_libs nspr`
fi
--- nspr-4.9/mozilla/nsprpub/configure.in.orig 2012-03-24 01:49:14.667083058 +0100
+++ nspr-4.9/mozilla/nsprpub/configure.in 2012-03-24 01:49:27.556944216 +0100
@@ -3357,6 +3357,8 @@
config/nsprincl.mk
config/nsprincl.sh
config/nspr-config
+ config/nspr-config-pc
+ config/nspr-config-vars
lib/Makefile
lib/ds/Makefile
lib/libc/Makefile
--- nspr-4.9/mozilla/nsprpub/configure.orig 2012-03-24 01:48:32.729534715 +0100
+++ nspr-4.9/mozilla/nsprpub/configure 2012-03-24 01:49:05.446182357 +0100
@@ -6694,6 +6694,8 @@
config/nsprincl.mk
config/nsprincl.sh
config/nspr-config
+ config/nspr-config-pc
+ config/nspr-config-vars
lib/Makefile
lib/ds/Makefile
lib/libc/Makefile

195
libnspr.spec Normal file
View File

@ -0,0 +1,195 @@
Name: libnspr
Version: 4.10.5
Release: 1mamba
Summary: Netscape Portable Runtime
Summary(it): Runtime portabili di Netscape
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.mozilla.org/projects/nspr/
Source0: ftp://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v%{version}/src/nspr-%{version}.tar.gz
Source1: nspr.pc.in
Source2: nspr-config-vars.in
Patch0: %{name}-4.6.5-m4_underquoteddef.patch
Patch1: libnspr-4.9-config-pc.patch
License: MPL 1.1, GPL, LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
## AUTOBUILDREQ-END
Obsoletes: libmozilla-nspr
Provides: libmozilla-nspr = %{?epoch:%epoch:}%{version}-%{release}
Conflicts: libmozilla <= 1.7.13-1
Obsoletes: libmozilla
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Netscape Portable Runtime (NSPR) provides a platform-neutral API for system level and libc like functions.
The API is used in the Mozilla client, many of Netscape/AOL/iPlanet's and other software offerings.
%description -l it
I Runtime portabili di Netscape (NSRP) forniscono delle API indipendenti dalla piattaforma per funzioni simili a libc e a livello di sistema.
Le API sono usate nel client di Mozilla e da Netscape/AOL/iPlanet e altri programmi.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Conflicts: libmozilla-devel <= 1.7.13-1
Obsoletes: libmozilla-nspr-devel
Provides: libmozilla-nspr-devel = %{?epoch:%epoch:}%{version}-%{release}
%description devel
Netscape Portable Runtime (NSPR) provides a platform-neutral API for system level and libc like functions.
The API is used in the Mozilla client, many of Netscape/AOL/iPlanet's and other software offerings.
This package contains static libraries and header files need for development.
%prep
%setup -q -n nspr-%{version}
mv nspr/* .
cp config/nspr-config.in config/nspr-config-pc.in
#%patch1 -p1
#cp %{SOURCE2} ./mozilla/nsprpub/config/
%build
./configure \
--prefix=%{_prefix} \
--libdir=%{_libdir} \
--includedir=%{_includedir}/nspr \
%ifarch x86_64 ia64
--enable-64bit\
%endif
--enable-optimize="%{optflags}" \
--disable-debug
%make
#NSPR_LIBS=`./config/nspr-config --libs`
#NSPR_CFLAGS=`./config/nspr-config --cflags`
#NSPR_VERSION=`./config/nspr-config --version`
#
#cat ./config/nspr-config-vars > nspr.pc
#
#cat %{S:1} | sed -e "s,%%libdir%%,%{_libdir},g" \
# -e "s,%%prefix%%,%{_prefix},g" \
# -e "s,%%exec_prefix%%,%{_prefix},g" \
# -e "s,%%includedir%%,%{_includedir}/nspr,g" \
# -e "s,%%NSPR_VERSION%%,$NSPR_VERSION,g" \
# -e "s,%%FULL_NSPR_LIBS%%,$NSPR_LIBS,g" \
# -e "s,%%FULL_NSPR_CFLAGS%%,$NSPR_CFLAGS,g" > nspr.pc
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
#install -D -m 644 nspr.pc %{buildroot}%{_libdir}/pkgconfig/nspr.pc
%makeinstall DESTDIR=%{buildroot}
######### make real_install
# remove unpackaged files
rm -f %{buildroot}%{_libdir}/libnspr4.a
rm -f %{buildroot}%{_libdir}/libplc4.a
rm -f %{buildroot}%{_libdir}/libplds4.a
#mkdir -p %{buildroot}%{_bindir}
#install -pm 755 ./config/nspr-config-pc %{buildroot}%{_bindir}/nspr-config
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libnspr4.so
%{_libdir}/libplc4.so
%{_libdir}/libplds4.so
%files devel
%defattr(-,root,root)
%{_bindir}/compile-et.pl
%{_bindir}/nspr-config
%{_bindir}/prerr.properties
%{_datadir}/aclocal/nspr.m4
%{_includedir}/nspr/
%{_libdir}/pkgconfig/nspr.pc
%changelog
* Fri May 09 2014 Automatic Build System <autodist@mambasoft.it> 4.10.5-1mamba
- automatic version update by autodist
* Wed Mar 26 2014 Automatic Build System <autodist@mambasoft.it> 4.10.4-1mamba
- automatic version update by autodist
* Tue Feb 04 2014 Automatic Build System <autodist@mambasoft.it> 4.10.3-1mamba
- automatic version update by autodist
* Thu Nov 14 2013 Automatic Build System <autodist@mambasoft.it> 4.10.2-2mamba
- rebuilt after breaking and fixing rpm
* Wed Nov 13 2013 Automatic Build System <autodist@mambasoft.it> 4.10.2-1mamba
- automatic version update by autodist
* Tue Oct 29 2013 Automatic Build System <autodist@mambasoft.it> 4.10.1-1mamba
- automatic version update by autodist
* Sat Apr 06 2013 Automatic Build System <autodist@mambasoft.it> 4.9.6-1mamba
- automatic version update by autodist
* Fri Dec 28 2012 Automatic Build System <autodist@mambasoft.it> 4.9.4-1mamba
- automatic version update by autodist
* Sat Dec 01 2012 Automatic Build System <autodist@mambasoft.it> 4.9.3-1mamba
- automatic version update by autodist
* Wed Oct 10 2012 Automatic Build System <autodist@mambasoft.it> 4.9.2-1mamba
- automatic version update by autodist
* Sat Mar 24 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.9-1mamba
- update to 4.9
* Tue Aug 02 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.8-1mamba
- update to 4.8.8
* Sat Apr 09 2011 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 4.8.7-2mamba
- added italian description
* Tue Jan 25 2011 gil <puntogil@libero.it> 4.8.7-1mamba
- update to 4.8.7
* Fri Sep 24 2010 Automatic Build System <autodist@mambasoft.it> 4.8.6-1mamba
- automatic update to 4.8.6 by autodist
* Sat Jun 26 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.4-2mamba
- change include dir suffix from /nspr4 to /nspr as required by xulrunner > 1.9.2.4
* Sun Apr 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.4-1mamba
- update to 4.8.4
* Thu Aug 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8-2mamba
- specfile changes to fix pkgconfig file (fixes OpenOffice build)
* Wed Jul 01 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8-1mamba
- update to 4.8
* Mon Mar 09 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.7.3-1mamba
- update to 4.7.3
* Sat May 31 2008 gil <puntogil@libero.it> 4.7.1-1mamba
- update to 4.7.1
- removed patch
- replaced make real_install with %makeinstall
* Thu Apr 05 2007 Davide Madrisan <davide.madrisan@gmail.com> 4.6.5-2mamba
- fixed the underquoted definition of AM_PATH_NSPR in nspr.m4
* Wed Jan 31 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 4.6.5-1qilnx
- update to version 4.6.5 by autospec
* Tue Jan 16 2007 Davide Madrisan <davide.madrisan@qilinux.it> 4.6.4-2qilnx
- add nspr.cp file for pkg-config
* Mon Jan 15 2007 Davide Madrisan <davide.madrisan@qilinux.it> 4.6.4-1qilnx
- package created by autospec

2
nspr-config-vars.in Normal file
View File

@ -0,0 +1,2 @@
ldflags=@LDFLAGS@
os_libs=@OS_LIBS@

12
nspr.pc.in Normal file
View File

@ -0,0 +1,12 @@
ldflags=
os_libs=-lpthread -ldl
prefix=%prefix%
exec_prefix=%exec_prefix%
libdir=%libdir%
includedir=%includedir%
Name: NSPR
Description: The Netscape Portable Runtime
Version: %NSPR_VERSION%
Libs: -L/usr/lib -lplds4 -lplc4 -lnspr4 -lpthread -ldl
Cflags: -I${includedir}