automatic version update by autodist [release 1.1.4-1mamba;Fri May 31 2013]
This commit is contained in:
parent
9970053166
commit
cb6cca0b16
@ -1,2 +1,5 @@
|
|||||||
# libnl1
|
# libnl1
|
||||||
|
|
||||||
|
libnl is a library for applications dealing with netlink sockets.
|
||||||
|
The library provides an interface for raw netlink messaging and various netlink family specific interfaces.
|
||||||
|
|
||||||
|
13
libnl-1.1-glibc-2.8.patch
Normal file
13
libnl-1.1-glibc-2.8.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
--- libnl-1.1/include/netlink-local.h.orig 2008-06-08 19:09:20.000000000
|
||||||
|
+0200
|
||||||
|
+++ libnl-1.1/include/netlink-local.h 2008-06-08 19:09:33.000000000 +0200
|
||||||
|
@@ -26,6 +26,7 @@
|
||||||
|
#include <sys/socket.h>
|
||||||
|
#include <inttypes.h>
|
||||||
|
#include <assert.h>
|
||||||
|
+#include <limits.h>
|
||||||
|
|
||||||
|
#include <arpa/inet.h>
|
||||||
|
#include <netdb.h>
|
||||||
|
|
||||||
|
|
15
libnl-1.1-vlan_flags.patch
Normal file
15
libnl-1.1-vlan_flags.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff -Nru libnl-1.1.orig//lib/route/link/vlan.c libnl-1.1/lib/route/link/vlan.c
|
||||||
|
--- libnl-1.1.orig//lib/route/link/vlan.c 2010-04-30 17:34:00.305578537 +0200
|
||||||
|
+++ libnl-1.1/lib/route/link/vlan.c 2010-04-30 17:34:29.563827551 +0200
|
||||||
|
@@ -28,9 +28,11 @@
|
||||||
|
|
||||||
|
#include <linux/if_vlan.h>
|
||||||
|
|
||||||
|
+#ifndef _LINUX_IF_VLAN_H_
|
||||||
|
enum vlan_flags {
|
||||||
|
VLAN_FLAG_REORDER_HDR = 0x1,
|
||||||
|
};
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/** @cond SKIP */
|
||||||
|
#define VLAN_HAS_ID (1<<0)
|
14
libnl-1.1-vlan_include_fix.patch
Normal file
14
libnl-1.1-vlan_include_fix.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -Nru libnl-1.1.orig/lib/route/link/vlan.c libnl-1.1/lib/route/link/vlan.c
|
||||||
|
--- libnl-1.1.orig/lib/route/link/vlan.c 2008-01-14 16:48:45.000000000 +0100
|
||||||
|
+++ libnl-1.1/lib/route/link/vlan.c 2008-05-11 14:05:11.000000000 +0200
|
||||||
|
@@ -28,6 +28,10 @@
|
||||||
|
|
||||||
|
#include <linux/if_vlan.h>
|
||||||
|
|
||||||
|
+enum vlan_flags {
|
||||||
|
+ VLAN_FLAG_REORDER_HDR = 0x1,
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
/** @cond SKIP */
|
||||||
|
#define VLAN_HAS_ID (1<<0)
|
||||||
|
#define VLAN_HAS_FLAGS (1<<1)
|
97
libnl1.spec
Normal file
97
libnl1.spec
Normal file
@ -0,0 +1,97 @@
|
|||||||
|
Name: libnl1
|
||||||
|
Version: 1.1.4
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A library for applications dealing with netlink sockets
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://people.suug.ch/~tgr/libnl/
|
||||||
|
Source: http://people.suug.ch/%7Etgr/libnl/files/libnl-%{version}.tar.gz
|
||||||
|
Patch0: libnl-1.1-vlan_include_fix.patch
|
||||||
|
Patch1: libnl-1.1-glibc-2.8.patch
|
||||||
|
Patch2: libnl-1.1-vlan_flags.patch
|
||||||
|
License: LGPL
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
libnl is a library for applications dealing with netlink sockets.
|
||||||
|
The library provides an interface for raw netlink messaging and various netlink family specific interfaces.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
libnl is a library for applications dealing with netlink sockets.
|
||||||
|
The library provides an interface for raw netlink messaging and various netlink family specific interfaces.
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n libnl-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
#fix permissions
|
||||||
|
chmod 644 ChangeLog COPYING
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
##fix permissions
|
||||||
|
#chmod 755 %{buildroot}%{_libdir}/libnl.so.?.?
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libnl.so.*
|
||||||
|
%doc COPYING ChangeLog
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/netlink
|
||||||
|
%{_includedir}/netlink/*.h
|
||||||
|
%dir %{_includedir}/netlink/fib_lookup
|
||||||
|
%{_includedir}/netlink/fib_lookup/*.h
|
||||||
|
%dir %{_includedir}/netlink/route
|
||||||
|
%dir %{_includedir}/netlink/route/cls
|
||||||
|
%{_includedir}/netlink/route/cls/*.h
|
||||||
|
%dir %{_includedir}/netlink/route/sch
|
||||||
|
%{_includedir}/netlink/route/sch/*.h
|
||||||
|
%{_includedir}/netlink/route/*.h
|
||||||
|
%dir %{_includedir}/netlink/genl
|
||||||
|
%{_includedir}/netlink/genl/*.h
|
||||||
|
%{_libdir}/libnl.a
|
||||||
|
%{_libdir}/libnl.so
|
||||||
|
%{_libdir}/pkgconfig/libnl-1.pc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri May 31 2013 Automatic Build System <autodist@mambasoft.it> 1.1.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Oct 04 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1-4mamba
|
||||||
|
- rebuilt as legacy package
|
||||||
|
|
||||||
|
* Fri Apr 30 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1-3mamba
|
||||||
|
- added patches to build with current glibc and kernel headers
|
||||||
|
|
||||||
|
* Mon Aug 25 2008 Aleph0 <aleph0@openmamba.org> 1.1-2mamba
|
||||||
|
- fix wrong file permissions
|
||||||
|
- update dynamic linker cache
|
||||||
|
|
||||||
|
* Sun May 11 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1-1mamba
|
||||||
|
- update to 1.1
|
||||||
|
|
||||||
|
* Thu Mar 08 2007 Silvan Calarco <silvan.calarco@mambasoft.it> pre6-1qilnx
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user