automatic version update by autodist [release 3.2.24-1mamba;Fri Mar 07 2014]
This commit is contained in:
parent
05347661f4
commit
402dad14a2
@ -1,2 +1,5 @@
|
||||
# libnl
|
||||
|
||||
libnl is a library for applications dealing with netlink sockets.
|
||||
The library provides an interface for raw netlink messaging and various netlink family specific interfaces.
|
||||
|
||||
|
13
libnl-1.1-glibc-2.8.patch
Normal file
13
libnl-1.1-glibc-2.8.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- libnl-1.1/include/netlink-local.h.orig 2008-06-08 19:09:20.000000000
|
||||
+0200
|
||||
+++ libnl-1.1/include/netlink-local.h 2008-06-08 19:09:33.000000000 +0200
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <sys/socket.h>
|
||||
#include <inttypes.h>
|
||||
#include <assert.h>
|
||||
+#include <limits.h>
|
||||
|
||||
#include <arpa/inet.h>
|
||||
#include <netdb.h>
|
||||
|
||||
|
15
libnl-1.1-vlan_flags.patch
Normal file
15
libnl-1.1-vlan_flags.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -Nru libnl-1.1.orig//lib/route/link/vlan.c libnl-1.1/lib/route/link/vlan.c
|
||||
--- libnl-1.1.orig//lib/route/link/vlan.c 2010-04-30 17:34:00.305578537 +0200
|
||||
+++ libnl-1.1/lib/route/link/vlan.c 2010-04-30 17:34:29.563827551 +0200
|
||||
@@ -28,9 +28,11 @@
|
||||
|
||||
#include <linux/if_vlan.h>
|
||||
|
||||
+#ifndef _LINUX_IF_VLAN_H_
|
||||
enum vlan_flags {
|
||||
VLAN_FLAG_REORDER_HDR = 0x1,
|
||||
};
|
||||
+#endif
|
||||
|
||||
/** @cond SKIP */
|
||||
#define VLAN_HAS_ID (1<<0)
|
14
libnl-1.1-vlan_include_fix.patch
Normal file
14
libnl-1.1-vlan_include_fix.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -Nru libnl-1.1.orig/lib/route/link/vlan.c libnl-1.1/lib/route/link/vlan.c
|
||||
--- libnl-1.1.orig/lib/route/link/vlan.c 2008-01-14 16:48:45.000000000 +0100
|
||||
+++ libnl-1.1/lib/route/link/vlan.c 2008-05-11 14:05:11.000000000 +0200
|
||||
@@ -28,6 +28,10 @@
|
||||
|
||||
#include <linux/if_vlan.h>
|
||||
|
||||
+enum vlan_flags {
|
||||
+ VLAN_FLAG_REORDER_HDR = 0x1,
|
||||
+};
|
||||
+
|
||||
/** @cond SKIP */
|
||||
#define VLAN_HAS_ID (1<<0)
|
||||
#define VLAN_HAS_FLAGS (1<<1)
|
138
libnl.spec
Normal file
138
libnl.spec
Normal file
@ -0,0 +1,138 @@
|
||||
Name: libnl
|
||||
Version: 3.2.24
|
||||
Release: 1mamba
|
||||
Summary: A library for applications dealing with netlink sockets
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://people.suug.ch/~tgr/libnl/
|
||||
Source: http://people.suug.ch/%7Etgr/libnl/files/libnl-%{version}.tar.gz
|
||||
Patch0: %{name}-1.1-vlan_include_fix.patch
|
||||
Patch1: %{name}-1.1-glibc-2.8.patch
|
||||
Patch2: %{name}-1.1-vlan_flags.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
libnl is a library for applications dealing with netlink sockets.
|
||||
The library provides an interface for raw netlink messaging and various netlink family specific interfaces.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
libnl is a library for applications dealing with netlink sockets.
|
||||
The library provides an interface for raw netlink messaging and various netlink family specific interfaces.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
#fix permissions
|
||||
chmod 644 ChangeLog COPYING
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%dir %{_sysconfdir}/libnl
|
||||
%config %{_sysconfdir}/libnl/classid
|
||||
%config %{_sysconfdir}/libnl/pktloc
|
||||
%{_sbindir}/genl-ctrl-list
|
||||
%{_sbindir}/nl-*
|
||||
%{_libdir}/libnl*.so.*
|
||||
%dir %{_libdir}/libnl
|
||||
%{_libdir}/libnl/*
|
||||
%{_mandir}/man8/nl-*.8.*
|
||||
%{_mandir}/man8/genl-ctrl-list.8.*
|
||||
%doc COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libnl*.a
|
||||
%{_libdir}/libnl*.la
|
||||
%{_libdir}/libnl*.so
|
||||
%dir %{_includedir}/libnl3
|
||||
%{_includedir}/libnl3/*
|
||||
%{_libdir}/pkgconfig/libnl-3.0.pc
|
||||
%{_libdir}/pkgconfig/libnl-cli-3.0.pc
|
||||
%{_libdir}/pkgconfig/libnl-genl-3.0.pc
|
||||
%{_libdir}/pkgconfig/libnl-nf-3.0.pc
|
||||
%{_libdir}/pkgconfig/libnl-route-3.0.pc
|
||||
%doc ChangeLog
|
||||
|
||||
%changelog
|
||||
* Fri Mar 07 2014 Automatic Build System <autodist@mambasoft.it> 3.2.24-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Nov 01 2013 Automatic Build System <autodist@mambasoft.it> 3.2.23-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed May 15 2013 Automatic Build System <autodist@mambasoft.it> 3.2.22-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Feb 18 2013 Automatic Build System <autodist@mambasoft.it> 3.2.21-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jan 23 2013 Automatic Build System <autodist@mambasoft.it> 3.2.20-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jan 19 2013 Automatic Build System <autodist@mambasoft.it> 3.2.19-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jan 13 2013 Automatic Build System <autodist@mambasoft.it> 3.2.18-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Dec 08 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.16-1mamba
|
||||
- update to 3.2.16
|
||||
|
||||
* Sun Nov 25 2012 Automatic Build System <autodist@mambasoft.it> 3.2.15-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Oct 30 2012 Automatic Build System <autodist@mambasoft.it> 3.2.14-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Sep 14 2012 Automatic Build System <autodist@mambasoft.it> 3.2.13-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Aug 07 2012 Automatic Build System <autodist@mambasoft.it> 3.2.11-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Oct 03 2011 Automatic Build System <autodist@mambasoft.it> 3.2.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jul 24 2011 Automatic Build System <autodist@mambasoft.it> 3.0-1mamba
|
||||
- automatic update to 3.0.3.0 by autodist
|
||||
|
||||
* Fri Apr 30 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1-3mamba
|
||||
- added patches to build with current glibc and kernel headers
|
||||
|
||||
* Mon Aug 25 2008 Aleph0 <aleph0@openmamba.org> 1.1-2mamba
|
||||
- fix wrong file permissions
|
||||
- update dynamic linker cache
|
||||
|
||||
* Sun May 11 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1-1mamba
|
||||
- update to 1.1
|
||||
|
||||
* Thu Mar 08 2007 Silvan Calarco <silvan.calarco@mambasoft.it> pre6-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user