automatic version update by autodist [release 0.1.15-1mamba;Sat Feb 02 2019]
This commit is contained in:
parent
29cfb35ef4
commit
217847c25d
31
libnice-0.1.15-arm-upsteam-fix_memory_alignment.patch
Normal file
31
libnice-0.1.15-arm-upsteam-fix_memory_alignment.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
From 603ab1d45d0103fc51031152a10ddbdaf7dadf86 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jakub Adam <jakub.adam@collabora.com>
|
||||||
|
Date: Thu, 3 Jan 2019 09:50:25 +0100
|
||||||
|
Subject: [PATCH] udp-turn: Fix unaligned memory access on ARM
|
||||||
|
|
||||||
|
---
|
||||||
|
socket/udp-turn.c | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/socket/udp-turn.c b/socket/udp-turn.c
|
||||||
|
index bf81fd9c..1bc5e031 100644
|
||||||
|
--- a/socket/udp-turn.c
|
||||||
|
+++ b/socket/udp-turn.c
|
||||||
|
@@ -362,7 +362,7 @@ socket_recv_messages (NiceSocket *sock,
|
||||||
|
guint f_buffer_len = priv->fragment_buffer->len;
|
||||||
|
|
||||||
|
for (i = 0; i < n_recv_messages && f_buffer_len >= sizeof (guint16); ++i) {
|
||||||
|
- guint16 msg_len = ntohs (*(guint16 *)f_buffer) + sizeof (guint16);
|
||||||
|
+ guint16 msg_len = ((f_buffer[0] << 8) | f_buffer[1]) + sizeof (guint16);
|
||||||
|
|
||||||
|
if (msg_len > f_buffer_len) {
|
||||||
|
/* The next message in the buffer isn't complete yet. Wait for more
|
||||||
|
@@ -452,7 +452,7 @@ socket_recv_messages (NiceSocket *sock,
|
||||||
|
* return. */
|
||||||
|
guint16 msg_len = 0;
|
||||||
|
if (!priv->fragment_buffer) {
|
||||||
|
- msg_len = ntohs (*(guint16 *)buffer) + sizeof (guint16);
|
||||||
|
+ msg_len = ((buffer[0] << 8) | buffer[1]) + sizeof (guint16);
|
||||||
|
if (msg_len > parsed_buffer_length) {
|
||||||
|
/* The RFC4571 frame is larger than the current TURN message, need to
|
||||||
|
* buffer it and wait for more data. */
|
21
libnice.spec
21
libnice.spec
@ -1,5 +1,5 @@
|
|||||||
Name: libnice
|
Name: libnice
|
||||||
Version: 0.1.14
|
Version: 0.1.15
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: An implementation of the IETF's draft Interactice Connectivity Establishment standard (ICE)
|
Summary: An implementation of the IETF's draft Interactice Connectivity Establishment standard (ICE)
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -8,6 +8,7 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://nice.freedesktop.org/wiki/
|
URL: http://nice.freedesktop.org/wiki/
|
||||||
Source: http://nice.freedesktop.org/releases/libnice-%{version}.tar.gz
|
Source: http://nice.freedesktop.org/releases/libnice-%{version}.tar.gz
|
||||||
|
Patch0: libnice-0.1.15-arm-upsteam-fix_memory_alignment.patch
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libffi-devel
|
BuildRequires: libffi-devel
|
||||||
@ -45,11 +46,15 @@ Existing standards that use ICE include Session Initiation Protocol (SIP) and XM
|
|||||||
This package contains static libraries and header files need for development.
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
|
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure \
|
||||||
|
%ifarch arm
|
||||||
|
CFLAGS="-Wno-error=cast-align"
|
||||||
|
%endif
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -68,7 +73,6 @@ This package contains static libraries and header files need for development.
|
|||||||
%{_bindir}/stund
|
%{_bindir}/stund
|
||||||
%{_libdir}/libnice.so.*
|
%{_libdir}/libnice.so.*
|
||||||
%{_libdir}/girepository-1.0/Nice-0.1.typelib
|
%{_libdir}/girepository-1.0/Nice-0.1.typelib
|
||||||
%{_libdir}/girepository-1.0/Nice-0.1.typelib
|
|
||||||
%{_libdir}/gstreamer-0.10/libgstnice010.la
|
%{_libdir}/gstreamer-0.10/libgstnice010.la
|
||||||
%{_libdir}/gstreamer-0.10/libgstnice010.so
|
%{_libdir}/gstreamer-0.10/libgstnice010.so
|
||||||
%{_libdir}/gstreamer-1.0/libgstnice.la
|
%{_libdir}/gstreamer-1.0/libgstnice.la
|
||||||
@ -77,9 +81,9 @@ This package contains static libraries and header files need for development.
|
|||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/sdp-example
|
#%{_bindir}/sdp-example
|
||||||
%{_bindir}/simple-example
|
#%{_bindir}/simple-example
|
||||||
%{_bindir}/threaded-example
|
#%{_bindir}/threaded-example
|
||||||
%{_libdir}/libnice.la
|
%{_libdir}/libnice.la
|
||||||
%{_libdir}/libnice.so
|
%{_libdir}/libnice.so
|
||||||
%dir %{_includedir}/nice
|
%dir %{_includedir}/nice
|
||||||
@ -95,6 +99,9 @@ This package contains static libraries and header files need for development.
|
|||||||
%doc NEWS README TODO
|
%doc NEWS README TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Feb 02 2019 Automatic Build System <autodist@mambasoft.it> 0.1.15-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Fri Apr 07 2017 Automatic Build System <autodist@mambasoft.it> 0.1.14-1mamba
|
* Fri Apr 07 2017 Automatic Build System <autodist@mambasoft.it> 0.1.14-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user