update to 1.1.6 [release 1.1.6-1mamba;Sat Dec 01 2012]
This commit is contained in:
parent
a201d8543f
commit
bf864c8fcb
@ -1,2 +1,8 @@
|
||||
# libnet
|
||||
|
||||
Libnet is a high-level API (toolkit) allowing the application programmer to construct and inject network packets.
|
||||
It provides a portable and simplified interface for low-level network packet shaping, handling and injection.
|
||||
Libnet hides much of the tedium of packet creation from the application programmer such as multiplexing, buffer management, arcane packet header information, byte-ordering, OS-dependent issues, and much more.
|
||||
Libnet features portable packet creation interfaces at the IP layer and link layer, as well as a host of supplementary and complementary functionality.
|
||||
Using libnet, quick and simple packet assembly applications can be whipped up with little effort. With a bit more time, more complex programs can be written.
|
||||
|
||||
|
12
libnet-1.1.4-cross_configure_endianess.patch
Normal file
12
libnet-1.1.4-cross_configure_endianess.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru libnet-1.1.4.orig//configure libnet-1.1.4/configure
|
||||
--- libnet-1.1.4.orig//configure 2009-06-10 01:13:22.000000000 +0200
|
||||
+++ libnet-1.1.4/configure 2010-05-25 13:37:47.359414717 +0200
|
||||
@@ -19724,7 +19724,7 @@
|
||||
elif test $result = "L"; then
|
||||
ac_cv_libnet_endianess=lil
|
||||
else
|
||||
- ac_cv_libnet_endianess=unknown
|
||||
+ ac_cv_libnet_endianess=$ac_cv_libnet_endianess
|
||||
fi
|
||||
fi
|
||||
rm -f conftest* core core.conftest
|
105
libnet.spec
Normal file
105
libnet.spec
Normal file
@ -0,0 +1,105 @@
|
||||
Name: libnet
|
||||
Version: 1.1.6
|
||||
Release: 1mamba
|
||||
Summary: High-level API to construct and inject network packets
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://sourceforge.net/projects/libnet-dev
|
||||
Source: http://downloads.sourceforge.net/project/libnet-dev/libnet-%{version}.tar.gz
|
||||
Patch0: %{name}-1.1.4-cross_configure_endianess.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-build
|
||||
|
||||
%description
|
||||
Libnet is a high-level API (toolkit) allowing the application programmer to construct and inject network packets.
|
||||
It provides a portable and simplified interface for low-level network packet shaping, handling and injection.
|
||||
Libnet hides much of the tedium of packet creation from the application programmer such as multiplexing, buffer management, arcane packet header information, byte-ordering, OS-dependent issues, and much more.
|
||||
Libnet features portable packet creation interfaces at the IP layer and link layer, as well as a host of supplementary and complementary functionality.
|
||||
Using libnet, quick and simple packet assembly applications can be whipped up with little effort. With a bit more time, more complex programs can be written.
|
||||
|
||||
%package devel
|
||||
Summary: High-level API to construct and inject network packets
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Libnet is a high-level API (toolkit) allowing the application programmer to construct and inject network packets.
|
||||
It provides a portable and simplified interface for low-level network packet shaping, handling and injection.
|
||||
Libnet hides much of the tedium of packet creation from the application programmer such as multiplexing, buffer management, arcane packet header information, byte-ordering, OS-dependent issues, and much more.
|
||||
Libnet features portable packet creation interfaces at the IP layer and link layer, as well as a host of supplementary and complementary functionality.
|
||||
Using libnet, quick and simple packet assembly applications can be whipped up with little effort. With a bit more time, more complex programs can be written.
|
||||
This package contains the static library and headers for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure --libdir=/%{_lib} \
|
||||
%if "%{_host}" != "%{_build}"
|
||||
ac_libnet_have_pf_packet=yes \
|
||||
ac_cv_lbl_unaligned_fail=no \
|
||||
ac_cv_libnet_endianess=lil
|
||||
%endif
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
test x"$RPM_BUILD_ROOT" != x/ && rm -rf "$RPM_BUILD_ROOT"
|
||||
%makeinstall
|
||||
install -d -m755 $RPM_BUILD_ROOT%{_mandir}/man3/
|
||||
install -m644 doc/man/man3/libnet-functions.h.3 \
|
||||
$RPM_BUILD_ROOT%{_mandir}/man3/libnet.3
|
||||
install -D -m755 libnet-config %{buildroot}%{_bindir}/libnet-config
|
||||
|
||||
%clean
|
||||
test x"$RPM_BUILD_ROOT" != x/ && rm -rf "$RPM_BUILD_ROOT"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
/%{_lib}/libnet.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/libnet-config
|
||||
%{_includedir}/libnet.h
|
||||
%{_includedir}/libnet/libnet-asn1.h
|
||||
%{_includedir}/libnet/libnet-functions.h
|
||||
%{_includedir}/libnet/libnet-headers.h
|
||||
%{_includedir}/libnet/libnet-macros.h
|
||||
%{_includedir}/libnet/libnet-structures.h
|
||||
%{_includedir}/libnet/libnet-types.h
|
||||
/%{_lib}/libnet.so
|
||||
/%{_lib}/libnet.la
|
||||
/%{_lib}/libnet.a
|
||||
%{_mandir}/man3/libnet.3.gz
|
||||
%{_mandir}/man3/libnet*.h.3.gz
|
||||
%doc doc/CHANGELOG doc/CONTRIB doc/COPYING doc/DESIGN_NOTES doc/MIGRATION
|
||||
%doc doc/PACKET_BUILDING doc/PORTED doc/RAWSOCKET_NON_SEQUITUR doc/TODO
|
||||
%doc doc/html/*.html doc/html/doxygen.png
|
||||
|
||||
%changelog
|
||||
* Sat Dec 01 2012 Automatic Build System <autodist@mambasoft.it> 1.1.6-1mamba
|
||||
- update to 1.1.6
|
||||
|
||||
* Tue May 25 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.4-1mamba
|
||||
- update to 1.1.4
|
||||
- switched to maintained libnet-dev project from sourceforge
|
||||
- added libnet binary package with shared library
|
||||
|
||||
* Fri Jun 13 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.2.1-2mamba
|
||||
- source renamed from libnet-devel to libnet
|
||||
|
||||
* Fri Jul 08 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.2.1-1qilnx
|
||||
- update to version 1.1.2.1 by autospec
|
||||
|
||||
* Mon Feb 02 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.1-1qilnx
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user