update to 5.1.0 [release 5.1.0-1mamba;Sat Aug 22 2020]
This commit is contained in:
parent
e6f4eb0a8e
commit
08180936a3
24
libmusicbrainz-5.1.0-CmakeLists.patch.patch
Normal file
24
libmusicbrainz-5.1.0-CmakeLists.patch.patch
Normal file
@ -0,0 +1,24 @@
|
||||
From 36262d60fe92fe7a2c9bfb40e736bfcd29a6c3bd Mon Sep 17 00:00:00 2001
|
||||
From: Abderrahim Kitouni <a.kitouni@gmail.com>
|
||||
Date: Fri, 13 Apr 2018 09:56:57 +0100
|
||||
Subject: [PATCH] src/CMakelists.txt: do not use wildcards for dependencies
|
||||
|
||||
This is discouraged by cmake's documentation and doesn't work with the ninja generator.
|
||||
---
|
||||
src/CMakeLists.txt | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
||||
index 68c04e3..f7439d3 100644
|
||||
--- a/src/CMakeLists.txt
|
||||
+++ b/src/CMakeLists.txt
|
||||
@@ -37,7 +37,8 @@ ADD_CUSTOM_COMMAND(
|
||||
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/mb5_c.cc ${CMAKE_CURRENT_BINARY_DIR}/mb5_c.h ${CMAKE_CURRENT_BINARY_DIR}/../include/musicbrainz5/mb5_c.h
|
||||
COMMAND make-c-interface ${CMAKE_CURRENT_SOURCE_DIR} cinterface.xml ${CMAKE_CURRENT_BINARY_DIR} mb5_c.cc mb5_c.h
|
||||
COMMAND ${CMAKE_COMMAND} -E copy_if_different ${CMAKE_CURRENT_BINARY_DIR}/mb5_c.h ${CMAKE_CURRENT_BINARY_DIR}/../include/musicbrainz5/mb5_c.h
|
||||
- DEPENDS make-c-interface cinterface.xml *.inc
|
||||
+ DEPENDS make-c-interface cinterface.xml c-int-medium-defines.inc c-int-query-source.inc c-int-source-funcs.inc
|
||||
+ c-int-medium-source.inc c-int-release-defines.inc c-int-query-defines.inc c-int-release-source.inc
|
||||
)
|
||||
|
||||
ADD_CUSTOM_TARGET(src_gen DEPENDS mb5_c.h)
|
@ -1,14 +1,23 @@
|
||||
Name: libmusicbrainz
|
||||
Version: 3.0.3
|
||||
Version: 5.1.0
|
||||
Release: 1mamba
|
||||
Summary: MusicBrainz Client Library
|
||||
Group: System/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@qilinux.it>
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.musicbrainz.org/
|
||||
Source: ftp://ftp.musicbrainz.org/pub/musicbrainz/libmusicbrainz-%{version}.tar.gz
|
||||
Source: https://github.com/metabrainz/libmusicbrainz/releases/download/release-%{version}/libmusicbrainz-%{version}.tar.gz
|
||||
Patch0: libmusicbrainz-5.1.0-CmakeLists.patch.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libneon-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libxml2-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libexpat-devel >= 1.95.6
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-build
|
||||
|
||||
@ -27,8 +36,11 @@ The library allows you to access the data held on the MusicBrainz server.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
@ -46,17 +58,18 @@ This package contains static libraries and header files need for development.
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libmusicbrainz3.so.*
|
||||
%{_libdir}/libmusicbrainz5.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/musicbrainz3/*.h
|
||||
#%{_libdir}/libmusicbrainz3.a
|
||||
#%{_libdir}/libmusicbrainz3.la
|
||||
%{_libdir}/libmusicbrainz3.so
|
||||
%{_libdir}/pkgconfig/libmusicbrainz3.pc
|
||||
%{_includedir}/musicbrainz5/*.h
|
||||
%{_libdir}/libmusicbrainz5.so
|
||||
%{_libdir}/pkgconfig/libmusicbrainz5.pc
|
||||
|
||||
%changelog
|
||||
* Sat Aug 22 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 5.1.0-1mamba
|
||||
- update to 5.1.0
|
||||
|
||||
* Tue Oct 05 2010 Automatic Build System <autodist@mambasoft.it> 3.0.3-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user